Tag/tag.png

Candidate for Deletion
This article may not be appropriate for this wiki, and may be deleted. More info...

Tag/tag.png

Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...

Install Ubuntu Hardy Heron (8.04.1)

Fully functional:

  • Suspend / Resume
  • Video (with desktop effects)
  • Wireless Networking
  • Wired Networking
  • Webcam
  • USB
  • Silent FanSIG
  • Card Readers

Partial Function:

  • Audio - there is sound, issues detailed below

Not Functional:

  • Hibernate on A110L
  • Card Reader power saving
  • wifi power saving
  • wifi kill switch

Step 1: Install Ubuntu

As the Acer Aspire One doesn't have a CD drive you must install with an USB drive or an external CD-ROM drive.

(NOTE: It is also possible to install directly from network, which makes USB devices unneeded. You will still need a network cable and another computer. See: Installation/Netboot or Netinstall via Windows)

Shut down your Aspire One and insert the external USB CD-ROM or the USB stick that we just used. Turn it on and tap F12 to bring up the boot menu.

With a CD-ROM, choose the USB CD-ROM option. With the bootable USB stick created, choose the USB HDD option. This will boot you to the USB CD-ROM/LiveUSB stick, and allow you to install Ubuntu. Install it like normal if you have the hard disk Aspire One. If you have the SDD Aspire One, for good performance and to increase the life of the SSD use a non-journaled filesystem like EXT2.

Step 2: Tweak / Fix

So now we should have an installed Ubuntu system. At this point, if you have not already done, so connect your Aspire One to the internet using a wired connection. First and immediate task is to update, since the wireless driver needs to be reinstalled after every kernel update. Open a terminal (Applications -> Accessories -> Terminal). Perform the updates:

sudo apt-get update
sudo apt-get upgrade

Note: Currently there's an issue updating kernel to 2.6.24-23, as reported in Bug #322867. At the time of writing it seems advisable to keep the kernel back to an earlier version.

WIRELESS:

There are two different ways of configuring the wifi hardware, using either madwifi drivers, or wrapping Windows drivers with ndiswrapper. If you have troubles with one method, try the other.

madwifi

Now we need to disable the hardware drivers that Ubuntu tries to use before the ones we make will function. So go to System -> Administration -> Hardware Drivers and uncheck everything. It should prompt us to reboot, so lets do it now.

We need to grab the wireless driver, and the things we need to build it, from a terminal:

mkdir source
cd source
wget http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6-current.tar.gz
tar -xzvf madwifi-hal-0.10.5.6-current.tar.gz
cd madwifi-hal-0.10.5.6-r3879-20081204
sudo apt-get install build-essential linux-headers-$(uname -r)

And we build and install:

make
sudo make install
sudo modprobe ath_pci

In order to have the wireless work after reboot, add the following line to /etc/modules ("gksudo gedit /etc/modules") to automatically load the module when booting:

ath_pci

You should now have working wireless. However you may want to do the following to prevent problems (the symbol mismatch) when the module is loaded:

Add ath_hal to the DISABLED_MODULES= stanza in /etc/default/linux-restricted-modules-common

(i.e. 'DISABLED_MODULES="ath_hal"')

Every time there is a kernel update you will need to perform the following steps to make the wireless work. Go to the directory (madwifi-hal-0.10.5.6-r3835-20080801) and run:

make clean
make
sudo make install

ndiswrapper

If the above madwifi instructions didn't work for you, using ndiswrapper is an alternative that is known to work, but uses Windows drivers.

Download drivers for your wireless card from: http://download2.dvd-driver.cz/atheros/drivers/ar5008/xp32-6.0.3.85.zip

Unzip those drivers.

Install ndiswrapper, and launch the installer:

sudo aptitude install ndisgtk
sudo ndisgtk

Find the net5416.inf file, and install it.

If you have tried madwifi, unload it with:

madwifi-unload

Restart your AA1, and everything should work.

WIRELESS LED:

To get your awesome wireless led to blink for you based on traffic, put these lines in /etc/rc.local, just above the string exit 0 (below doesn't work).

  • Note: The 2.6.27 kernel does not appear to have these options anymore (earlier kernels do).

sysctl -w dev.wifi0.ledpin=3
sysctl -w dev.wifi0.softled=1

The led on the front will now do the association blink, as well as blink based on wireless traffic.

rc.local may not be executable so

sudo chmod a+x /etc/rc.local 

The wifi kill switch uses these keycodes (also to use in rc.local):

/usr/bin/setkeycodes e055 159
/usr/bin/setkeycodes e056 158

WEBCAM

Install luvcview - USB Video Class grabber

apt-get install luvcview

You may confirm it is recognized

 dmesg |grep -i "uvc"

And this is the repply

[   29.601485] uvcvideo: Found UVC 1.00 device USB 2.0 Camera (0c45:62c0)
[   29.617301] usbcore: registered new interface driver uvcvideo

Say hello to yourself with this command Wink ;)

luvcview -f yuv

CARD READER:

Note: there are problems with the card readers: DO NOT SUSPEND your Aspire One with an SD Card inserted, or you may lose all data on it.

If you want the card readers to be hot-pluggable, you'll need to work through the following modified instructions from http://wiki.debian.org/DebianAcerOne.

Create a file /etc/modprobe.d/aspireone with the following content:

####################################################################
# Module options for the Acer AspireOne
#
# Enable USB card reader
options pciehp pciehp_force=1
install sdhci for i in 2381 2382 2383 2384; do /usr/bin/setpci -d 197b:$i AE=47; done; /sbin/modprobe --ignore-install sdhci

Add the following line to the end of you existing /etc/modules file:

pciehp

You need to reboot to the get the files /etc/modules and /etc/modprobe.d/aspireone read properly. Inserting a SD card should then result in HAL finding the card and placing icon on the desktop automagically.

Note there are still a few problems with this setup:

  • If you first insert a card in the left card reader, both card readers will be hot pluggable. However, if you first insert a card in the right card reader, the left card reader will not be available until reboot.
  • MemorySticks won't work in the right multi-card reader. This may be a kernel module limitation.

A script to poll the card reader for power events (AC unplugged, etc.) is included on the recovery DVD shipped with the machine within the "hdc1._.tar.bz2" archive as /usr/sbin/jmb38x_d3e.sh. This script runs once every 5 minutes and adjusts the power level depending on the system power state.

The script is also available from the petaramesh site. Download it, make it executable and copy it to /usr/local/sbin with:

wget http://petaramesh.org/public/arc/projects/AcerOne_Ubuntu/jmb38x_d3e.sh
sudo chmod 754 jmb38x_d3e.sh
sudo mv jmb38x_d3e.sh /usr/local/sbin/

To use the script add a line like:

/usr/local/sbin/jmb38x_d3e.sh &>/var/log/jmb38x_d3e.log &

to rc.local before exit 0. Next time you reboot this script will be running (or you can execute it in a terminal now as root).

The script generates lots of harmless warning messages, so we send the output messages to a log file.

The card readers are identified as /dev/mmcblk0 and /dev/mmcblk1. Partitions on them are labeled, for example /dev/mmcblk0p1.

USB MOUNT:

(Do this step only if you get an error inserting a USB stick)

If you insert a memory key, you may notice an error and that it cannot be mounted. This is due to the CD-ROM entry in the fstab. Since we don't have an optical drive on the One we will comment that out. From a terminal again:

gksudo gedit /etc/fstab

You should see a line that looks like:

/dev/sdb        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0

add a hash in front:

#/dev/sdb        /media/cdrom0   udf,iso9660 user,noauto,exec 0       0

Reboot, and automount should work.

NOISE (FAN CONTROL)

(10/09/09) This is an update to the following fan control section below. The user space script "acerfand" originaly used to fix the noisy fan problem can cause race conditions and lockups as it accesses registers asynchronous to the kernel. A kernel module to do the fan control has recently been created and this avoids the race condition problem.

You can install the kernel module in the following way. These instructions also work for 8.10.

wget http://piie.net/files/acerhdf_kmod-0.2.2-2.tar.gz
tar -zxvf acerhdf_kmod-0.2.2-2.tar.gz
cd acerhdf_kmod
make
sudo make install

Now load the kernel module using

sudo modprobe acerhdf

check it worked by looking in your message log

tail /var/log/messages

Feb 19 01:25:42 mythtv kernel: [106628.078100] acerhdf: version: 0.2 compiledate: Feb 19 2009 01:25:21
Feb 19 01:25:42 mythtv kernel: [106628.078116] acerhdf: biosvendor:Acer
Feb 19 01:25:42 mythtv kernel: [106628.078125] acerhdf: biosversion:v0.3309
Feb 19 01:25:42 mythtv kernel: [106628.078134] acerhdf: biosrelease:10/06/2008
Feb 19 01:25:42 mythtv kernel: [106628.078143] acerhdf: biosproduct:AOA150
Feb 19 01:25:42 mythtv kernel: [106628.078850] acerhdf: Temperature is: 49

To make sure it loads at boot time add acerhdf to /etc/modules

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

fuse
lp
ath_pci
acerhdf

For further information on the kernel module see http://www.piie.net/index.php?section=acerhdf

I am leaving the old acerfand perl instructions below for reference, but it is advisable not to use this method.


Aspire One by default commonly doesn't manage Fan speed correctly, resulting in a very noisy AA0.

Note: On A150X with a 160gb hd and 6 cell battery the perl script returns 0ºC every time, because the thermal control is not working. This causes the fan to shutdown. It could DAMAGE your system severely. Please check that the script is returning the correct values manually before applying the daemon.

Solution:

  • Ensure you have dmidecode installed, so acerfand can detect which bios version you have. It's probably installed by default already. If not, execute:

 sudo aptitude install dmidecode
  • Download the acer_ec.pl script (Direct download).

  • Download the acerfand daemon script (Direct download). (New version (0.07 2009-03-14) fixed bug for detecting what the current fan control state is in bios 3309, which was causing it to unnecessarily repeatedly switch off the fan (in my case; may also have been causing problems others have seen) and spam the logs about it keeping my hard drive alive.)

  • (You can check whether the scripts shows a reasonable cpu temperature (in hex) as follows:)

 perl acer_ec.pl ?= 58
  • Execute these lines in a terminal in the directory you downloaded the above scripts:

 chmod a+x acerfand
 sudo cp acer_ec.pl acerfand /usr/local/bin/
  • To run it straight away:

 sudo acerfand
  • Note, you need the correct bios for this to work correctly. To see if the acerfand script is working, you can check the system log after you have run the *sudo acerfand* command:

#sudo tail -f /var/log/syslog
Oct  9 02:04:36 lilput acerfand: acerfand 0.03 starting
Oct  9 02:04:36 lilput acerfand: Detected bios version v0.3301
Oct  9 02:04:36 lilput acerfand: Unsupported bios version v0.3301 found. Aborting.
  • To run it at boot:

 gksudo gedit /etc/rc.local

Insert the following line above the exit 0 at the bottom:

 /usr/local/bin/acerfand

The fan is not completely disabled. When the FANAUTO temperature is reached (70ºC), fan works again. According to Intel, the Atom chip could work until 99ºC.

Optional: Above instructions will work fine, but if you want to define another temperature:

  • Create an /etc/acerfand.conf file. The file is just a shell script that sets up to three values. eg:

INTERVAL=5
FANOFF=60
FANAUTO=70

Those are the default values, if the /etc/acerfand.conf file isn't found.

INTERVAL is the polling interval in seconds

FANOFF is the temperature (in Celsius Degrees) at or below which to turn the fan off, if it's currently on auto

FANAUTO is the temperature (in Celsius Degrees) at or above which to turn the fan to auto, if it's currently off

More information from the original source, AspireOne Wiki.

OPTIMIZING SSD PERFORMANCE:

  • Note: (Skip this step if you have the hard disk Acer Aspire One)

The performance of the SSD drive can be significantly improved by a few tweaks described in an article by Jason Perlow (But ignore Tweak #1, which does not apply.). The most important of these are described here.

Change the file system mount options on SSDs to “noatime”

Edit /etc/fstab (gksudo gedit /etc/fstab) and change the the option “relatime” to “noatime”. The line for the root partition should then be something like:

UUID=f0ae2c59-83d2-42e7-81c4-2e870b6b255d / ext2 noatime,errors=remount-ro 0 1

Use the “noop” I/O scheduler

Edit /boot/grub/menu.lst using your favorite editor, and add "elevator=noop" as an option. The default kernel configuration, found in the last part of the file should be something like:

title           Ubuntu 8.04.1, kernel 2.6.24-19-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.24-19-generic root=UUID=f0ae2c59-83d2-42e7-81c4-2e870b6b255d ro quiet splash elevator=noop
initrd          /boot/initrd.img-2.6.24-19-generic
quiet

In order for the changes to remain when updating the kernel, also in menu.lst, find the line

# defoptions=quiet splash

and add "elevator=noop" as an option:

# defoptions=elevator=noop quiet splash

REDUCING SSD WEAR:

  • Note: (Skip this step if you have the hard disk Acer Aspire One)

Frequent writes to the SSD will cause failure eventually. We can reduce the number of writes to the SSD by moving our logs to a temporary filesystem in RAM that gets destroyed at ever reboot. Now this means your logs will not be persistent across reboots making debugging difficult in some cases. This step is optional of course, so if you need the logs for an extended period of time do not follow these steps.

Open your fstab again, and add the following lines:

gksudo gedit /etc/fstab
tmpfs      /var/log        tmpfs        defaults           0    0
tmpfs      /tmp            tmpfs        defaults           0    0
tmpfs      /var/tmp        tmpfs        defaults           0    0

There is currently a bug in sysklogd where it cannot handle booting with an empty /var/log directory (bug #290127). This can be fixed by modifying /etc/init.d/sysklogd:

Find this function:

fix_log_ownership()
        for l in `syslogd-listfiles -a`
        do
                chown ${USER}:adm $l
        done
}

..and replace it with this:

fix_log_ownership()
{
        for l in `syslogd-listfiles -a --news`
        do
                # Create directory for logfile if required
                ldir=$(echo ${l} | sed  's/[^\/]*$//g')
                if [ ! -e $ldir ] ; then
                        mkdir -p $ldir
                fi
                # Touch logfile and chown
                touch $l && chown ${USER}:adm $l
        done
}

Warning: this will cause some packages to fail mysteriously when they cannot access the log directories that were installed with the packages and then disappeared at reboot.

To rebuild the rest of the directory structure inside /var/log on each reboot, add these lines to /etc/rc.local above the 'exit 0' line:

for dir in apparmor apt ConsoleKit cups dist-upgrade fsck gdm installer news ntpstats samba unattended-upgrades ; do
        if [ ! -e /var/log/$dir ] ; then
                mkdir /var/log/$dir
        fi
done

Note: discovered ATA 40-wire cable misdetection after resume (currently 2.6.27), causing hdparm down from 40MB/s to 25MB/s: filed http://bugzilla.kernel.org/show_bug.cgi?id=11879 for this issue -AndiM

Note: you may have to specify more directories if you have applications which use them, check the contents of /var/log/ for directories before rebooting/deleting them.

DISABLE SCROLLKEEPER:

(Skip this step if you have the hard disk Acer Aspire One)

ScrollKeeper is a cataloging system for documentation on open systems. Hardly anyone ever uses it and on the AAO's slow SSD it takes ages every time you install anything. Disable it and your installs will fly! Finally add a diversion to stop dpkg from overwriting your changes.

sudo mv /usr/bin/scrollkeeper-update /usr/bin/scrollkeeper-update.real
sudo ln -s /bin/true /usr/bin/scrollkeeper-update
sudo find /var/lib/scrollkeeper/ -name \*.xml -type f -exec rm -f '{}' \;
sudo dpkg-divert --local --divert /usr/bin/scrollkeeper-update.real --add /usr/bin/scrollkeeper-update

VIDEO AND 3D PERFORMANCE: (Optional)

Out of the box, the graphic card Intel GMA 950, is well detected, however you can tweak /etc/X11/xorg.conf to achieve better graphic card performance:

Section "Device"
(...)
        Option "MonitorLayout" "LVDS,VGA"
        Option "Clone" "true"
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
        VideoRam       229376
        Option "CacheLines" "1980"
EndSection

The Option Clone is especially usefull, if you want to capture video or photos. Without it you will get a black screen on applications like cheese.

Also add this to your /etc/profile:

export INTEL_BATCH=1

Note: 'export INTEL_BATCH=1' appears to causes graphics faults (artifacts) within 'ume-launcher' (even with Compiz fully disabled).

Reboot and you will have a more responsive system, with better 3D FPS, and improved video performance.

AUDIO:

Out of the box there are various issues with the sound. These range from headphone detection not functioning correctly, to the internal MIC not working. There are solutions to these problems. Currently, however, there is no known way to get everything working at once. All of the steps begin the same way, rebuilding ALSA:

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa
sudo alsa force-unload
sudo depmod -ae
sudo modprobe snd-hda-intel

Add the following line to the end of /etc/modules in order to ensure that the module is loaded during bootup:

snd-hda-intel

Now we need to make a choice. To have the internal MIC non-functional (external works), but sound working after suspend and resume, we edit /etc/modprobe.d/alsa-base (gksudo gedit /etc/modprobe.d/alsa-base) and add the following line to the bottom:

options snd-hda-intel model=toshiba

Reboot for that to take effect.

To have the internal MIC function correctly, but no sound after suspending and resuming the computer add or change the following to the /etc/modprobe.d/alsa-base as before:

options snd-hda-intel model=auto

Again, reboot for this to take effect.

For some unknown reason some people don't hear any sound with either option. If you experience this problem you might want to use the option in /etc/modprobe.d/alsa-base as before to the following to resolve this problem:

options snd-hda-intel model=acer

For A150L, model=basic seems to work fine with alsa 1.018rc3 (internal mic and sound work after suspend; plugging headphone in does turn the speakers off)

options snd-hda-intel model=basic

According to the ArchWiki alsa version 1.018 and up contains a new dedicated audio model option for the Acer aspire one that can be used instead:

options snd-hda-intel model=acer-aspire

If you experience crackling sound after rebooting, insert the following line in /etc/modprobe.d/blacklist:

blacklist snd_pcsp

Optional: The default sound level is low. Open a terminal and type alsamixer to adjust volume.

Alsa needs to be version 1.0.17.

Alternative Method for upgrading ALSA and settings

There is a script available at http://ubuntuforums.org/showthread.php?t=962695 This will currently upgrade ALSA to 1.0.17 or 1.0.18final (IBEX comes with version 1.0.17 by default) Tweak the configuration as suggested above

options snd-hda-intel model=acer

Why do it this way? because it works it fetches the required tools and source builds and installs it all in one step leaving you with just the configuration steps needed specifically for the Aspire One. Why not do it this way? It can overwrite system settings and files without giving you any choice in the matter. See the link for details and this is not recommended practice. Your Aspire One, your choice.

Note The script at the beginning of the thread given by the Link appears to be broken, on page 2 is another version for 1.0.18 by the same author which may work, however also on that page is a link for a script which will install 1.0.18r3 http://ubuntuforums.org/showpost.php?p=6090951&postcount=16 That does work fine.

Retaining Mixer Settings

There is an issue with retaining the audio settings in Hardy You configure the mixer so sound input is internal mic, on reboot it is reset to mic. The desktop applet doesn't have a save settings option. so use it to configure your audio then open a terminal and type

sudo alsactl store

however on reboot you will find your settings are gone again

sudo alsactl restore

will retrieve your settings. (this section is incomplete and needs details for restoring the alsa settings automatically on boot) http://ubuntuforums.org/showthread.php?t=962695 is currently at version 1.15 and can be downloaded here

http://ubuntuforums.org/attachment.php?attachmentid=96599&d=1229445232 there are a couple of options how to use the script with intrepid running with the options -di should work, for older kernel versions 2.6.24.x there is a compilation error but snapshots work so sudo ./AlsaUpgrade-1.0.x-rev-1.15.sh -d sudo ./AlsaUpgrade-1.0.x-rev-1.15.sh -snap (2.6.24.x kernels e.g hardy) sudo ./AlsaUpgrade-1.0.x-rev-1.15.sh -i

using model=acer-aspire seems to give good results and use of the above script ensures mixer settings are restored after a reboot.

Screen Tweaks

TWEAKS TO MAKE BETTER USE OF THE ASPIRE ONE'S SMALL SCREEN:

There are various methods that will help you make better use of the Aspire One's small screen. One of the most important is being able to move windows that are too large to fit on the screen at once. To move a hidden part of the window into view, click and drag with the left mouse button on any part of the window while holding down the ALT key. However, you won't be able to drag windows so the top of the window is above the top of the screen. To fix that, enter the following in a terminal window:

gconftool-2 --set /apps/compiz/plugins/move/allscreens/options/constrain_y --type bool 0

Since the Aspire One's screen has almost twice as much resolution horizontally as vertically, having panels on both the top and bottom is not ideal. You may want to remove the top or bottom panels, make them smaller, or move them so that they are vertical, on the left and right side, instead of horizontal on top and bottom.

TOUCHPAD TWEAKS:

The AAO touchpad is quite easy to bump whilst typing. The best fix is to disable all scroll and tap commands for 1 second after each keystroke.

Go to Preferences and select "Sessions". Click the add button and add an entry:

Name: Syndaemon
Command: syndaemon -d -t -i 1
Comment: Disable trackpad while typing

The '1' can be changed to any decimal number, and defines the amount of time to lock the trackpad after each keystroke. See the Syndaemon man page for full details.

Another option is to go to System->Preferences->Mouse->Touchpad and choose the options you prefer.

Start/Resume

HIBERNATE:

In some set-ups, using hibernate has been reported to cause file corruption.

TWEAK FOR BOOTUP SPEED (Optional):

To decrease boot time, activate concurrency bootup:  gksudo gedit /etc/init.d/rc  and replace the line:

  • CONCURRENCY=none

with

  • CONCURRENCY=shell

TWEAKS FOR POWERSAVING (Optional):

Add the following to the /etc/rc.local file:

# Economize the SSD
sysctl -w vm.swappiness=1               # Strongly discourage swapping
sysctl -w vm.vfs_cache_pressure=50      # Don't shrink the inode cache aggressively

# As in the rc.last.ctrl of Linpus
echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
echo ondemand > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
cat /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate_max > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/sampling_rate

echo 1500 > /proc/sys/vm/dirty_writeback_centisecs
echo 20 > /proc/sys/vm/dirty_ratio
echo 10 > /proc/sys/vm/dirty_background_ratio

echo 1 > /sys/devices/system/cpu/sched_smt_power_savings
echo 10 > /sys/module/snd_hda_intel/parameters/power_save
echo 5 > /proc/sys/vm/laptop_mode

#Decrease power usage of USB while idle
[ -w /sys/bus/usb/devices/1-5/power/level ] && echo auto > /sys/bus/usb/devices/1-5/power/level
[ -w /sys/bus/usb/devices/5-5/power/level ] && echo auto > /sys/bus/usb/devices/5-5/power/level

NETBOOK REMIX (Optional):

UPDATE: An Ubuntu Netbook Remix (UNR) installer image with the LPIA kernel is now available. Such image can be installed as-is on an Aspire One and most of the steps described are not necessary. Of particular interest, wifi, suspend/resume, webcam and fan control (once BIOS has been upgraded) work out-of-the-box. Card readers have the same issues.

WARNING ABOUT UNR: The UNR installer image currently wants to format your entire hard disk. If you want to dual boot XP Home and Ubuntu your best bet is to use GPARTD from a live linux such as systemrescuecd to resize the windows partition and create partitions for your Ubuntu install. Recommended one main partition labeled / and formatted and a 1-2 gb swap partition.

To install Ubuntu Netbook remix -

In Intrepid, the netbook remix packages are already in the universe repository. For Hardy, you'll need to add the netbook remix PPA to your sources.list.

  • Insert the following into /etc/apt/sources.list (not required for Intrepid):

deb http://ppa.launchpad.net/netbook-remix-team/ubuntu hardy main
deb-src http://ppa.launchpad.net/netbook-remix-team/ubuntu hardy main
  • then execute

In Hardy:

sudo apt-get update
sudo apt-get install go-home-applet human-netbook-theme maximus ume-launcher window-picker-applet

In Intrepid (ume-launcher has been renamed to netbook-launcher):

sudo apt-get install go-home-applet human-netbook-theme maximus netbook-launcher window-picker-applet
  • Add maximus as startup program (system > preferences > sessions > startup programs)

  • Change the desktop theme to Human-Netbook (system > preferences > appearance > theme)

  • Delete the bottom panel
  • Reconfigure the top panel to contain the following items -
    • Go Home Applet
    • Window Picker Applet
    • Notification Area
    • Mixer Applet
    • Clock
  • There is a bug in the ume-launcher after resuming from suspend. To work around this place the following in /etc/pm/sleep.d/01UMELauncher -

#
# Copyright 2008 Matteo Collina <matteo.collina@gmail.com>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of version 2 of the GNU General Public License as
# published by the Free Software Foundation.

export DISPLAY=:0.0

TMPFILE=/tmp/.launcher/resume-event

case "$1" in
        suspend|hibernate)
                rm -rf $TMPFILE
                echo "Removed resume-notify file"
        ;;
        resume|thaw)
                touch $TMPFILE
                echo "Created resume-notify file"
        ;;
esac

exit $?
  • Make the above file executable -

sudo chmod +x /etc/pm/sleep.d/01UMELauncher

You should also disable desktop effects as these cause issues with netbook remix.

Maximizing screen real estate in Firefox:

To take your screen saving netbook remix to the next level, you can do the following to maximise screen real estate in everyone's most used app - Firefox -

  • Install the following addons
  • Install the following theme -
    • Classic Compact
  • Configure Personal Menu to include all the standard menus except History and Bookmarks (they get their own buttons)
  • Disable the menu toolbar. You can always get it back by pressing Alt
  • Use the top-bar icon tabs instead of firefox tabs. (options are in edit > preferences > tabs )

Drastically speed up Firefox

Make firefox store its cache in the /tmp directory --- which when we we have moved it to a tmpfs according to this wiki is *fast*.

  • Firefox 3.x uses a sqlite db that creates many write accesses, so this can reduce it:
    1. In Firefox go to (type as url) "about:config", right click, add new string „browser.cache.disk.parent_directory“ with value "/tmp/firefox"
    2. In Firefox change options/security/ and disable phishing if you dare. - Your firefox will run even faster then but won't warn you about phishing any more so take care!

Alternatively, to speed up Firefox further, enter "about:config" (without the quotes) as an url in Firefox, then change the following settings:

// disable disk and offline cache
set browser.cache.disk.enabled: false
set browser.cache.disk.capacity: 0
set browser.cache.offline.enable: false
set browser.cache.offline.capacity: 0
// just as a precaution
add browser.cache.disk.parent_directory: /tmp
// apparently safebrowsing slows things down - disable at your own risk!
set browser.safebrowsing.malware.enabled: false
set browser.safebrowsing.enabled: false
set network.prefetch-next: false
// don't show suggestions in the search bar
browser.search.suggest.enabled: false
// don't spellcheck as I type
layout.spellcheckDefault: 0

Firefox still records a list of all places that have been visited so far in the file places.sqlite. If you don't need your firefox to keep this history until the next system start browsing can be speeded up even further:

  • Add the following line to etc/rc.local somewhere before the exit 0 that creates a file of this name in our tmp directory that is kept in RAM by the /etc/fstab modifications from this wiki page:

echo >> /tmp/places.sqlite
  • and replace places.sqlite from your firefox profile by a symbolic link that links to this temporary file. This can be done e.G. by:

cd
cd .mozilla/firefox/
tmp=`find |grep places.sqlite$`
rm $tmp
ln -s /tmp/places.sqlite $tmp
  • Firefox still occasionally uses the flash disk after that, but the delays from this should no more be recognizable.

Ubuntu Hardy installs flash version 9.0.115, this version needs a lot of memory to work and makes 'AspireOne' slower than it is. A good option is to download the latest Flash player plugin 10, which delivers improved performance and less memory requirements. This package is the flashplugin-nonfree, which is available on hardy-backports repository, or by download in the following link:

http://packages.ubuntu.com/hardy-backports/flashplugin-nonfree

Verifying Flash player 10 installed correctly

Once you've installed Flash 10, verify that it installed correctly by visiting here. In the version information box, verify it says version "10,0,12,36" or newer installed.

If version 9 is still installed in Firefox then you will need to do it manually by following these directions.

Uninstalling the Flash 9 plugin from Firefox

Open a terminal window (Applications>Accessories>Terminal) and type:

cd ~/.mozilla
rm flashplayer.xpt libflashplayer.so
exit

Installing the Flash 10 RC plugin into Firefox

Visit the Adobe website and select from "Select version to download..." drop down menu the "tar.gz for Linux" option. Save the file to your Desktop.

Close all open Firefox windows before proceeding.

Open a terminal window (Applications>Accessories>Terminal) and type:

cd Desktop
tar -zxvf install_flash_player_10_linux.tar.gz
cd install_flash_player_10_linux
./flashplayer-installer

Press ENTER to install. Answer y to proceed. Answer n to not perform another installation.

Open the Firefox browser and type about:plugins in the address bar and hit ENTER.

You should see:

Filename libflashplayer.so
Shockwaveflash 10.0 b218

Or a newer version listed.

Under MIME Type the following should be listed:

application/x-shockwave-flash  Shockwave Flash
application/futuresplash       Futuresplash player

AspireOne/Ubuntu8.04 (last edited 2011-11-24 19:58:49 by skovprodukter)