Tag/tag.png

Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...

With A110 and UNR v9.10, (late 2009 release), the only thing needed to be changed from the vanilla install is to edit /etc/modprobe.d/acerhdf.conf and add the line: options acerhdf kernelmode=1 then reboot. This controls the fan and is worth swapping to ubuntu just for this, the netbook is then silent apart from the sound made by using the keyboard..

The default temps are a bit high, so if you notice your device getting too hot, you can adjust the temp that the fan turns on and off by adding a few parameters to the options line above. The following seems to prevent it from running too hot: 'options acerhdf kernelmode=1 fanon=61000 fanoff=54000' See http://piie.net/files/acerhdf_README.txt for more info.

(N.B.- http://piie.net/files/acerhdf_README.txt has not yet been updated to reflect that ubuntu now expects the temperatures to be specified as '61000' rather than the former '61'.)

As described the battery status will take bit of time to update when you unplug the AC cord, but if you wait 30 seconds it will change, which I can live with. The second Wifi LED that indicates traffic does not flash, but again that's no great loss.

Suspend mode will hang if a MM/SD/SDHC card is mounted, if you don't like the excellent script below then you can unmount it from the Nautilus file manger, or physically pop it out, if you're 100% sure it's not is use. In the script below I have to change /dev/mmcblk?p* to /dev/mmcblk*

If you try and suspend with a card mounted then you'll have to hold down the power button for five seconds to power off.

Power manager status icon in the Notification Applet does not switch from AC power to Battery when unplugged, although the screen dims. Since it still shows as AC power, it does not show an estimate of battery time left. If it is unplugged at login, it will switch to AC power status when plugged in, but not back if unplugged again. A work around for this is to add the add the following line in /etc/rc.local before the exit 0 line

  • /etc/init.d/laptop-mode start
    service laptop-mode status

Suspend Mode with SD cards mounted: The system hangs when the suspend mode is entered with SD cards inserted. The following script will unmount these SD cards. All SD cards will be automatically mounted again after resume. The suspend mode is not entered when there are programs that still access the SD cards. There are no more system crashes with the following script. Create one named /usr/lib/pm-utils/sleep.d/010_unmount_SD.sh as user root. Make it executable with chmod 755 /usr/lib/pm-utils/sleep.d/010_unmount_SD.sh. This script should contain the following lines:

# Drop to: /etc/pm/sleep.d
# Use this script to prevent data loss on mounted MMC/SD
# cards. It syncs data and umounts all mmcblk devices prior to
# suspend, and cancels suspend if umounting was not possible
# (i.e: something locks a file)
case "${1}" in
    hibernate|suspend)
        /bin/sync
        for drive in $( /bin/ls /dev/mmcblk?p* ); do
            /bin/umount ${drive} > /dev/null
            # If umount failed: abort suspend
            if [ $? -gt 0 ]; then
            # Test if device keeps mounted. Previous command could fail
            # (i.e device was not mounted) with a non-stopper
            # problem for the suspend process.
            /bin/mount | /bin/grep ${drive}
            if [ $? -eq 0 ]; then
                exit 1
            fi
            fi
        done
        ;;
#    resume|thaw)
##       Do nothing. All devices will be automatically mounted again.   
#       ;;
esac

For KDE users, there is another version of this script (see bug 424877) that uses the KDE4.x solid-hardware daemon to re-mount the devices.

Video (.AVI, etc) aspect ratio is way off. Much narrower horizontally than should be. This is because Xorg incorrectly detects the physical display size as 451mm x 113mm. A workaround for this is to force it with xrandr --fbmm 195x113. This can be made persistent by creating a script /etc/gdm/Init/:0 containing:

#!/bin/sh
xrandr --fbmm 195x113

Make it executable with chmod 755 /etc/gdm/Init/:0.

110L (512Mb RAM, 8Gb SSD)

Status: (based on a semi-clean install [/home partition retained from 9.04] from a Live boot)

  • Install (once all the info had been supplied) to a SSD took 50 minutes using a 2GB SanDisk Cruzr USB memory stick.

  • UNR boot time (from pressing power button to asking for keyring password) 35- 40 seconds.
  • Sound (mic and speakers) works OOTB on my model.
  • touchpad works, but in some case 'tap to click' is not enabled by default (you have to use the left mouse button). To enable, System->Mouse and choose the "Touchpad" tab and tick "Enable mouse clicks with touchpad". Anyway the problem seems fixed in Karmic at the time of official release.

  • gsynaptics doesnt work this used to sort out the annoying problem of the mouse moving the curser whilst typing by adding a delay unfortunately this doesn't work in the current xorg with no shared memory. Hopefully there will be an answer to this latest annoyance soon.
  • All USB ports are hot-pluggable, RH SD works if card is present on boot. LH SD is hot-pluggable on my model. RH now recognizes, but will not open, Sony MemoryStick (if present on boot). Have not tested XD nor CF cards. Karmic uses grub2 by default. The right hand slot can be made hot-pluggable by editing /etc/default/grub. Add pciehp.pciehp_force=1 between the double quotes on the line GRUB_CMDLINE_LINUX_DEFAULT (SSD users can also add elevator=noop to increase speed) then run (using sudo) update-grub2 and reboot.

  • Both Card readers work after bios update to version 3309, which makes the leftcard reader recognise cards even if empty at boot time, however the righthand card reader still requires some work if you edit /etc/default/grub as detailed below GRUB_CMDLINE_LINUX_DEFAULT="pciehp.pciehp_force=1 elavator=noop quiet splash"

this results in the righthand card reader working perfectly in combination with the bios update. The aspireone can have an issue with flickering at low brightness levels and 3309 fixes that by eliminating the brightness levels that flicker. If you don't have the flickering the loss of the lower brightness levels might be annoying however there are 2 alternatives using bios versions designed for packardbell and gateway aspireone clones see http://macles.blogspot.com/2009/03/brightness-table.html for details.

  • Extending /etc/default/grub (or /etc/default/grub if you are already using grub2) to contain GRUB_CMDLINE_LINUX_DEFAULT="pciehp.pciehp_force=1 elavator=noop quiet splash enable_mtrr_cleanup" makes the already quite fast video chipset much faster.
  • Fan Control module is now part of the kernel, but is not enabled by default. To enable it for the running session type: "sudo echo -n “enabled” > /sys/class/thermal/thermal_zone0/mode". To automatically enable it at boot, create “/etc/modprobe.d/acerhdf.conf” and add the line: options acerhdf kernelmode=1

  • WiFi (WPA2 passphrase) 'just works' OOTB, including the RH led. It seems to be much more stable with many fewer drop-outs than 9.04. [WEP 40/128 bit key does not work on AAO 150 - Does work in 9.10 Beta]. Dropout can be observed when heavy internet traffic is present.

  • Suspend and hibernate seem both to be working without a hiccough. [Edit: (28/09) a recent upgrade seems to have broken suspend/resume with a flurry of bug-reports and me-toos on launchpad.]
  • 3G dongle works (O2 payg) Most huawai 3g modems work but the E620 (contract modem) works in karmic but not in jaunty or lucid alpha one. Its a kernel issue so may be fixed in later versions. the E156,E169 seem to be better supported (3 payg uk/ie )
  • Audio or more specifically pulseaudio has a few problems with selecting internal / external microphone installing linux-backports-modules-alsa-karmic-generic-pae 2.6.31.17.30 updates alsa so it auto senses the presence of a mic jack but that doesn't help pulse as a work around /bin/sh -c "PULSE_SERVER=127.0.0.1 skype" launches skype and uses alsa bypassing pulseaudio /bin/sh -c "PULSE_SERVER=127.0.0.1 linphone-3" is a similar workaround for linphone a sip client. you get the idea.
  • The applet to switch between UNR and standard ubuntu desktop does not work properly, but I don't think this is specifically an AAO issue and it is being worked on. For the moment don't use it unless you are prepared to manually rebuild your panels.
  • The new UNR interface is way cool. You can have (and see) a background image (wallpaper) should you wish, as all is now semi-transparent. Files and folders are now a heading on the LH side, no panel in the RHS which allows even bigger application icons. Major kudos to the team for this much-improved interface.

../Screenshot-1.png

110L

Installed with update-manager -d.

  • All hardware still as functional as 9.04.

ZG8 (AO510 Bios)

Status: Semi clean install (/home retained from 9.04)

  • WiFi did not work OOTB. Had to blacklist acer_wmi (the same problem with 9.04)

  • WiFi LED and switch are not working

  • Bluetooth, LED and switch are all working
  • Built in mic works OOTB (unlike 9.04)
  • Even though this model's touchpad under Windows supports multi-touch, the new "Two finger scroll" feature in mouse settings of UNR did not work

Only after installation and a 500MB update that I got the new theme and startup splash. The switch between Netbook and Classic desktop interfaces caused the Windows Manager to break. Had to go back to 9.04

ZG5 (8+8/SSD)

Status: Kubuntu 9.10 RC3 clean install with home dir restored from tarball

  • All hardware works OOTB, except RH SD slot not hot pluggable
  • I made /home on LH SD card, with encrypted home dir. SD card shows up in device notifier, resume does not re-mount home dir, therefore suspend/resume not working for this configuration.
  • Desktop resolution and type (folder view) not retained, nor custom panel widgets (konsole profile launcher)

ZG5 (1GB + HDD160GB)

Status: Upgrade from 9.04 with full updates of 20091204

  • Seems OK except the Wifi that doesn't work (listed in lspci, but not recognized in iwconfig)

P531h

Status: Ubuntu 9.10 install with all updates on 01/12/2009

  • No sound via the line-in and line-out, but the internal boxes and microphone works
  • Closing the lid will not suspend.
  • un/plugging the power cable suspends the netbook
  • Logging out when another user is logged in will result in a suspend
  • Other hardware works OOTB

AO532h (N450-GMA3150-1GB-HDD160GB-Atheros B&G-BT)

Status: Ubuntu Netbook Remix 9.10 fresh install with all updates on 01/06/2010.

  • Card reader do not work, even after editing (110L trick)/etc/default/grub .
  • Fn + F2 for wireless shortcut do not work.
  • Multi-gesture touchpad do not work.
  • Hibernate works.
  • Setting "Extra" Visual-Effects in Appearance works.
  • Other hardware works OOTB.

AO532h-2326

Status: Ubuntu Netbook Remix fresh install with all updates as of 03/12/2010.

  • Used unetbookin to create a FreeDOS USB start up disk to update BIOS to v1.18.
  • Sound, suspend, wireless, touchpad all work.
  • Can't disable touchpad tap-to-click "feature," which makes the keyboard almost unusable. Can't figure out what kind of touchpad chipset is being used; only a psmouse is listed in lshal.

AOA150-1635

I used these steps to get it working - Download and extract the files, then install compile and install the module

tar -xzvf madwifi-0.9.4-current.tar.gz
cd madwifi-0.9.4-r4100-20090929
make
sudo make install
sudo modprobe ath_pci

The wireless should become active after the last line above. Further instructions can be found at http://madwifi-project.org/wiki/UserDocs/FirstTimeHowTo

D150 (1G, 160Gb HDD)

Works OOTB:

  • Ethernet 10/100
  • Camera
  • Keyboard and functional keys
  • WiFi (the switcher was not tested because it's broken on my netbook)

  • Bluetooth and BT button above the keyboard
  • Suspend/hibernate (but not on lid close, see below)
  • Sound and headphones out
  • Card reader
  • Fn + key: F4(suspend), F5(VGA output), F6(display off), F7(touchpad off), F8(mute), up/down (volume controll), right/left (brightness controll), numpad, NumLock. ScrLock.

Works after some troubleshooting:

  • Microphone. It was too quiet, but helps this thread (need to open alsamixer, press Tab to switch to recorder controllers and at CAPTURE controller make 0<>100 using 'Z' and 'E' keys)

  • Did not suspend/hibernate on lid close. Upgrading BIOS to 1.11 version helps.
  • Un/plugging AC causes netbook to suspend. With BIOS ver 1.11 this was fixed.

Does not work:

  • Fn + key: F1(help sign), F2(don't know what is it), F3(also don't know). Those keys even don't send scan codes to showcodes -s.


CategoryWireless

Wireless Problems Connecting WEP(Wired Equivalent Privacy) 64-bit - encryption shared key Ubuntu 9.10 PT - Aspire One AOA110

The wireless device is installed it detects all the available wireless connections but when I edit my connection to select WEP, shared key and to insert access key the network connects for seconds and then it goes offline. When I edit connection again the access key field it's empty.

If I search for available wireless networks I do find several nearby but when I select it to connect nothing happens...

I've already made all the updates available to the software expecting that the problem could be solved...

Anyone has solution for this?

I found connecting wpa encrypted networks didn't work under 9.10 the network was visible but didn't connect, recent experiments with 10.04 shows this isn't a problem any more however 3G modem support is broken for some models E620 is broken E156 works (detected as E220). Vodafone mobile connect isn't an option due to broken dependencies. Update

  • the E620 is supported but you need to download usb-modeswitch_1.1.0-2_i386.deb and usb-modeswitch-data_20100127-1_all.deb if you install these packages the next time the modem is inserted it will be recognised and be fully working. (The rc candidate doesn't install these by default so its likely the initial release due in 3 days is likely to be missing these 2 deb files)


Install WICD from the package manager.


CategoryWireless CategoryWireless

AspireOne/Ubuntu9.10 (last edited 2011-06-09 14:11:54 by skovprodukter)