Parent: Games

Introduction

Wolfenstein: Enemy Territory is a first-person-shooter game from Activision. At QuakeCon 2010, co-founder and Technical Director John D. Carmack announced that the source code for this game is now under the GPL.

Requirements

  • You will need an accelerated 3D graphics card driver. If you have an Nvidia or ATI graphics card, and an accelerated driver was not enabled by default, then you can read instructions for obtaining a proprietary driver in BinaryDriverHowto

  • libgtk1.2 must also be installed if you want to install with a GUI. You can install it by running this command in a terminal: sudo apt-get install libgtk1.2

  • If you are running 64-bit install the 32-bit libraries sudo apt-get install ia32-libs

Download

Full game

You can get the game from FileShack

or directly with the command:

wget -c http://ftp.games.skynet.be/pub/wolfenstein/et-linux-2.60.x86.run

Patch to v2.60

If you have already installed the older Enemy Territory version 2.55 then you can download a patch to update it.

You can get the patch from FileShack

or directly with the command:

wget -c http://ftp.games.skynet.be/pub/wolfenstein/et-linux-2.60-update.x86.run

Patch to v2.60b

The latest full installer is Enemy Territory version 2.60, however, a patch which brings the game to version v2.60b has also been released.

You can get the patch from FileShack or FileFront.

New Versions

You can check FileShack to see if a newer version is available than this, however, no new official releases are expected as the source code of the game engine has been released.

Installation

Full Game

The file you have downloaded is an installer, which can be run from a terminal with the command (adjusting versions where necessary):

sudo sh ./et-linux-2.60.x86.run

and a GUI installer should appear (if you have libgtk1.2) to help you through the process. (By default Punk Buster is selected. This is needed to join a lot of servers). If it does not run then you may need to check the Troubleshooting section below.

NOTE: To avoid permissions issues DO NOT RUN the game from the installer. (Once installed do not click Start ET, exit the installer). It is also advisable to run the PunkBuster updater before running the game for the first time.

Updating Old Versions

Updating to version 2.60

To apply the patch you have downloaded, you should run the file from where you have downloaded it with the command:

sudo sh ./et-linux-2.60-update.x86.run

(Adjusting the version where necessary). If it does not run then you may need to check the Troubleshooting section below.

Updating to version 2.60b

To apply the patch you have downloaded, extract from the archive the following files: * /Enemy Territory 2.60b/linux/et.x86 * /Enemy Territory 2.60b/linux/etded.x86

You need to replace the existing files in the game folder (by default /usr/local/games/enemy-territory/) with the two you have just extracted. If the game was installed with super-user permissions, you need to use the Terminal:

sudo chown root:root et*.x86
sudo mv et*.x86 /usr/local/games/enemy-territory/

Running The Game

The installer will create a menu entry called Applications->Other->enemy-territory. You can either use this as it is, or put it in a more sensible location (such as Applications->Games->Enemy Territory) with the Alacarte Menu Editor which you can find in Applications->Accessories or System->Preferences->Main Menu.

Alternatively you can run it from a terminal with the command:

et

Troubleshooting

Punkbuster update

If you cannot update punkbuster and you get kicked out every time, try the graphical user interface (GUI) application:

http://www.evenbalance.com/index.php?page=pbsetup.php

You have to extract the .zip file, run pbsetup.run, "Add a Game" > Enemy territory. Then hit "Check for updates".

If you have run the game already and performed the procedure above and still get disconnected by PunkBuster, delete the folder ~/.etwolf/pb (~ means your home folder):

rm -r ~/.etwolf/pb

PunkBuster is now disabled in your game profile so enable it via the server browser. This will cause the updated PunkBuster libraries to be copied from the game folder to the user profile.

Permission Errors

Downloaded files do not have permission to execute by default, but you can change this with these commands:

sudo chmod +x et-linux-2.60.x86.run
sudo chmod +x et-linux-2.60-update.x86.run

(Adjusting the version as necessary).

Downloading Maps

Verify that the directory for downloaded maps is accessible and writable by your user. If you do not do this, you will be unable to download and install the maps and other files you need to join games!

sudo chown -R user:group ~/.etwolf/

Replace user:group with your own username and group (usually these are the same).

Sound Issues

If you're not hearing any sound from Enemy Territory, then the ESD sound server may be having problems. You may need to install extra files for this to work. Install the esound package like so:

sudo apt-get install esound

If this does not work there are a few methods you can try:

Method 1

You can try stopping the ESD sound server before running the game by running:

killall esd; et; esd

If this works for you then you can create a script to run it. To do this create a new text file called start-et and add these lines to it:

killall esd
et
esd
exit 0

Now save the file and you will need to run these commands to make it executable and to put it somewhere in your user's $PATH variable (so that it can be executed by just typing it's name):

chmod a+x start-et
sudo cp start-et /usr/local/games

If you don't want to put it in /usr/local/games you don't have to, but remember to specify whatever path you decide to give it whenever you execute it (some paths can use shortcuts, like ./start-et for the current directory, ~/start-et for your Home directory, etc.)

Method 2

If you don't hear any sound and see the following error message in a terminal:

/dev/dsp: Input/output error
Could not mmap /dev/dsp

You will need to do the following in addition to the steps above:

sudo -i
echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
exit

This makes the script slightly more complicated, since parts of it will need to be run with superuser priviledges. To use the above commands in the star-et script described in Method 1 you should make it look like this:

gksudo echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss
gksudo echo "et.x86 0 0 disable" > /proc/asound/card0/pcm0c/oss
killall esd
et
esd
exit 0

Then use the commands to give it execute permissions and to put it in /usr/local/games.

Method 3

If "echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss" fixed it when run as root, this is how to add it at startup.

Create File

sudo nano /etc/init.d/makeETwork.sh

Add This to File

echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

Exit nano and make it executable

sudo chmod uog+x makeETwork.sh

Make it run at bootup

sudo update-rc.d makeETwork.sh defaults

Reboot and try to play

Method 4a

The thread http://ubuntuforums.org/showthread.php?t=362231 has a script that uses the libsdl1.2debian-alsa package to launch ET with sound.

To get install the package

sudo apt-get install libsdl1.2debian-alsa

To get and make the script installable

wget -q -O - http://nullkey.kapsi.fi/et-sdl-sound/et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound

Method 4b

To make work the method 4a with pulseaudio in ubuntu 11.04, we need to download the same script and edit it changing the line

SDL_AUDIODRIVER="alsa" 

by

SDL_AUDIODRIVER="pulse"

Method 5

Temporarily suspend PulseAudio: pasuspender et

Method 6 Xubuntu 12.10 64bit

Install prerequisites

sudo apt-get install libsdl-sound1.2 libsdl1.2-dev ia32-libs

Download et-sdl-sound.tar.gz from http://nullkey.kapsi.fi/et-sdl-sound/ (under source code and binaries), extract the archive and copy et-sdl-sound.so to enemy territory install directory (where you got files like et.x86 and etded.x86). Create executable script to launch et

 #!/bin/bash
export ETSDL_SDL_LIB="/usr/lib/i386-linux-gnu/libSDL-1.2.so.0"
export SDL_AUDIODRIVER="pulse"
cd /path_to/et/
LD_PRELOAD="${LD_PRELOAD}:/path_to/et/et-sdl-sound.so" ./et.x86 $*

Making Startup Scripts More Friendly

If either of the above scripts fix your problem then you can add them to the system's menu using the Alacarte Menu Editor in Applications->Accessories. Go to a suitable location such as Games and make a new entry. It's Command should be start-et (as long as it is in /usr/local/games. If you put it somewhere else then put the whole path), set the icon, name, etc. to what you want then press OK. To avoid confusion you should also disable the old Enemy Territory entry which was added by the installer by unticking the box next to it in Alacarte.

Uninstalling

The installer downloaded above offers no uninstall method, so to uninstall the game, it must be done manually through the command line.

Below will remove the game, the shortcut to the game and your personal preferences:

sudo rm -rf /usr/local/games/enemy-territory/ && sudo rm -f /usr/local/bin/et && rm -rf $HOME/.etwolf

See Also

Forum Thread A useful thread in the Ubuntu Forums which may be useful if you are still having problems.


CategoryGames

EnemyTerritory (last edited 2012-12-18 20:23:35 by phukariflux)