Tag/tag.png

Candidate for Deletion
This article may not be appropriate for this wiki, and may be deleted. More info...

Font problems in OpenOffice.org

A large number of people have reported numerous problems with fonts in OpenOffice.org and on this page I to consolidate all the info as well as provide a standard troubleshooting guide. What contitutes the best looking fonts is obviously highly subjective and something a great number of people spend a great amount of time discussing. That's not the point here. If your OpenOffice.org fonts look terrible, you should try following these steps. If you do not like the result, feel free to undo them again.

The document is divided in two sections:

  • UI fonts (or 'why does my menu look awful?')
  • Document fonts (or 'why does this document look awful?')

Assumptions

  • You are using one (or more) LCD monitor(s) as opposed to a CRT
  • You are using Intrepid (this probably also applies to earlier versions)
  • Your language is set to 'English' - the text in the different panels refers to the

UI fonts

I am assuming that you are using an LCD monitor. The steps below do not apply (or will apply with less success) in case you are using a CRT, but if somebody can elaborate on the 'best' settings for CRTs that would be great. Ensure you perform the following steps:

  1. sudo apt-get install openoffice.org-gnome
  2. sudo dpkg-reconfigure -plow fontconfig-config and answer:
    1. 'Native'
    2. 'Always'
    3. 'Yes' or 'No' depending on if you want to use bitmapped fonts. If you don't know, you probably do not and should answer 'No'
  3. In GNOME go to 'System', 'Preferences', 'Appearance'
    1. Select the 'Fonts' tab
    2. Select 'Subpixel smoothing (LCDs)'
    3. Click 'Details...'
      1. Under 'Smoothing' select 'Subpixel (LCDs)'
      2. Under 'Hinting' select 'Full'

Document fonts

It's coming guys. Hang on.


CategoryOffice

OpenOffice.orgFonts (last edited 2013-12-26 14:11:04 by fitojb)