Setting up an AMD E-350-based thin client under LTSP

I recently bought the following hardware for a thin client:

This is not an endorsement of any particular hardware or vendor. But you can probably see how your E-350 hardware and display are different from this one.

Things more or less worked, but getting the display to work with proper resolution might be useful to some of you. Install the memory (easy), connect the display using either the HDMI or HDMI/VGA adapter Zotac includes.

To start you need a 64-bit server architecture and a standard install of LTSP5. I did this with an LTSP server built on ubuntu-desktop 10.10, with latest security updates. The server has two NICs and I assume your server is working fine. This was my first 64-bit client.

1. Build the client image on the server

  • The following, all as su, or prefixing sudo:

    ltsp-build-client

    ltsp-update-sshkeys

    ltsp-update-image

2. Restart the dhcp3-server

  • The following, all as su, or prefixing sudo:

    /etc/init.d/dhcp3-server restart

3. Boot the thin client

  1. Enter the BIOS by pressing the Delete key. Change: Chipset-Onbaord Device Config - Launch PXE OpROM to Enabled.
  2. Change the clock to the correct time settings.
  3. Save and exit. Save and reset.

4. Configure the thin client display

  1. Download the latest ati driver for linux x86-64, from AMD. I got this one, version dated 10/31/2011, from here: [http://support.amd.com/us/gpudownload/Pages/index.aspx]

    1. Choose Type of System: Desktop Graphics
    2. Choose Product Family: E-Series APU
    3. Choose Product: E-350 APU
    4. Choose Supported Operating System: x86_64
    5. Choose Display Results

      which gives this link: [http://www2.ati.com/drivers/linux/ati-driver-installer-11-10-x86.x86_64.run]

    b. Copy the installer file to the thin client installation, in a new directory.
    • Here I assume the chroot is /opt/ltsp/amd64/ and the new directory for building the ati driver is /opt/ltsp/amd64/usr/share/ati_catalyst.
      • mkdir /opt/ltsp/amd64/usr/share/ati_catalyst

        cp -rp ati-driver-installer-11-10-x86_64.run /opt/ltsp/amd64/usr/share/ati_catalyst/

    c. Open an xterm onto the thin client and install the driver. Here I am following instructions from [https://help.ubuntu.com/community/BinaryDriverHowto/ATI] (someone please make that link properly?)

    • ltsp-localapps xterm & (or?) sudo ltsp-chroot -p

      cd /usr/share/ati_catalyst

      chmod +x ati-driver-installer-11-10-x86.x86_64.run

    d. Now before I installed the driver, I needed several dependencies. So do this first:
    • apt-get install dpkg-dev build-essential debhelper fakeroot execstack

    e. Now you can run the installer as follows to create .deb packages for install the Debian Way (adjust as necessary for different version of Ubuntu}:
    • ./ati-driver-installer-11-10-x86.x86_64.run --buildpkg Ubuntu/maverick

    f. You should now see several .deb packages in your directory ati_catalyst:

    • fglrx-amdcccle_8.902-0ubuntu1_amd64.deb fglrx-modaliases_8.902-0ubuntu1_amd64.deb fglrx_8.902-0ubuntu1_amd64.deb fglrx-dev_8.902-0ubuntu1_amd64.deb
    • Install all of them:
      • dpkg -i *.deb

    g. Exit the thin client and update the images:
    • ltsp-update-kernels

      ltsp-update-image

    h. Update /var/lib/tftpboot/ltsp/amd64/lts.conf using an editor. Here is mine:
    • [default]

      CONFIGURE_X=True

      X_CONF=/etc/X11/xorg.conf

      LOCALDEV=True

      SOUND=True

      CONFIGURE_FSTAB=False

      I think the important line for our purposes is X_CONF=/etc/X11/xorg.conf. Now we need to create it.

  2. Create the xorg.conf file in /opt/ltsp/amd64/etc/X11/xorg.conf. Mine has just:
    • Section "Device"

       Identifier "ATI radeon 6310"

       Driver "fglrx"

      EndSection

5. Finish up and test

  1. Exit the thin client (or ltsp-chroot) b. Update the ltsp kernel and image (again as su or using sudo):
    • ltsp-update-kernels

      ltsp-update-image

    c. Reboot the thin client. Now when I go to System > Administration > Monitors I see the correct possible resolutions, starting with 1920x1080 (16:9), and 60Hz refresh rate.

6. Getting localdev USB support

  1. localdev USB support is missing. I tried what is here: [https://wiki.ubuntu.com/DebugLocalDev], everything checks out except the last step fails. UPDATE 1/27/2012: How to get localdev USB support (Thanks to alkisg and stgraber for these instructions): Apparently support for fuse for amd64 clients was only recently added (this statement may be inaccurate?) But the solution is to add a recent (1.0-1 or later) version of ltspfs and ltspfsd to your ltsp install. It looks like this fix should go away with finalization of 12.04LTS.

    • On the server do the following:
      1. Make a backup of /opt/ltsp:
        • sudo rsync -avuz /opt/ltsp /opt/ltsp-backup

      In case of a disaster, you can (as sudo)
      • mv /opt/ltsp /opt/ltsp-broken

        mv /opt/ltsp-backup /opt/ltsp

        ltsp-update-image

      and reboot the client, to get back where you were.
      1. Get ltspfs from here and ltspfsd from here Put them somewhere like /opt/ltsp/amd64/ so you can see them from the chroot (next step).

      2. change to the chroot:
        • sudo chroot /opt/ltsp/amd64

      3. install the packages:
        • sudo dpkg -i ltspfsd-core_1.0-1_amd64.deb

          sudo dpkg -i ltspfsd_1.0-1_all.deb

      4. Exit the chroot:
        • exit

      5. Update the image:
        • sudo ltsp-update-image

      6. Reboot the client, and then try to insert a usb hotplug device, like a flashdrive. It came up for me.

Please edit this entry should you try this and find mistakes! Thanks.


CategoryLtsp

UbuntuLTSP/AMDE-350 (last edited 2012-03-20 17:30:17 by mnevans)