Install the Flash plug-in

Flash is a plug-in for your web browser that allows you to watch videos and use interactive web pages on some websites. While HTML5, which is a more modern solution, is increasingly offered, there are still some websites which won't work without Flash.

If you do not have Flash installed, you will probably see a message telling you so when you visit a website that needs it. Flash is available as a free (but not open-source) download for most web browsers.

Adobe has announced that they will stop updating and distributing the Flash Player at the end of 2020. Consequently, for security reasons, the Flash plug-in should not be used after 2020.

There are two kinds of plug-ins available:

  • NPAPI for Firefox and other Gecko-based web browsers

  • PPAPI for Chromium and other Blink-based web browsers including Opera and Vivaldi

The Google Chrome browser is shipped with Flash bundled, and does not need a plug-in.

flashplugin-installer

The flashplugin-installer package provides the NPAPI plug-in for Firefox. Install the package and restart your browser.

adobe-flashplugin

The adobe-flashplugin package provides both the NPAPI and PPAPI plug-ins, i.e. it provides Flash for both Firefox and Chromium like web browsers.

  1. Make sure that the Canonical Partner repository is activated.

  2. Install the adobe-flashplugin package.

  3. Restart your browser.

browser-plugin-freshplayer-pepperflash

Some features of the PPAPI plug-in, such as 3D acceleration and premium video DRM, are not available in the NPAPI plugin. If you use Firefox or some other Gecko-based browser and need those features, you can install the browser-plugin-freshplayer-pepperflash package. It's a wrapper which makes Firefox use the PPAPI plug-in.

  1. Make sure that adobe-flashplugin is installed.

  2. Open a terminal window by pressing Ctrl+Alt+T and install the browser-plugin-freshplayer-pepperflash package:

    sudo apt install browser-plugin-freshplayer-pepperflash

  3. Restart your browser.