This page contains suggested fixes and/or hacks to get hardware working properly with Ubuntu on the Aspire Timeline.

Boot issue after installation

This issue has been fixed, for more info see

There are two workarounds to this issue.

Switch SATA mode from AHCI to IDE

Enter the BIOS and change the SATA mode from AHCI to IDE. (Feel free to write this process down in more detail if you like)


  • Changing mode to IDE will prevent you from dual booting into Vista
  • NCQ is disabled (does the disk have NCQ?)
  • IDE mode prevents use of the SATA ALPM to reduce power usage

Set boot option in Grub

  1. Press the escape key during boot to get access to the Grub interface. Enter "libata.force=noncq" (without quotation marks) and boot into Ubuntu.
  2. Open a terminal and enter "sudo gedit /boot/grub/menu.lst"
  3. Change "# defoptions=quiet splash" to "# defoptions=quiet splash libata.force=noncq"
  4. Save and close gedit, then run "sudo update-grub" on the command line.


  • NCQ is disabled (does the disk have NCQ?)


  • This problem does not apply to the version with Intel SSD. Nothing needs to be done for the SSD version. It would be great if someone with the HD version can try a different HD, to make sure it's not a problem with the particular HD Acer uses.

Wired Networking

On this page here: you can find the AR81Family-linux-v1.0.0.10.tar.gz driver. Download and extract it.

  • Note: Is my case, Ubuntu's default archive manager (file-roller) couldn't extract the file, however Ark could. (sudo apt-get install ark and open the file with Ark)

The README in the file pretty much explains the installation. The MAKE INSTALL failed for me on the installation of the man-file but that does not seem to have mattered. Now the card is detected.

Here is a more detailed description:

  • $ tar xvf AR81Family-linux-v1.0.0.10.tar
  • $ cd src/
  • $ make
  • $ sudo make install
    • Note: An error might appear saying that the man pages couldn't be created. This is not really a problem.

At this point you can either restart or manually insert the module with:

  • $ sudo insmod /lib/modules/2.6.<your kernel revision>-generic/kernel/drivers/net/atl1e/atl1e.ko


Works out of the box with 9.10 alpha 2, alpha 3 and beta.


Seems to work perfectly out of the box (at least with 9.10 alpha 2 and alpha 3). Low volume is a hardware shortcoming. It's the same under Vista.

However, there are things you can try to make it better. A fresh install may leave some ALSA channels low. Try running alsamixer and setting all the channels to maximum volume. Type Esc to quit. From then on you should be able to just use the PulseAudio controls.

Internal microphone


The internal mic is not working out of the box, despite any attempts with alsamixer. External-jack mic works perfectly.

To get the microphone working with Sound Recorder:

  • apt-get install linux-backports-modules-alsa-karmic-generic
  • reboot

Anyway internal mic is still not working with skype It seems to be a bug in pulseaudio, which is used internally by skype The solution may be in new fixes for pulseaudio for related / similar bugs like Bug 277532 Recording does not work with internal microphone on Dell Vostro 1500 laptop

As reported here Comment 12 in System Test for microphone failed (ACER Aspire 3810T) Bug #405120 it is often possible to use the microphone in applications such as Skype by forcing it to fallback to ALSA by pointing to a non-existent Pulse server, like so:

$ PULSE_SERVER= /usr/bin/skype



Internal microphone was initially non-working, but fixable by installing the latest ALSA and then adjusting alsamixer. If it doesn't help, try opening Alsamixer. go to the "Capture" device and then mute (using the Z key) only the left channel while keeping the right channel up. That is the only thing that fixed the problem for me.


All Audio devices work out of the box on 5810t, includes hdmi audio and usb audio devices, internal and external mics. Microphone still doesn't work on 3810t unless performing the workaround mentioned above (muting one channel)

Suspend to RAM

For Aspire 4810/5810, the problem has been fixed by a BIOS upgrade. You should upgrade to the latest BIOS available for your model from Acer.

For Aspire 3810 and Travelmate 8371/8471/8571, it helps to add the kernel parameter i8042.reset=1. See Grub2 for instructions on how to do that.

Bug report:

Blocked during Reboot / Shutdown

Symptoms : During a reboot or a shutdown, you're stuck on a blackscreen with a white blinking cursor.

Affected models : This issue has been experienced with 4810TG and 3810T on Jaunty.

Solution : In some cases, it can be solved by upgrading the kernel to the (or better) version. You can use kernelcheck if you're not comfortable with kernel compilation.


works fine also after installing the proper driver: - type in: sudo modprobe uvcvideo - type in: sudo apt-get install cheese - type in: cheese - set the resolution in the preferences to 640x480 to get rid of the distortion - done!

Touchpad Multitouch


The following changes should be made to the 11-x11-synaptics.fdi file. I have tested this solution in both ubuntu karmic 9.10 and linux mint 8 Helena. This file can be located from the terminal by running the following:

locate 11-x11-synaptics.fdi


sudo gedit 'location'/11-x11-synaptics.fdi

(From post in 3810 thread):

The synaptics pad may not support true multitouch. However, we emulate multitouch when the width of the touch is greater than 6 units:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <merge key="input.x11_options.SHMConfig" type="string">On</merge>
        <merge key="input.x11_options.EmulateTwoFingerMinZ" type="string">50</merge>
        <merge key="input.x11_options.EmulateTwoFingerMinW" type="string">6</merge>
        <merge key="input.x11_options.VertTwoFingerScroll" type="string">1</merge>
        <merge key="input.x11_options.HorizTwoFingerScroll" type="string">1</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.TapButton2" type="string">3</merge>
        <merge key="input.x11_options.TapButton3" type="string">2</merge>

To find a suitable width threshold for your interactions, use:

synclient -m 100


Ubuntu 10.04 no longer uses hal so the above does not work. Instead we can setup the touchpad in the terminal.

$ xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 8
$ xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 40
$ xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 1 1
$ xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Edge Scrolling" 0 0 0
$ xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Tap Action" 9 3 8 0 1 2 3

For example, we can put this in a bash script and load it on Gnome session start up. Alternatively, the file /usr/lib/X11/xorg.conf.d/10-synaptics.conf may be adapted. See also the manual page of "synaptics" and the output of

xinput list-props "SynPS/2 Synaptics TouchPad"

Touchpad On/Off button


Simple workaround to activate the touchpad again:

sudo modprobe -r psmouse && sudo modprobe psmouse


Works perfectly out of the box in 9.10 alpha 2 and 3. Broken again in 9.10 Beta

To fix the problem in the final version of Ubuntu 9.10, just add the optioni8042.nomux to your GRUB_CMDLINE_LINUX_DEFAULT. This worked for me with Ubuntu 9.10 64bits on an Acer 4810T, 4810TZ and a non-Timeline laptop from acer (Aspire 5738Z-424G25Mn). To avoid any problems just follow this procedure:

  1. Access the Grub while booting by pressing the shift key (when you see GRUB loading at the top of your screen).
  2. Select the line you usually use for booting and press e.

  3. Just before quiet splash add i8042.nomux

  4. Press Ctrl-X to boot and just go to your session and try the button to see if it works.
  5. If it works then you can add it permanently to your boot options. To do that, go to your session and edit /etc/default/grub (need to be root) and again, change:



GRUB_CMDLINE_LINUX_DEFAULT="i8042.nomux quiet splash"

Then open a terminal and type sudo update-grub and enter your password. This will generate a new grub.cfg file in /boot/grub. This is why you should not modify /boot/grub/grub.cfg as any direct change is lost when updating.



Touchpad did not work any more (out of the blue). Could reenable it in gconf-editor desktop/gnome/peripherals/touchpad/touchpad_enabled.



See above fix for 9.10 if re-enable does not work.

External monitor

I have a Samsung 970p here and wanted to attach it with a resolution of 1280x1024 and had some trouble doing it. So here is the solution in case you also have issues getting the proper resolution.

First, know the resolution and the frequency. 60Hz is working fine here. You have to find out a modeline for the screen you are using. For this go into a shell and type:

# gtf 1280 1024 60.0

which gives you the modeline for 1280 x 1024 at 60Hz:

  # 1280x1024 @ 60.00 Hz (GTF) hsync: 63.60 kHz; pclk: 108.88 MHz
  Modeline "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync1024 1025 1028 1060  -HSync +Vsync

Then you edit your /etc/X11/xorg.conf to look like this:

Section "Monitor"
        Identifier      "Acer Monitor"

Section "Monitor"
        Identifier      "External Monitor"
        Modeline        "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync

Section "Screen"
        Identifier      "Internal Screen"
        Monitor         "Acer Monitor"
        Device          "Video Card (Primary)"
        SubSection "Display"
                Virtual         1900 1200
                Modes           "1900x1200" "1366x768" "1280x1024"

Section "Device"
        Identifier      "Video Card (Primary)"
        Option          "Monitor-VGA" "External Monitor"

Note where I inserted my modeline to make it work. If you then log out and log in again, the menu SYSTEM - PREFERENCES - DISPLAY should show the 1280x1024 resolution in the dropdown. This is the general direction. If this does NOT work for you for whatever reason, please take a look at this here:


Works perfectly out of the box in 9.10 alpha 2 and 3. Just use System -> Pref -> Displays.

DVD Not Mounted

This seems to be a bug. The simple workaround is use "eject cdrom" command from terminal

You can create a custom keyboard shortcut for ejecting, for example "Alt+x" runs the "eject cdrom" command. Info for gnome (gconf-editor) Info for KDE


My DVD device did not mount since updating to 10.04. The only solution that helped was switch SATA mode from AHCI to IDE in bios.

Brightness Control (fn+Arrow)


Workaround solution exists, using this rudimentary script (invoking it by global hotkeys):

function getAddr {
        ADDR=`lspci | grep VGA | cut -d' ' -f1`

function getBL {
        CURR=`sudo setpci -s $ADDR F4.B`

function setBL {
        sudo setpci -s $ADDR F4.B=$1

function toDec {
        DEC=`printf "%d" 0x${1}`

function toHex {
        HEX=`printf "%02x\n" ${1}`

function inc {
        NEWVAL=`expr $1 + 10`
        if [ $NEWVAL -gt 255 ]

function dec {
        NEWVAL=`expr $1 - 10`
        if [ $NEWVAL -lt 0 ]

toDec $CURR
case $1 in
                inc $DEC
                dec $DEC
                echo "Usage: (up|down)"
                exit -1
setBL $HEX

There is in my opinion a more simple solution described further down for Ubuntu 9.04, which worked for with Ubuntu 9.10 on an Acer 4810T, 4810TZ and a non-Timeline laptop from acer (Aspire 5738Z-424G25Mn). Add in your GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" (in /etc/default/grub)

nomodeset acpi_backlight=vendor

This will disable KMS, but will also solve some other problems, like Framebuffer Compression not being enabled (drains on the battery).


Out of the box the brightness control arrows will bring up the change notification but will not actually adjust the brightness. Run the following command to fix the issue.

xrandr --output LVDS --set BACKLIGHT_CONTROL native

This does not work in 9.10 Beta

10.04 Lucid Lynx (i386)

There is a problem related to the brightness keys and the BIOS version. Please check bug #446717 Using BIOS v1.31 or v1.35 the brightness keys would cause my laptop (4810T) to freeze. I solved the problem by downgrading my BIOS to v1.26 as discussed in the bug.

Using BIOS v1.20 the brightness keys were fixed by adding "nomodeset acpi_backlight=vendor" to the grub kernel config.

10.10 (amd64)

Freezes up the computer mostly... still can adjust brightness just not do anything else. Used the following to stop from freezing up everything:

xrandr --output LVDS --set BACKLIGHT_CONTROL native

Alternative fix for 10.10

I couldn't get the xrandr command to work, it would just crash but the following worked for me. Create a file /etc/acpi/ that contains

val=`cat /sys/class/backlight/acpi_video0/brightness`
value=$(echo "ibase=10; obase=16; $value" | bc)
setpci -s 00:02.0 F4.B=$value

set it to be executable with chmod u+x /etc/acpi/

and create two event hook files called /etc/acpi/events/acer_brightup and /etc/acpi/events/acer_brightdown

and fill them with

event=video DD02 00000086 00000000


event=video DD02 00000087 00000000


Now you just have to restart acpid with sudo restart acpid and voila!

Another alternative fix for 10.10 Maverick and 11.04 Natty

The solution valid in 10.04 ("nomodeset acpi_backlight=vendor" in grub) does not work in 10.10 (ubuntu boots in text mode), but it works perfectly with an experimental kernel patch, that I hope it will be incorporated in the official kernel soon, and with just "acpi_backlight=vendor".

Wireless network

Affected model 1810tz with wificard identified as Intel Corporation WiFi Link 100 Series (lspci). Killswitch always off for wireless in 9.04 and 9.10 alpha6. Follow instructions to fix issue.


  1. Download new microcode from put in /lib/firmware

  2. Download latest compat-wireless (2009-09-30 worked) from, follow instructions (install, unload).

  3. sudo modprobe iwlagn or restart

CPU Scaling

To enable 800Mhz CPU scaling for the Intel Core 2 Solo SU3500 just update BIOS 1.27


In order to fix bluetooth in your Timeline(X), copy driver file (thanks to ArchWiki and Xanfer)

sudo cp /lib/firmware/ath3k-2.fw /lib/firmware/ath3k-1.fw


AspireTimeline/Fixes (last edited 2013-09-26 08:21:00 by localhost)