Warning /!\ New page based on the 1810T docs, but updating for an 1830, work in progress: I have to run Maverick for work so I only had some small time with it in Lucid, hoping someone will help me doublecheck. -- jorge 2010-06-28 19:30:45

Added 11.04 on 1830T-5434G32nki 2011-7-14(Michael Becker)

Added 11.04 on 1830t-3721 2011-7-26 (Dave Moten)

Acer Aspire 1830T on Ubuntu 10.04, 10.10 and 11.04


This page aims to describe the steps needed, to fully enable all features of the 1830T when using Ubuntu 10.04, 10.10, 11.04 . Please feel free to add your information to make this page as accurate as possible!


Ubuntu 10.04 supports some hardware components of this netbook.

In one hardware configuration all hardware except the ethernet card is supported. Sound is fully supported. WLAN support works right away. In the system menu, scrolling with the touchpad easily can be configured. Due to the dual core processor, Ubuntu runs with excellent performance on this netbook. Watching movies in HD for example is not a problem, as this netbook is basically a real laptop in a netbook body.

This laptop doesn't have bluetooth or a 3G card in the configuration I purchased (the 68U118 does have Bluetooth).


In another configuration (of the AS1830T-3721), the Broadcom wireless card requires manual installation of restricted drivers. The Atheros ethernet card requires compilation of Atheros source drivers. The ALPS Touchpad is seen as a PS/2 Mouse under Lucid, and neither vertical one-finger edge scrolling not any two-finger scrolling is supported. A third-party psmouse.ko (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/550625/comments/152) allows vertical one-finger scrolling, but no multitouch. Fan control is not supported; the fan runs at a low setting, but temperature under Lucid is higher than under MS-Windows. Power consumption is also higher than under MS-Windows. Bluetooth works with kbluetooth installed. Other hardware works. --

Ubuntu 11.04 supports most of the Hardware (AS1830T-5434G32NKI) OTB except of the internal Microphone. Broadcom Wireless requires manual installation of restricted drivers and a few steps listed under "Wireless Networking" to solve a few Bugs.

Ubuntu 11.04 on 1830t-3721 wifi works well and has no suspend/resume issues after the acer-wmi is blacklisted. See Powersave/Network Manager section below for how to do that. Internal microphone not working (yet).


Acer sells several configurations of the 1830T, including AS1830T-3505, AS1830T-3927, AS1830T-3721, AS1830T-5434, AS1830T-68U118








Intel® Core i3-330UM Mobile Processor

Intel® Core™ i5-430UM Mobile

Intel® Core™ i5-430UM Mobile

Intel® Core™ i7-680UM Mobile


3MB Intel® Smart Cache, 1.2GHz

4MB Intel® Smart Cache, 1.2GHz


3GB (2/1) DDR3 SDRAM

4GB (2/2) DDR3 SDRAM

4GB (2/2) DDR3 SDRAM

4GB (2/2) DDR3 SDRAM


250GB hard drive

320GB hard drive

500GB hard drive

500GB hard drive

All come with Genuine Windows® 7 Home Premium 64-bit version, and various hardware which includes:


11.6 TFT (1366 x 768 (WXGA))


Intel "HD graphics"


Atheros AR928X Wireless or Broadcom


Atheros AR8151 gigabit


Synaptics or ALPS

Card Reader

SD Memory Card, Memory Stick, Memory Stick PRO, MultiMediaCard, xD-Picture Card


  • Feature

    Support status

    Suspend & Hibernate









    IconsPage/ok.png IconsPage/info.png


    IconsPage/ok.png IconsPage/info.png

    Keyboard (Brightness, layout,...)

    IconsPage/ok.png IconsPage/info.png

    External Monitor VGA


    External Monitor HDMI


    Playback HD movies 720p



    IconsPage/ok.png IconsPage/info.png





IconsPage/ok.png (works out-of-the-box)
IconsPage/ok.png IconsPage/info.png (works, with remarks)
IconsPage/warning.png (needs manual install)
IconsPage/dont.png (won't work)
IconsPage/question.png (not yet documented)

Basic Installation Instructions

Warning! Before you install Ubuntu on the 1830T, backup all your data. During the installation procedure, parts of your hard drive will be formated and you will most likely change the size of existing partitions. If something goes wrong during these very critical operations, all your data may be lost! So backup all your data! Keep in mind, that the installation disks of the original operating system of the 1830T are ONLY stored as images on the hard drive. So please, make sure you have backed up all your data before you proceed!

A Quick Guide and the Generic User Guide from Acer can be found on the NTFS partition in the folder book.

Dual Boot Ubuntu and Windows

It is recommended to keep a Windows installation on the netbook. It is at least needed for BIOS updates.

  • Boot Windows and shrink the NTFS partition: English German

  • Get the installation image from Get Ubuntu. If you have a 64 bit processor then you should use the 64 bit ubuntu as it works significantly faster. (If you like to know, whether you have a x86 (=32bit) or x64 (=64bit) windows installation, click right on the system icon in the windows start menu.) Once the .iso file is downloaded, create a bootable USB pen drive either directly on windows (download the USB pendrive application) or on an existing Ubuntu 9.10 computer (create a bootable USB pendrive with the USB-startup-creator tool in the Ubuntu menu under "System" > "Administration")

  • Plug the USB stick into the netbook, turn it on and enter the BIOS by pressing F2. In the boot tab, make sure that the USB stick is at the top of the boot order. Save the changes and leave the BIOS.
  • Ubuntu can now be installed from the stick as usual.

Installation Notes

  • The ethernet card is not supported by the 10.04 kernel unless you install the linux-backports-modules, this makes netinstalling from the current 10.04 net media impossible so you need to either install it via wireless or copy the debs over by hand.

  • The wireless works out of the box, but network-manager has "Enable wireless" unchecked in the UI, this makes it seem like the wireless doesn't work but it does work, it's just a dumb default setting in the UI. When you check it in network-manager the orange wifi light will turn on.
    • Need to investigate to find out where to report this bug.

Powersave / Network Manager bug

This applies for 11.04 on 1830t-3721 and possibly other configurations. It did not apply to 10.10 on 1830t-3721.

Closing the lid will suspend and resume the laptop perfectly, except the network manager will crash; in some cases Wireless will not work at all. To fix this bug:

Press Alt+F2 or open a terminal and excute

gksu gedit /etc/modprobe.d/blacklist.conf

Add the following line:

blacklist acer-wmi

Microphone (From the 1810TZ page, check)

(For Ubuntu 11.10 beta2, Microphone works OTB.) For 10.04 and 10.10 Install the package "linux-backports-modules-alsa-karmic-generic" with the synaptic package manager and the internal microphone should work. (in the Ubuntu system menu under "System" > "Administration" > "Synaptic Package Manager").

To use the terminal to achieve the same thing type :

sudo apt-get install linux-backports-modules-alsa-karmic-generic

Some microphone amplification can be achieved using the sound preferences (in the Ubuntu system menu under "System" > "Preferences" > "Sound" and then access the input tab).

dmjm reports that for Ubuntu 10.10 on 1830T-3712, internal microphone works out of box but some static. dmjm says it was acceptable for Skype use. Anyone got a fix they can report here? Tried this without success:

sudo apt-get install linux-backports-modules-alsa-maverick-generic

Internal MIC with Skype (From the 1810TZ page, check)

To use the internal mic with Skype, start Skype with

/bin/sh -c "PULSE_SERVER= skype" &


For Ubuntu 11.04, Touchpad with Two Finger scrolling works OTB. (From the 1810TZ page, check) Enable scrolling with the touchpad (right edge of the touchpad area) in the Ubuntu menu under "System" > "Preferences" > "Mouse". Then select the touchpad tab and enable the two finger scrolling. Two-finger scroll is enabled by typing these lines in a terminal window :

synclient EmulateTwoFingerMinW=7
synclient EmulateTwoFingerMinZ=20
synclient VertTwoFingerScroll=1

dmjm asks: How do we make these settings persist after logout?


On 1830T-3712, brightness adjustment works fine in Ubuntu 10.10 although I'm pretty sure the icons on the keyboard for dimmer and brighter seem to be reversed.

The brightness adjustment (for which model?) fires off a notification when you use the keyboard but the screen never dims, it runs at full brightness. Echoing the brightness_switch_enabled trick from the 1810T doesn't appear to work on the 1830T (Need to investigate)

Adding the option "acpi_osi=" to the kernel options in grub.cfg solves the brightness issue (at least in ubuntu 10.10):

linux /boot/<kernelimage> root=<rootpartition> ro quiet splash acpi_osi=


If your ethernet isn't working on the 1830TZ-U544 model try tweaking the Grub Command Line as posted here: http://ubuntuforums.org/showpost.php?p=8446793&postcount=12.

Wireless Networking

Someone reports (1830T-3721) Ethernet worked out of the box but the Broadcom Wifi needed proprietary drivers installed. Bluetooth seems to be detected.

dmjm confirms drivers installed fine on 1830t-3721 with Ubuntu 10.10 but that wireless network was very slow (virtually unusable NFS). He fixed this with:

sudo iwconfig eth1 power off

This can be scripted by creating a network interface script called for example powermode

gksudo gedit /etc/network/if-up.d/powermode

with contents:


if [ "$IFACE" = "$DEVICE" -a "$PHASE" = "up" ]; then
  /sbin/iwconfig $DEVICE power off

exit 0


sudo chmod 755 /etc/network/if-up.d/powermode

dmjm reports this does not appear to be needed with 11.04 on 1830t-3721. Wireless networking seems to be lots faster in general.

See also the Suspend/Resume notes.


(From the 1810TZ page, check)

The slot for the SIM-card for the mobile internet connection is located under the battery (Picture from netzwelt.de). The internal modem is basically supported by Ubuntu. If it is properly configured, it can be used alongside with other network connections like WLAN.


Suspend and resume seem to work fine with Ubuntu 11.04 and 10.10 on 1830T-3721/5435. 11.04 on 1830t-3721 now connects to wifi straight away on resume (note that acer-wmi needs to be blacklisted as mentioned elsewhere).

However with 10.10 one problem is that a wireless network connection is doubly turned off when you resume (Broadcom BCM43225 wifi). To reenable you need to tick on Wireless Network in Network Manager and hit Fn+F3 once or three times (!). Fn+F3 seems to cycle through 4 modes corresponding to Bluetooth/Wifi being on/off. Every time you suspend/resume it seems to cycle automatically through one mode. A fix for this would be nice!

dmjm added a script to enable wifi always in Network Manager (you still have to do the Fn+F3 stuff though). You might not want this if you use your laptop on aircraft (although it still has no effect in terms of connecting via wifi till you hit the FN+F3 keys).

gksudo gedit /etc/pm/power.d/20_wifi_on

with contents:

nmcli nm wifi on


sudo chmod 755 20_wifi_on

Christof Krüger proposed to use rfkill commands in the 20_wifi_on file. This should automatically enable the WLAN module without the need to press Fn+F3 any more. dmjm added a test for resume after noting that plugging in power cord also brought about a 30 second reconnect.

## only do this on resume
if [ "x$METHOD" = "xsuspend" ] && [ -z "$PM_CMDLINE" ]; then
  rfkill unblock 0
  rfkill unblock 1
  sleep 10
nmcli nm wifi on

The number of seconds to sleep between using rfkill and nmcli seems a bit random and there might be a more elegant way of doing it.

dmjm confirms this fix works for him (thanks Christof!) though he is seeing a 30 second delay before reconnect to wifi succeeds on resume. Sleep is set at 2 seconds in 20_wifi_on. Relevant lines from /var/log/syslog are

Jan 16 07:12:58 lap avahi-daemon[1123]: Joining mDNS multicast group on interface eth1.IPv6 with address fe80::5eac:4cff:fe86:7140.
Jan 16 07:12:58 lap avahi-daemon[1123]: New relevant interface eth1.IPv6 for mDNS.
Jan 16 07:12:58 lap avahi-daemon[1123]: Registering new address record for fe80::5eac:4cff:fe86:7140 on eth1.*.
Jan 16 07:13:07 lap kernel: [ 3908.990191] eth1: no IPv6 routers present
Jan 16 07:13:14 lap kernel: [ 3916.556870] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=600
Jan 16 07:13:14 lap init: anacron main process (5203) killed by TERM signal
Jan 16 07:13:15 lap kernel: [ 3916.856817] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=600
Jan 16 07:13:18 lap bluetoothd[5436]: Stopping SDP server
Jan 16 07:13:18 lap bluetoothd[5436]: Exit
Jan 16 07:13:22 lap NetworkManager[1120]: <info> Activation (eth1) starting connection 'home'

Note that suspend/resume behaviour is marked as a TODO against the brcm80211 kernel source. See http://wireless.kernel.org/en/users/Drivers/brcm80211.

Power saving tips

Warning! This comes from the 1810T power tips. I am using these and they seem to work, however I don't know exactly how much of this is needed, so I will review them at a later time. Help wanted.

This information is copied from the initial post http://ubuntuforums.org/archive/index.php/t-1341325.html by Patrick Vogeli

By default, an ubuntu install won't take too much care of saving power, which is very important in an ultra mobile laptop. You can easily setup the system to enter some power saving modes, specifically the sata controller and the sound chip.

I've setup a script which will take care of making the devices entering the power saving mode when the laptop is on battery.

# Make sure brightness switch enabled stays on N, even on resume.
echo N > /sys/module/video/parameters/brightness_switch_enabled
# Disable wake on lan
ethtool -s eth0 wol d

# Go fast on AC power. Similar to default Ubuntu settings
if on_ac_power; then
# Remount ext3 filesystems so the journal commit only happens every 60
# seconds. This reduces disk activity.
mount -o remount,commit=5,atime,diratime /
mount -o remount,commit=5,atime,diratime /home

# Set SATA back to normal operation
for foo in /sys/class/scsi_host/host*/link_power_management_policy;
do echo max_performance > $foo;

# Manually set the wifi driver to no power savings.
# broken in 2.6.31 kernel
# iwconfig wlan0 power off

# Set kernel dirty page value back to default
echo 10 > /proc/sys/vm/dirty_ratio
echo 5 > /proc/sys/vm/dirty_background_ratio
echo 600 > /proc/sys/vm/dirty_writeback_centisecs 

# Disable Intel HD audio power saving:
echo 0 > /sys/module/snd_hda_intel/parameters/power_save

else # Save power

# Change the ext3 commit times to 10 minutes. Reduces disk activity
# disable disk writes when reading
mount -o remount,commit=600,noatime,nodiratime /
mount -o remount,commit=600,noatime,nodiratime /home

# Set SATA to save power
for foo in /sys/class/scsi_host/host*/link_power_management_policy;
do echo min_power > $foo;

# Manually set the iwl3945 driver to power savings.
# broken in 2.6.31 kernel
# iwconfig wlan0 power on

# Reduce disk activity by waiting up to 10 minutes before doing writes
echo 90 > /proc/sys/vm/dirty_ratio
echo 1 > /proc/sys/vm/dirty_background_ratio
echo 60000 > /proc/sys/vm/dirty_writeback_centisecs

# Enable Intel HD audio power saving:
echo 10 > /sys/module/snd_hda_intel/parameters/power_save

To install this power saving script, do the following:

gksudo gedit /etc/pm/sleep.d/15_saving

# Paste the script above into the file, save and close

sudo chmod +x /etc/pm/sleep.d/15_saving
sudo ln -s /etc/pm/sleep.d/15_saving /etc/pm/power.d/

Next, let's configure gnome-power-manager, under System -> Preferences -> Power management:

- Hard drive power saving: in the battery tab tick on "Reduce hard drive revolutions when possible" - Battery tab: tick on reduce brightness and dim display. - AC and Battery tab: configure what to do when closing the lid and what to do on very low battery remaining. - General tab: configure what to do when pressing the power button and sleep button (Fn+f4). - General tab: configure when to show the battery icon.

Lm-profiler: Last, but not least, we'll run lm-profiler to start / stop services when running on battery. To do that, disconnect from the mains and open a terminal (Aplications -> Accessories -> Terminal) and run sudo lm-profiler. It will run for 10 minutes and, when finished, it will ask what services to disable / enabled. You can safely disable cron, anacron and atd, if you don't use them. If you don't know what those are, you can dissabled them. If you never use a printer, or you only use it when connected to the mains, you can also disable cups. If in doubt, don't disable.

External monitor with VGA

  • Works out of the box. (Tested with various 1024x768 beamers and an 1920x1200 monitor.)

External monitor with HDMI

(From the 1810TZ page, check)

Known Bugs

None listed.

Please update this page, if you have figured out anything, that is not mentioned here!

Aspire1830T (last edited 2013-12-14 01:18:58 by knome)