Maverick Meerkat 64bit (Ubuntu 10.10 x64)

What works out of the box

  • Audio (including mic)
  • Video (with desktop effects) [IMPORTANT: DO NOT INSTALL NVIDA RESTRICTED DRIVERS]
  • USB
  • Wireless Networking
  • Volume control (Fn+F10/F11/F12)
  • Brightness control (Fn+F5/F6)
  • WiFi switch (Fn+F2)

  • LCD on/off switch (Fn+F8)
  • Multimedia controls (Fn+Up/Down/Left/Right) [Tested with Rythmbox]
  • VGA port
  • Card reader
  • USB 3.0 port with USB 3.0 hardware
  • TurboBoost (can be checked with turbostat utility from package acpidump - frequency is 2.93, but lowers when the CPU become warm)

What hasn't been tested (yet)

  • Hibernate

What isn't working, and no working method is known yet

  • Fingerprint reader
  • HDMI port

What works but needs tweaking

Hard Drive Power Management

Got the solution here.

When running on battery, the default hard drive power saving setting causes the drive heads to continuously park and then ramp up again. This results in a quiet "clicking" sound approximately every five seconds. You can adjust this setting by using hdparm to disable power management or to set it to the least aggressive setting (in the latter case, it will still park the heads though far less often). To do so, open a terminal and type:

sudo gedit /etc/hdparm.conf

Add the following lines (Note: use 255 to disable or 254 to set to the least aggressive setting):

/dev/sda {
    apm = 254
    apm_battery = 254
}

Save and quit. Reboot to apply.

Video driver

Asus U36JC includes a dual mode graphics card (NVIDIA Optimus). This type of cards aren't supported by NVIDIA restricted driver neither by nouveau open source driver.

After installation Ubuntu will offer you installing NVIDIA restricted driver. If you do so, the next time you boot you won't have X. DO NOT INSTALL RESTRICTED DRIVER.

The default Intel card will be sufficient to use full compiz desktop effects.

Boot splash

As usual with Intel cards, Plymouth boot splash will show too late in the boot process. If you want it to appear earlier, type this in a console window:

sudo echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
sudo update-initramfs -u

You might get a little bit slower boot, but it will look much consistent (IMHO).

Bluetooth

(http://www.phlerion.com/blog/exopc/exopc-ubuntu/ original version)

Following script makes bluetooth working:

killall bluetoothd
sleep 1
rmmod btusb
rmmod ath3k
modprobe -a ath3k
echo "13d3 3304" > /sys/bus/usb/drivers/ath3k/new_id
modprobe btusb
bluetoothd

Touchpad

Touchpad works out of the box, but you won't get multitouch capabilities. If you want two finger scrolling, type this in a console window:

wget http://ppa.launchpad.net/utouch-team/utouch/ubuntu/pool/main/s/synaptics-dkms/synaptics-dkms_1.0.0_all.deb
sudo dpkg -i ./synaptics-dkms_1.0.0_all.deb

Then edit "/usr/share/X11/xorg.conf.d/50-synaptics.conf"

sudo gedit /usr/share/X11/xorg.conf.d/50-synaptics.conf

and add

Option "SHMConfig" "1"

before "EndSection". After reboot you can enable two finger scrolling under "System > Preferences > Mouse > Touchpad > Two finger scrolling". If you want two finger horizontal scrolling and palm detection, add also these lines to 50-synaptics.conf:

Option "VertTwoFingerScroll" "on"
Option "HorizTwoFingerScroll" "on"
Option "PalmDetect" "on"

Suspend/Resume

Suspend doesn’t work out of the box because of a problem with the USB buses. To workaround it, create the following file:

sudo gedit /etc/pm/sleep.d/20_custom-asus-u36jc

And paste this script (original version for the Asus U35JC) [remove leading white space in the first line]:

 #!/bin/sh

BUSES="0000:00:1a.0 0000:00:1d.0"
BUSES3="0000:07:00.0"

case "${1}" in
    hibernate|suspend)
        # Switch USB buses off
        for bus in $BUSES; do
            echo -n $bus | tee /sys/bus/pci/drivers/ehci_hcd/unbind
        done
        # Switch USB 3.0 buses off
        for bus in $BUSES3; do
            echo -n $bus | tee /sys/bus/pci/drivers/xhci_hcd/unbind
        done
        ;;
    resume|thaw)
        # Switch USB buses back on
        for bus in $BUSES; do
            echo -n $bus | tee /sys/bus/pci/drivers/ehci_hcd/bind
        done
        # Switch USB 3.0 buses back on
        for bus in $BUSES3; do
            echo -n $bus | tee /sys/bus/pci/drivers/xhci_hcd/bind
        done
        ;;
esac

And make it executable:

sudo chmod +x /etc/pm/sleep.d/20_custom-asus-u36jc

Hibernation

Haven't tested it before applying the above solution, so I don't know if it works out of the box. With the above workaround applied, it works ok. IMHO hibernation is too slow to be used frequently, but it can save your work in case you run your laptop off battery.

Webcam

Webcam works out of the box, but the video will be flipped upside down and left to right. I haven't found a permanent solution for every program using the webcam, but there are some workarounds. First install "gtk-v4l" and "libv4l-0" from libv4l ppa:

sudo add-apt-repository ppa:libv4l
sudo apt-get update && sudo apt-get install gtk-v4l libv4l-0

You can workaround flipped image permanently in Cheese (and supposedly other Gnome native programs that use the webcam) by editing "/etc/environment":

sudo gedit /etc/environment

and adding

LIBV4LCONTROL_FLAGS=3

After reboot Cheese will work OK. Non Gnome native programs, as Skype, will still show the image flipped. You can workaround it by declaring LD_PRELOAD before launching. The following example is for launching Skype from console:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

I've tested it also with Google Chrome and Google Talk audio and video plugin:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so google-chrome

Asus_U36JC/PastVersions (last edited 2011-10-13 14:15:06 by sfmarcos)