Tag/tag.png

Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...


Introduction

There seems to be a great deal of issues surrounding ATI cards. This guide is aimed at ATI cards.

Before We Get Started

Make sure your system is up to date

sudo apt-get update && sudo apt-get upgrade 

You can replace:

  • sudo nano with gksudo gedit

  • sudo apt-get with sudo aptitude

While you can use several methods for InstallingSoftware, I use the Gnome Terminal to install all of the software with 'sudo apt-get'.

For Ubuntu Gutsy Gibbon 7.10

Info (!) This guide will work only for fresh Gutsy Gibbon 7.10 installs. It will not work for upgrades from Feisty.

Enabling ATI Binary driver

Open the restricted drivers manager in "System -> Administration -> Restricted Drivers Manager" and select "ATI accelerated graphics driver". You may need a reboot after that.

If you don't see Restricted Drivers Manager, enable restricted repositories. Select System > Administration > Software Sources and check "Proprietary Drivers for Devices (Restricted)" box.

Install linux-restricted-modules-generic restricted-manager packages using

      sudo apt-get update
      sudo apt-get install linux-restricted-modules-generic restricted-manager

Install XGL

      sudo apt-get install xserver-xgl

Install Compiz Fusion

Make sure you execute the following command in a single line.

      sudo apt-get install compizconfig-settings-manager compiz compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compiz-gnome compiz-plugins libcompizconfig-backend-gconf libcompizconfig0

Run Compiz Fusion

Reboot computer and log in. You should have a functional Compiz Fusion with full 3D support.

For Ubuntu Feisty Fawn 7.04

Info (!) Do not this part of guide for any other version but Fiesty Fawn 7.04.

Getting Your ATI Working

Before we get into anything we should know if your drivers are installed correctly.

Run this command:

fglrxinfo -display :0 

If the command hangs, abort it by Ctrl-C and try a variation

fglrxinfo -display :1 

If it returns something similar to the following, then your card is working:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON XPRESS Series
OpenGL version string: 2.0.6334 (8.34.8) 

If not, then it isn't working yet. Run this command to install the drivers:

sudo apt-get install xorg-driver-fglrx xserver-xorg-video-ati 

Now that your drivers are installed, execute these commands:

sudo depmod -a
sudo aticonfig --initial
sudo aticonfig --overlay-type=Xv 

You'll need to edit your X configuration to get rendering working properly. Run this command to open up the configuration file:

sudo nano /etc/X11/xorg.conf 

Add this to the end of the file. If you have a similar section, make it look like this instead.

Section "Extensions"
        Option          "Composite"     "0"
EndSection 

Save the file and restart your computer.

Configuring Your XGL Session

Info (!) Do not use this section for Gutsy Gibbon 7.10 as it will break XGL.

Now we're going to create a script for XGL:

sudo nano /usr/local/bin/startxgl.sh 

Put this in the file:

Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
exec dbus-launch --exit-with-session gnome-session 

Save and close the file.

In order for it to be any good, we need to make it executable:

sudo chmod a+x /usr/local/bin/startxgl.sh 

Creating Your XGL Session

We'll need to create an XGL option to log in with:

sudo nano /usr/share/xsessions/xgl.desktop 

Put this in the file:

[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Comment=Start an Xgl Session
Exec=/usr/local/bin/startxgl.sh
Icon=
Type=Application 

Save and close the file.

Now restart your computer. When you're logging in, notice the Sessions option. Click that and choose the XGL session you just created.

You make want to make it default because you will need to log in this way every time you want to use CompizFusion.

If you see a thatched background behind your splash screen when you're logging in, then congratulations. You're through the sticky stuff.

Installing CompizFusion

You need to add the repositories to your /etc/apt/sources.list file:

sudo nano /etc/apt/sources.list 

Add these lines to the end:

deb http://ppa.launchpad.net/amaranth/ubuntu feisty main restricted
deb-src http://ppa.launchpad.net/amaranth/ubuntu feisty main restricted 

Since you've done a lot to your computer so far,it would be a good idea to make sure everything is completely up to date:

sudo apt-get update && sudo apt-get dist-upgrade 

Hurray, we have everything set up for CompizFusion. How we need to install CompizFusion itself: Ubuntu using Gnome:

sudo apt-get install compiz compizconfig-settings-manager compiz-gnome 

Kubuntu using KDE:

sudo apt-get install compiz compizconfig-settings-manager compiz-kde 

Run CompizFusion

Alt+F2 then Enter

compiz --replace

Configure CompizFusion

Alt+f2 then Enter

ccsm 

Also: Gnome: System -> Preferences -> CompizConfig Settings Manager KDE: KMenu > Settings > CompizConfig Settings Manager

Start Copmiz When You Login

Method 1: Go to System->Preferences->Sessions Click New Name: CompizFusion Command: fusion-icon

I prefer this method because it gives you a nice icon that will control whether or not CompizFusion loads when you start up.

Method 2: Go to System->Preferences->Desktop Effects and click 'Enable Desktop Effects'

Quick Config

I hope that this section will guide you through a basic setup of what so many people seem to expect.

Run ccsm

ccsm 

Click General Options Open the Desktop Size tab

  • Horizonal Virtual Size: 4 Vertical Virtual Size: 1 Number of Desktops: 1

Click Back Check these plugins:

  • Desktop Cube Rotate Cube

Reload CompizFusion and enjoy. The plugins are somewhat of a maze to get around at first, but they should quickly become easy to understand.

Troubleshooting

Make sure that Composite extension is disabled. It doesn't work with restricted fgrlx driver. The relevant lines in /etc/X11/xorg.conf should read

Section "Extensions"
        Option          "Composite"     "0"
EndSection

If this section is not present, simply place it at the bottom of the xorg.conf file.

Some users complain that their window borders don't appear. I still haven't tracked down the exact problem but I have found that it occures in two instances. The first is when you set a setting that causes a conflict. The best way to fix this seems to be just setting things back to default. To do this, Open ccsm, Click Preferences, Select the Custom profile, Click Reset to defaults. The second is beyond me, but it seems to be fixable by first running

metacity --replace 

then

compiz --replace 

If all else fails, #compiz-fusion on Freenode.


Discuss this page.

CompositeManager/CompizFusionATI (last edited 2009-05-19 06:32:09 by gsawt)