If you experience jumpy DVD playback, slow CD ripping, or a general slow down when accessing optical drive(s) it may be because DMA is not enabled. DMA, or Direct Memory Access, lets hard drives and CD/DVD drives access the system memory.

Ubuntu 6.06 (Dapper Drake) has DMA automatically enabled for drives that support it.

IconsPage/warning.png Warning: Enabling DMA can be dangerous in some cases. Usually issues are directly related to faulty hardware, poorly written drivers, or using settings that are unsupported by your system.


Finding your CD/DVD player

With a disk in the drive, issue the command mount | egrep 'udf|iso9660' and you should see a line like

/dev/scd0 on /media/cdrom0 type udf (ro,nosuid,nodev,utf8,user=you)

This shows the device and where it is mounted in the file system. In this case, the device is /dev/scd0 which indicates you should skip down to the "ATAPI" section.

If the device has a name like /dev/hdc you can continue reading the hdparm section.

Enabling DMA with `hdparm`

To enable DMA, you need to use the hdparm command and the configuration file hdparm.conf.

These instructions assume that you are trying to enable DMA on hdc, usually the CD-rom drive.

  1. See the what the settings are on /dev/hdc

    •    sudo hdparm /dev/hdc
  2. If you get a line like  using_dma    =  1 (on), DMA is already enabled. Skip to step 4 to see if it has been enabled at boot time.

  3. Enable DMA on /dev/hdc

    •    sudo hdparm -d1 /dev/hdc
  4. You have now enabled DMA for the drive. However, in order for the settings to be automatically applied at boot there you need to edit the /etc/hdparm.conf script. To do this use this command: gksudo gedit /etc/hdparm.conf

Add the following to the end of your hdparm.conf

/dev/hdc {
dma = on

(another way of avoiding editing of the hdparm.conf file is to simply run sudo hdparm -d1 -k1 /dev/hdc to keep the DMA flag).

ATAPI DVD drives

If you have an ATAPI DVD drive on a later (>=8.4) version of Ubuntu it is likely to be treated as a virtual SCSI device. DMA is generally turned on by default, but sometimes the generic ATA module doesn't work. If this is the case you see the following symptom when typing:

dmesg | grep ata

One of the lines will be:

ata2.00: simplex DMA is claimed by other device, disabling DMA

If this is the case type the following:

sudo gedit /etc/modprobe.d/aliases

And add the following lines to the bottom of the file:

## Turn on DMA for DVD ############################
alias ata_generic off
alias pata_atiixp on

Reboot and DMA should work. You can verify this by typing:

dmesg | grep ata

Two of the lines will resemble this:

[   23.937141] ata2.00: ATAPI: MATSHITAUJ-845D, D100, max UDMA/33
[   24.108846] ata2.00: configured for UDMA/33


If your drives are configured in [Cable Select] mode and while running hdparm commands you receive errors related to timeouts or drive not ready, try changing the drive to be a master or slave device depending on your system configuration. This does require opening the case and as far as I know most drives are set to Cable Select from the manufacturer.

Sometimes step 3 above can fail with an "Operation Not Permitted" message. You can fix this by editing the file /etc/modules: For an Intel CPU put the lines


above the line ide-cd

For an AMD CPU put the line amd74xx above ide-cd

For a VIA Chipset put via82cxxx above ide-cd

Then reboot and try steps 3-4 again....

If the problem still persists, and you're using a SATA hard drive, then the SATA module has to be loaded first before the ide-cd. Add sata_sil  to the beginning of your /etc/modules file then reboot.

Further reading

The hdparm has further options that may be more risky. They can be seen using the man hdparm command in the terminal.

For a detailed description of DMA visit the IEEE


DMA (last edited 2013-12-13 23:37:29 by knome)