Introduction

Subclipse is an Eclipse plugin that provides project integration with Subversion repositories. Using Subclipse you can checkout, browse, and share code from any Subversion repository.

See : SubVersion

See : Official Subclipse Home Page

See : EclipseIDE

The Chinese translation of thie article.

Subversion support

First of all, install the subversion package (see InstallingSoftware)

Installing Subclipse

The svn/javahl version in Ubuntu 9.04 (jaunty) is 1.5 so you need to install subclipse 1.4, for more info see [http://subclipse.tigris.org/wiki/JavaHL]. JavaHL is provided by the libsvn-java package, which matches the OS architecture's word size. Note that JavaHL does not install in a location that is on Eclipse's default path, so eclipse must be launched with -vmargs -Djava.library.path=/usr/lib/jni.

To install Subclipse:

You need to install the version of subclipse matching your subversion client, for example with

$ svn --version
svn, version 1.6.17 (r1128011)

the right Remote site for subclipse installation is http://subclipse.tigris.org/update_1.6.x For details see subclipse documentation

NOTE: On Ubuntu 9.10+ you may need to install the eclipse-pde package before installing Subclipse.

  • Open Eclipse, go into the menus : Help -> Install New Software...

  • Click "Add..." and add a new Remote Site with URL:  http://subclipse.tigris.org/update  Name: subclipse.tigris.org

  • Select "Subclipse Plugin" and optionally "Subclipse Book"
  • Next, Next, Accept license terms, Finish.
  • Note: You do not need to select the other "integration" packages unless you have Mylyn or Mylar and plan on integrating with them. In fact, the integration packages can break things unless you have the packages they're intended to integrate with.

  • Restart Eclipse

A note on architecture

There is at least one bug forcing Eclipse 3.4 users to use 32-bit Eclipse on 64-bit Ubuntu, necessitating 32-bit compatibility Java and therefore 32-bit JavaHL (libsvn-java), which is not in the repositories. The alternative SVN implementation, SVNKit, is ill-maintained and does not properly handle SSH host key fingerprinting, so JavaHL is still recommended.

Configuring a Subversion Repository

To configure Subclipse to connect to a repository open the SVN Repository Exploring perspective:

  • Click on Window -> Open Perspective -> Other

  • Highlight SVN Repository Exploring -> click Ok

You should now have the SVN Repository view open in the right hand column. Now we can add our Subversion repository url:

  • Right click in the SVN Repository column -> New -> Repository Location

  • Enter the url of your repository -> click Ok

Using Subclipse

Once you've configured your repository you can check out code into a new Eclipse project. You can also create new project from Subversion repositories by:

  • Clicking on File -> New -> Project

  • Expand the SVN folder -> Checkout Projects from SVN

You can upload your code into a Subversion repository by:

  • Right click the project -> Team -> Share Project

  • Highlight SVN -> Next

  • Select a Repository you've already configured and click Next, or choose create a new repository location and click Next.

  • Choose the folder you want to upload to and click Finish.

Once you've shared your project or checked one out you can access most common svn functions by right clicking the project and selecting an item from the Team menu.

Note: Old content about javahl to this page: SubversionAndJavahl. I believe the content is rather old, so if you use javahl please feel free to update the page.

Note: this guide has been tested on Ubuntu 7.06 (Feisty Fawn) and Ubuntu 7.10 (Gutsy Gibbon), and partially tested on Ubuntu 10.04 (Lucid Lynx).



CategoryProgramming

EclipseSubversion (last edited 2012-06-12 14:46:49 by ejn)