F-Spot is a photo management program designed for the Gnome Desktop. It includes all you need to import and organise your photos, perform basic touch-ups, enjoy your photos, and share them with other people.

In Ubuntu, F-Spot can be found in the Applications menu, at Applications -> Graphics -> F-Spot Photo Manager. Once launched you will see the main F-Spot window: If this is the first time you are launching F-Spot, there will be no photos in the F-Spot database. Otherwise you will see a number of photos displayed. Along the top is a row of buttons called the Toolbar, and below that (on the left) is a list of tags in the Tags pane. To the right of the Tags pane is the Timeline, and below the Timeline is the main photo window. Below the Tags pane is a list of information about the selected photo.

Importing Your Photos

The first thing you will need to do with F-Spot is to import some photos to work with. [To do: Add a sentence explaining what "importing" does. For example, does it copy the photos somewhere? If so, where does it put them?] F-Spot handles the importing of photos with its Import dialog, found under the File menu (File --> Import...). You have two options: you can either import photos from a camera or other removable storage device, or tell F-Spot to import some photos already on your hard drive. Both are handled from the same dialog:

FSpot_Import.png

Importing From Camera

When importing photos from a camera or removable storage, simply select the camera or storage device from the drop down list labeled 'Import Source:'. Most cameras should be automatically detected by F-Spot.

Since you are importing from a removable storage device, you'll most likely want F-Spot to copy the photos from the device onto your hard drive. To tell F-Spot to do this, select the box labeled 'Copy files to the Photos folder'. When this option is selected, F-Spot will copy all the photos that it imports into a Photos folder inside your Home Folder, placing the photos in sub folders that are numbered according to year, month and date.

Importing From Your Hard Drive

Importing files from your hard drive is done in almost the same way as importing files from a camera. Instead of choosing a device to copy files from (in 'Import Source:'), choose 'Select Folder...'. This will open another dialog that will allow you to choose a folder on your hard drive to import photos from. Since the files are already on your hard drive, usually you will not tell F-Spot to copy the photos to the Photos folder, as this will create duplicate copies of the photos on your hard drive.

Once you have selected an Import Source F-Spot will begin scanning that location or device for photos. If you want F-Spot to also scan sub folders, tick the box labeled 'Include subdirectories'. As F-Spot scans the Import Source it will display all the photos that it finds in a pane on the left of the Import dialog. Clicking on one of these photos will allow you to see a larger version of the photo in the pane on the right.

Quite often you will want F-Spot to attach a tag (see below) to your photos as it imports them. To enable this tick the box labeled 'Attach Tag:' and then select a tag from the drop down list. The selected tag will then be attached to every photo imported.

Organising Your Photos

Once you have imported some photos, the next step is to organise them. Since many users may end up with several thousand photos in their collection, some method of organisation is important in making sure photos are easy to find again.

Tags

Photos in F-Spot are generally organised by using tags. All tags can be given an icon and a name. Tags are similar to folders or directories in that they can be nested; one tag may be the parent of another tag. However, unlike folders, you can attach as many tags as you like to any photo. For example, one photo may have both a 'Favorites' tag and a 'Family' tag attached to it.

FSpot_Tags.png

Once you have attached tags to photos, you can tell F-Spot to display only photos with certain tags attached by selecting and deselecting tags in the Tags pane on the left of the main F-Spot window. More than one tag can be selected at a time, and selecting one tag will also select all sub tags. When no tags are selected, F-Spot will display your entire collection of photos.

Creating Tags

By default F-Spot comes with a number of tags already created. However, it is very easy to create your own tags. If you right click on an existing tag and select 'Create New Tag', the new tag will, by default, be nested below that tag. A new tag can also be created by selecting Tags --> Create New Tag... . This will display the 'Create New Tag' dialog. In this dialog you can choose another tag to be the parent of the new tag, and you must give the new tag a name. Click 'OK' to create the new tag.

FSpot_NewTag.png

Editing Tags

You can also edit any existing tags. To edit a tag, find the tag in the Tag pane on the left of the main F-Spot window. Right click the tag and select 'Edit Tag'. This will bring up a dialog that allows you to change the icon of the tag, the tag's parent tag, and the name of the tag. Clicking 'OK' will save any changes you have made.

To change the icon that represents a tag, click on the button with the existing icon on it. This will bring up the 'Edit Icon' dialog. You can either select an icon from one of the many provided icons, or choose a part of one of the photos to which the selected tag is attached for an icon. To choose one of the provided icons, simply click on it. To make your own icon, choose the number of the photo you would like to make an icon from using the box on the right of the dialog. All the photos represented by the selected tag are numbered in the order they are displayed. Once you have the photo you would like to make an icon from, you can use the mouse to select a region of the photo for an icon. The Preview are shows you how your selection will appear once it is shown as an icon. Click 'OK' to save your changes.

FSpot_EditIcon.png

Attaching Tags to Your Photos

There are a few ways to apply a tag to photo(s). (Taken from www.f-spot.org)

  • Drag and drop the photo(s) onto the tag
  • Drag and drop the tag onto the photo(s)
  • Right click on the photo, and choose Attach Tag -->

  • Through the Tags menu or the Edit menu
  • By typing them in (press 't' to pop up the tag entry bar so you can enter comma-separated tags)

Viewing Your Photos

There would be no point having all your photos without being provided with an opportunity to view them. F-Spot provides you with a number of ways to view your collection.

Browsing Photos

The main F-Spot window allows you to browse through your photo collection. By default, F-Spot will display your photos in chronological order, from the oldest to the newest. You can change this in the View menu, by selecting View --> Arrange By --> or by selecting View --> Reverse Order . Double clicking on a photo will allow you to see the photo larger, and also changes you from Browse mode to Edit mode (see below). The small slider on the lower right allows you to change how many photos are displayed at a time. Sliding it to the left will make the photos appear smaller and allow you to see more at a time, and sliding it to the right will do the opposite.

FSpot_Main.png

The Timeline

The Timeline is the band that appears across the top of the photo display pane. The Timeline allows you to immediately jump to any month. The bars shown in the Timeline represent the amount of photos present in your collection that were taken in that particular month. Clicking on the bar for a certain month will move the focus of the browse window to the first photo of that month.

FSpot_Timeline.png

Fullscreen and Slideshow

F-Spot comes with two additional features to allow you to enjoy your photos. These are the Fullscreen and Slideshow modes. Both of these modes will use the entire screen to display your photos as large as possible. They can be activated using the buttons in the toolbar, or by selecting View --> Slideshow or View --> Fullscreen. Fullscreen mode can also be activited by pressing the F11 key.

When Slideshow is activated, F-Spot will display your photos one after the other. In Fullscreen mode your photo will be displayed on the entire screen. You can exit from Slideshow or Fullscreen mode by pressing the Esc key, or (in Fullscreen mode) by pressing the 'Exit Fullscreen' button. It is also possible to zoom in and out of your photo by using the + and - keys on your keyboard. The mouse can then be used to drag the picture around.

FSpot_Fullscreen.png

Editing Your Photos

Not all photos are perfect. That's why F-Spot includes a number of tools that allow you to do basic touch ups on your photos, and correct the most common problems. Most of the options for editing photos are accessed from the Edit mode, which is activated by double clicking on a photo or clicking Edit Photo in the toolbar.

Versions

In order to make sure your original photos are never destroyed, F-Spot will keep them and save any changes as versions. This means that any edits to your original photo are stored as a separate version, so you can always view any version, including the original.

FSpot_Versions.png

You can change between versions by using the drop down list to the right of the photos (above), or by using the File --> Version --> menu item. The File menu also contains options to create new versions, delete versions, or give your version a different name.

Cropping

FSpot_Crop.png

Quite often you will want to remove parts of a photo, so that only the subject is visible. F-Spot allows you to do this with the Crop tool, accessible from Edit mode. It appears along with the other editing tools below the photo that you are editing. To crop a photo, use your mouse to select a part of the picture. Click the Crop button to crop the picture to that selection (ie, to remove all parts of the picture not selected). If you want to crop your photo to a certain shape, use the Constraint drop down list to select a certain shape.

Removing Red Eye

FSpot_Redeye.png

Sometimes a photo taken with a flash has red eye - the subject's eyes appear bright red. To fix red eye in F-Spot, first use the mouse to select the region of the photo that contains the red eye that you want to fix. Then click the Red Eye button, and F-Spot will remove the red eye from the selected region.

Adjusting Colours

FSpot_Colours.png

If you would like to adjust the colours of your photo, F-Spot includes the colour adjustment tool. This tool is launched using the colours button below the photo in Edit mode, and allows you to adjust the brightness, contrast, exposure and many other aspects of the photo's colours.

Converting to Sepia or Black & White

FSpot_Sepia.png

F-Spot also allows you to convert your photo to sepia or to black and white. To access either of these options, just click the appropriate buttons below the photo in Edit mode. The button on the far right of the edit buttons will change the photo to sepia, and the button on its left will change it to black and white.

Exporting Your Photos

F-Spot allows you to share your photos with others by means of its Export functions. Using these functions allow you to export your photos to many web services and local folders, as well as burning cds. In order to export your photos, you will first need to select all the photos that you would like to export. Once you have selected your photos, go to the File menu, and choose File --> Export --> and choose the appropriate option. Once you have the Export dialog open, the photos that are going to be exported will be displayed in a pane on the left of the dialog.

Exporting to Flickr

Flickr (www.flickr.com) is a service that allows you to publish your photos to the web for others to view, using your Flickr account. Before you can use this export function in F-Spot, you will need to create a Flickr account.

Choose File --> Export --> Export to Flickr... to bring up the Flickr Export dialog. If this is the first time using the Flickr export you will need to click the Authorize button to allow F-Spot to upload photos to your Flickr account. This will launch a web page asking you for authorization. Once you have allowed F-Spot to upload photos, press the Complete Authorization button in F-Spot. If done correctly, the F-Spot dialog should now read 'Welcome <user name> you are connected to Flickr.Com'. If you have the 'View photos in browser when done uploading' box selected, F-Spot will open your Flickr page once you have finished uploading.

You can either make your photos Private or Public. If they are Public, anyone can view your photos. If they are Private, only those users you allow can view your photos. F-Spot also allows you to set your photos as visible to friends or family.

FSpot_ExportFlickr.png

Exporting to Picasaweb

Picasaweb (picasaweb.google.com) is similar to Flickr but is designed to interface with Google's Picasa. You can use Picasaweb with a normal Google account. To export from F-Spot to Picasaweb, go to File --> Export --> Export to Picasaweb... to bring up the Picasaweb Export dialog. If you have not used Picasaweb Export from F-Spot before, you will need to add a gallery. Click the Add button next to the Gallery drop down list, and type in your Google Account user name and password. You can add as many galleries as you like, each associated with one Google Account.

FSpot_ExportPicasa.png

FSpot_WebGallery2.png

Exporting to a Folder

Exporting to a CD

F-SpotHowto (last edited 2010-06-13 03:44:59 by david-dbooth)