Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...


This guide is meant to help get the Gigabyte T1005 netbook working with Ubuntu 11.10.


What works out of the box

  • Graphics
  • Sound
  • Wifi
  • Bluetooth
  • Special keys on the keyboard
  • eSata
  • Card Reader
  • Webcam
  • 3G (standard PCI Express mini card, tested Ericsson F5521gw for Lenovo)
  • external VGA

Fixes available

  • Touchpad
  • Sleep/Hibernate fail
  • Sleep on Power removal
  • Lid Button registers as permanently closed
  • Touchscreen when rotating screen
  • Side Hard Button (battery level/SmartManager in Windows)
  • Keyboard keys get "stuck" (bug 769103)

  • Touchscreen configuration (T1005P only)

Not Tested

  • usb 3



Modify /etc/defaults/grub and modify the "splash quiet" line by including 'i8042.noloop=1'. Afterwards run update-grub2. You can test this by adding 'i8042.noloop=1' in the grub menu at boot. (From this post) See bug #737482.

Sleep/Hibernate fail

This is related to the USB 3 not unbinding (see this thread)

  • In /etc/pm/sleep.d create a new script: 20_custom-xhci_hcd

# File: "/etc/pm/sleep.d/20_custom-xhci_hcd".
case "${1}" in
              # Unbind xhci_hcd for first device 0000:02:00.0:
               echo -n "0000:02:00.0" | tee /sys/bus/pci/drivers/xhci_hcd/unbind
              # Bind xhci_hcd for first device 0000:02:00.0:
              echo -n "0000:02:00.0" | tee /sys/bus/pci/drivers/xhci_hcd/bind

Sleep on Power removal

This is a symptom of Lid Button registers as permanently closed. The default power setting is to sleep on lid close when on battery so when the power is removed the computer sleeps. Disable sleep on lid close in System > Preferences > Power Management by change When Laptop Lid is Closed from suspend to blank.

Lid Button registers as permanently closed

This problem isn't fully resolved at the moment but you can make your device to sleep on lid close (it does wakeup on lid open out of the box). Edit /etc/acpi/lid.sh as follows:

    for x in /tmp/.X11-unix/*; do
      displaynum=`echo $x | sed s#/tmp/.X11-unix/X##`
      if [ x"$XAUTHORITY" != x"" ]; then
        export DISPLAY=":$displaynum"
-       . /usr/share/acpi-support/screenblank
+       GS_PID=`pgrep -u $user -f "gnome-screensaver"`
+       export DBUS_SESSION_BUS_ADDRESS=`grep -z DBUS_SESSION_BUS_ADDRESS /proc/$GS_PID/environ | sed -e 's/DBUS_SESSION_BUS_ADDRESS=//'`
+       su $user -c 'dbus-send --session --type=method_call --dest=org.gnomeScreenSaver /org/gnome/ScreenSaver org.gnome.ScreenSaver.Lock'
+   pm-suspend

Touchscreen when rotating screen

  • Use xrandr -o [normal,right,inverted,left] to rotate the screen

  • Use xinput set-prop to rotate the Touchscreen to match

    • Find the touchscreen device number with xinput list|grep Cando | grep -o 'id=[0-9]*' | sed 's/id=//' e.g. 10

    • Use:
      • normal:
        • xrandr -o normal && xinput set-prop 10 "Coordinate Transformation Matrix" 1, 0, 0, 0, 1, 0, 0, 0, 1

      • right:
        • xrandr -o right && xinput set-prop 10 "Coordinate Transformation Matrix" 0, 1, 0, -1, 0, 1, 0, 0, 1

      • inverted:
        • xrandr -o inverted && xinput set-prop 10 "Coordinate Transformation Matrix" -1, 0, 1, 0, -1, 1, 0, 0, 1

      • left:
        • xrandr -o left && xinput set-prop 10 "Coordinate Transformation Matrix" 0, -1, 1, 1, 0, 0, 0, 0, 1

Side hard button (SmartManager)

You can get the button to work using gb-wmi DKMS module which is hosted on https://launchpad.net/~ivzave/+archive/gigabyte. To install open a terminal and enter following commands:

sudo apt-add-repository ppa:ivzave/gigabyte
sudo apt-get update
sudo apt-get install gb-wmi

Reboot to load the module (it will be loaded automatically on system boot) or manually start it:

sudo modprobe gb-wmi

Then you can bind the button to any action of your choice (e.g. screen rotation) using System Settings > Keyboard > Hotkeys.


Use System > Preferences > Keyboard and uncheck Repeat Keys This will prevent multiple key presses when a key gets "stuck". See bug 769103 for a better workaround that makes autorepeat work almost as expected.

Touchscreen configuration (T1005P only)

Device is equipped with IDEACOM IDC 6650 touchscreen. Its support is enabled in newest hid-multitouch driver but that driver isn't used by current Ubuntu at the moment. You need to do the following:

  • get your kernel source
  • manually apply changes listed in this patch

  • recompile hid.ko and hid-multitouch.ko modules
  • replace the modules in your kernel by updated ones
  • depmod -a && update-initramfs -u

  • reboot

The touchscreen then performs well and handles gestures up to dual-touch with ginn or touchegg running.

To Do


If you have any solutions please update this page or send them to XRayA4T

GigabyteT1005 (last edited 2017-09-06 17:30:42 by ckimes)