Printers probably working

(List is taken from http://www.gentoo-wiki.info/Lexmark_Printers) Models similar to these should also work:

  • Lexmark 5700 (using udev - black & white only)

  • Lexmark X1100 (using udev)
  • Lexmark X1110 (using devfs)
  • Lexmark X1130 (using devfs, only Printing)
  • Lexmark X1140 (using devfs, only Printing)
  • Lexmark X1150 (using devfs, using udev: black & white only)

  • Lexmark X1170 (using udev)
  • Lexmark X1185 (using devfs and udev)
  • Lexmark X1190 (using udev, only Printing; somewhat slow...)
  • Lexmark X1195 (using udev)
  • Lexmark X1270
  • Lexmark Z25 (using devfs and udev)
  • Lexmark Z35 (on Ubuntu 5.04 Hoary, using udev) -- Had to install PPD manually due to several errors.
  • Lexmark Z55 (using udev)
  • Lexmark Z513 (using udev)
  • Lexmark Z515 (using devfs and udev)
  • Lexmark Z517 (using udev)
  • Lexmark Z600 (using udev)
  • Lexmark Z605 (using devfs and udev ) -- Personal note: thank you for this tutorial!
  • Lexmark Z605 (on Debian Sarge without neither devfs nor udev) -- thank you very much Smile :-)

  • Lexmark Z611 (using devfs and udev)
  • Lexmark Z612 (devfs) - http://florian-konnertz.de thanks a lot for this detailed howto!

  • Lexmark Z615 (using devfs and udev)
  • Lexmark Z640 (even as a network printer)
  • Lexmark Z705 (using udev)
  • Dell A920 (using devfs, z600 driver)
  • Dell A920 (using udev, z600 driver)
  • Dell Photo 720 (using udev, z600 driver)
  • Lexmark P3150 (using udev, z600 driver, w/ some shading issues )

Specific Model Installation Packages

The following is a list of deb packages and resources for installing various Lexmark printer drivers. Generally, packages should be set up such that, once installed, a user need only select the appropriate printer from the System->Administration->Printing dialog when adding a new printer:

Lexmark Z600 Series Printers

Installation on Ubuntu 10.04.1 LTS

Follow the instructions for Ubuntu 9.10 below but get the libstdc++5 from http://packages.ubuntu.com/lucid-backports/libstdc++5

Installation on Ubuntu 9.10

  1. Download and install the Jaunty version of libstdc++5: http://packages.ubuntu.com/jaunty/libstdc++5 (alternative : http://packages.ubuntu.com/karmic-backports/libstdc++5)

    1. 32-bit:
      • Download the i386 version of libstdc++5.
      • Install the .deb package as usual.
    2. 64-bit:
      • Download the i386 AND amd64 versions of libstdc++5.
      • Install the amd64 version as usual. (This is just to satisfy the dependencies of the custom .deb driver package)
      • Install getlibs: http://ubuntuforums.org/showthread.php?t=474790

      • Install the i386 version of the libstdc++5 package by using:
        •     $ getlibs -i libstdc++5_3.3.6-17ubuntu1_i386.deb
  2. Download and install the following package: lexmark.z600-0.4.deb

  3. Install the printer using the Lexmark Z600 driver:
    1. Ubuntu: System->Administration->Printing->New

    2. Kubuntu: System settings->Printer configuration->New printer->New network printer

Notes

  • The Dell photoprinter 720 is just a rebranded Lexmark Z600 printer.
  • When the printer cannot take in a page, its light starts blinking. Under Windows, it was only necessary to push the paper further in and press the blinking button to resume printing. This does not seem to work under Ubuntu unfortunately. This means that printing more than one page is problematic.

Other

Z6XX, Ubuntu 8.04

Z6XX, Ubuntu 8.10

Z6XX, Ubuntu 9.10 (WARNING: Installing this package destroyed my fstab file. It also did not work for me. (64bit))

http://www.hackourlives.com/ubuntu-10-04-lucid-lynx-libstdc-so-5/

Lexmark Z700 Series Printers

Proceed the same way as for the z600 series, except with this package: lexmark.z700-0.4.deb

The package was made from the RPMs available here: http://users.cybercity.dk/~dko12479/

Contents of the debian package: lexmark.z700-0.3.tar.gz

Lexmark X1270 Series Printers

Should work with the z600 drivers. Follow the instructions for the z600 series.

Lexmark X1100 Series Printers

Introduction

How to install a Lexmark X1100-series, probably working for other multifunc printers as well. Instructions for "Ubuntu 6.06LTS (Dapper drake)"

Most is taken from http://www.ubuntuforums.org/showthread.php?t=49714 but it is adapted to Ubuntu 6.06LTS (Dapper drake) so that your system still will work after installation.

Installing the Z600 Driver

NOTE1: Try following the instructions for the z600 series before trying this.

NOTE2: You can also simply select, as printer model, Lexmark Z600.

1. Open a terminal (Applications > Accessories > Terminal) and follow these steps

2. Make sure you have installed the following packages

sudo apt-get install libstdc++5 alien

The Lexmark Z600 Driver is 32bit. If you are using the 64bit architecture instead, you need to install instead the whole 32bit library:

sudo apt-get install ia32-libs alien

3. You have to download the Lexmark driver from http://gentoo-wiki.com/HOWTO_Lexmark_Printers

mkdir lexmark
cd lexmark
wget http://www.downloaddelivery.com/srfilecache/CJLZ600LE-CUPS-1.0-1.TAR.gz

4. Then you have to extract the content

tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

5. You now have a lot of files in your current directory, the driver is buried inside a shell-script, and you have to dig it out:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz

6. Unpack your new tar-archive:

tar -xvzf install.tar.gz

7. Unfortunately Lexmark has only given you .rpm-packages, and you have to extract the content of those:

alien -t z600cups-1.0-1.i386.rpm
alien -t z600llpddk-2.0-1.i386.rpm

8. Now you have to extract the newly made tgz-files which contains the drivers, and copy them to their locations. !!! Important: do exactly as written, otherwise your system may become ruined !!!

tar -xvzf z600llpddk-2.0.tgz
tar -xvzf z600cups-1.0.tgz
cd usr
sudo cp -a * /usr
sudo ldconfig # Reloading library-database

9. The drivers are now installed and copied to their locations. Test everything out with the following command:

/usr/lib/cups/backend/z600

10. If the output is something similar to this:

direct z600:/dev/usblp0 "Lexmark  Lexmark X1100 Series" "Lexmark Printer"

Then it is working.

11. Reload CUPS:

sudo /etc/init.d/cupsys restart

12. Make sure your printer is plugged in and go to System > Administration > Printing and double click New Printer. In the first screen, select your printer and click Forward. In the second screen, click Install Driver and navigate to /usr/share/cups/model/ then double click Lexmark-Z600-lxz600cj-cups.ppd.gz. Click Forward twice and your printer should be installed. If your printer does not show up, repeat this step. Print a test page and check for shading issues.

Shading Problems

In some cases the black ink will print about .5 inches to the left more than it is supposed to. To fix this problem:

1. Open a terminal (Applications > Accessories > Terminal) and follow these steps

2. Navigate to the folder your driver is in

cd /usr/share/cups/model/

3. Edit your driver file

sudo gedit Lexmark-Z600-lxz600cj-cups.ppd

Look for anywhere that says CMYK and change it to CMY. Save and close the file

4. Make sure your printer is plugged in and go to System > Administration > Printing and delete the previous printer you created if any. Click New Printer. In the first screen, select your printer and click Forward. In the second screen, click Install Driver and navigate to /usr/share/cups/model/ then double click Lexmark-Z600-lxz600cj-cups.ppd. Click Forward twice and your printer should be installed. If your printer does not show up, repeat this step.

General Setup

This section contains instructions for setting up Lexmark printers supported by Lexmark's proprietary printer drivers. These instructions have been tested on Ubuntu 6.06 LTS and are current as of July 27, 2006.

Note that many, but not all, Lexmark printers have Linux drivers, and most of these drivers are proprietary and closed source. These instructions should work with all Lexmark monochrome and color laser printers, most or all multifunction printers, but will probably not work with inkjet or all-in-one printers.

I have also been told that the printers that work with the Lexmark proprietary drivers can also be set up as generic postscript printers, but I am not sure how that works or the appropriate protocol to use to communicate with a networked Lexmark printer. http://linuxprinting.org/ might have more information if this is how you want to access your printer.

Get the Lexmark printer drivers for Linux

The linux drivers for Lexmark printers can be download at:

http://downloads.lexmark.com/

Choose a model (the "C510" worked for me) and choose the driver for "Debian GNU/Linux". Ubuntu is currently not in the list of supported OS's, but the Debian driver works.

Installing the drivers and setting up a printer

The driver package can either be installed by navigating with Nautilus to its location and double clicking on the icon or from a terminal with the following command:

$ sudo dpkg -i print-drivers-linux-glibc2-x86.deb

where "print-drivers-linux-glibc2-x86.deb" should be replaced with the path and filename of the downloaded package if you saved it under some other name.

After driver installation, you will need to setup up lexprint, the Lexmark printer management system. Execute the following command from a terminal and follow the onscreen instructions:

$ sudo /usr/local/lexmark/setup.lexprint

The default settings should work fine for most users. Make sure to select cups as the printing system and create symlinks to lexprint so it is easy to execute.

After installation, the lexprint printer management program should be run to setup a printer. To add printers, execute from a terminal window:

$ sudo lexprint

To add a printer, you must first create a device and then associate a print queue with that device. For the print queue settings, I recommend using automatic language determination (i.e. setting up both PCL and PS print queues), as I have had difficulties using just one or the other.

The lexprint software can also be accessed via Applications->System Tools->Lexmark Print Drivers (you may have to restart gnome to see this menu entry), however this will run lexprint without administrative privileges. Without administrative privileges, lexprint can be used to list already setup printers and change printer settings (which cannot be changed via the normal Gnome printer interface) for the current user, but will not allow you to add devices or print queues.


Troubleshooting

Permission problems

When I initially installed the drivers and tried to setup a printer, I had problems associating a queue with a printer device. Each time I tried, lexprint would say "Creating print queue Lexmark failed.". This was because the permissions on the /etc/cups/interfaces directory would not allow lpadmin to work properly when run by lexprint. This problem was resolved via the following command:

$ sudo chown cupsys:lp /etc/cups/interfaces

If /etc/cups/interfaces does not exist then create it and change the group to lp

$ sudo mkdir /etc/cups/interfaces
$ sudo chown root:lp /etc/cups/interfaces
$ sudo chmod g+w /etc/cups/interfaces

If you have trouble using lexprint to add printers, then try this fix.

Margin problems

Problems with Ubuntu 9.10 Karmic

If you are using Ubuntu 9.10 Karmic, you may need to install libstdc++5 from the Jaunty repositories.


CategoryHardware

HardwareSupportComponentsPrinters/LexmarkPrinters (last edited 2011-05-20 00:19:50 by rocket2dmn)