UNetbootin (Automated, graphical approach)

UNetbootin for Mac OS X can be used to automate the process of extracting the Ubuntu ISO file to USB, and making the USB drive bootable. The resulting USB drive, however, can be booted on PCs only. If attempting to make a USB drive that can be booted from a Mac, follow the instructions below.

Manual Approach

We would encourage Mac users to download Ubuntu Desktop Edition by burning a CD for the time being. But if you would prefer to use a USB, please follow the instructions below.

Note: this procedure requires an .img file that you will be required to create from the .iso file you download.

TIP: Drag and Drop a file from Finder to Terminal to 'paste' the full path without typing and risking type errors.

  • Download the desired file
  • Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)

  • Convert the .iso file to .img using the convert option of hdiutil

    hdiutil convert /path/to/ubuntu.iso -format UDRW -o /path/to/target.img
  • Note: OS X tends to put the .dmg ending on the output file automatically.
  • Run

    diskutil list
    to get the current list of devices
  • Insert your flash media
  • Run

    diskutil list
    again and determine the device node assigned to your flash media (e.g. /dev/disk2)
  • Run

    diskutil unmountDisk /dev/diskN

    (replace N with the disk number from the last command; in the previous example, N would be 2)

    • If you see the error "Unmount of diskN failed: at least one volume could not be unmounted", start Disk Utility.app and unmount the volume (don't eject).

  • Execute

    sudo dd if=/path/to/downloaded.img of=/dev/diskN bs=1m
    (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).
  • Using /dev/rdisk instead of /dev/disk may be faster.

    • If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.

    • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start Disk Utility.app and unmount the volume (don't eject).

  • Run

    diskutil eject /dev/diskN
    and remove your flash media when the command completes
  • Restart your Mac and press alt while the Mac is restarting to choose the USB-Stick

MacBook Air 3,2

Please notice: While all of the info and above commands are executed properly on a MacBook Air 3,2 (that is the 2010 version 13" version of the Air) the end result will not produce a bootable USB device, at least not with the image for Ubuntu 10.10 64-bit. When booting of the USB device the following message or something similar will appear: "Missing operating system" and the process is auto-magically halted.

To get the USB device (e.g. a USB stick) to show up at all in the boot menu you also may have to reboot/turn on/off the computer a couple of times and also resync the partition tables using rEFIt. After doing this the USB should then appear as a bootable device while holding in the alt or c key when you are rebooting the computer. Notice that both the computers built in bootloader and rEFIt will identify the USB device as a Windows device, but that's not a problem and expected.

A workaround to the-usb-device-is-not-booting-problem is to:

  • Install rEFIt.
  • Create a bootable start disk using Ubuntu and a USB stick.
  • Create a separate partition on the Airs HD.
  • dd the whole USB stick to that partition.
  • Resync with rEFIt. Turn power off and on.
  • Select Pingo/Windows logo: Install should start. (Here you might want to press F6 to change parameters, e.g. use nomodeset)

Alternatively, burning a CD and installing via an external CD-drive will work fine on the Macbook Air 3,2.

Other procedure

(Moved from Installation/FromUSBStick)

We would encourage Mac users to download Ubuntu Desktop Edition by burning a CD for the time being. But if you would prefer to use a USB, please follow the instructions below. Note: this procedure requires an .img file that you will be required to create from the .iso file you download. TIP: Drag and Drop a file from Finder to Terminal to 'paste' the full path without typing and risking type errors.

  • Download the desired file
  • Open the Terminal (in /Applications/Utilities/ or query Terminal in Spotlight)

  • Convert the .iso file to .img using the convert option of hdiutil (e.g., hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso)

Note: OS X tends to put the .dmg ending on the output file automatically.

  • Run diskutil list to get the current list of devices

  • Insert your flash media
  • Run diskutil list again and determine the device node assigned to your flash media (e.g., /dev/disk2)

  • Run diskutil unmountDisk /dev/diskN (replace N with the disk number from the last command; in the previous example, N would be 2)

  • Execute sudo dd if=/path/to/downloaded.img of=/dev/rdiskN bs=1m (replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).

  • Using /dev/rdisk instead of /dev/disk may be faster.

  • If you see the error dd: Invalid number '1m', you are using GNU dd. Use the same command but replace bs=1m with bs=1M.

  • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the 'Disk Utility.app' and unmount (don't eject) the drive.

  • Run diskutil eject /dev/diskN and remove your flash media when the command completes

  • Restart your Mac and press Alt while the Mac is restarting to choose the USB-Stick

How to install Ubuntu on MacBook using USB Stick (last edited 2013-04-30 12:21:08 by CPE-124-181-128-191)