Needs Expansion
This article is incomplete, and needs to be expanded. More info...


Candidate for Deletion
This article may not be appropriate for this wiki, and may be deleted. More info...

Your make-kpkg kernel may not automatically load capabilities. This is how to add it:

Start with your custom kernel and do following:

$ echo capability | sudo tee -a /etc/modules
sudo mkinitrd -o /boot/initrd.img-$(uname -r) $(uname -r)

If you use a bootloader not handling changes by itself (e.g. lilo) you have to tell it about the new initrd.img.

From CedricVeilleux Fri Apr 8 16:25:34 +0100 2005 From: Cedric Veilleux Date: Fri, 08 Apr 2005 16:25:34 +0100 Subject: uname -r ??

The commands above uses uname -r to get the version of the running kernel.

If you are setting up a kernel to boot it, you are not yet running it. All references to uname -r should be changed to the new kernel name...


KernelDoesNotSupportCapabilities (last edited 2017-09-03 21:14:33 by ckimes)