Libero SOC is a proprietary FPGA design software from Microsemi, formerly Actel. It has a free one year licence option with some restrictions. Current version is 11.2. This page contains tweaks to get it working in 64bit Ubuntu 12.04 LTS. Currently most things work but the help is missing something to launch a webbrowser.

Update: having issues with version 11.4 and Ubuntu 14.04 LTS. Designer often segfaults with a designer_bin[21388]: segfault at d0 ip 00000000f140671d sp 00000000ff8b3100 error 6 in[f13e9000+20000]



Install the following packages:
libmotif4:i386 libmotif3 libmotif-dev nspluginwrapper lib32z1 libc6-i386 rpcbind xfonts-100dpi xfonts-75dpi ksh
Run the rpcbind with -i, this is sometimes deemed unsafe so be advised.
Create a tmp folder wich is writeable in /usr
Add fonts, this step might not be necessary since i think a reboot after the installation of the xfonts was the actual solution. *SystemFontSpec:-adobe-utopia-bold-i-normal--0-0-0-0-p-0-adobe-standard *SystemFont:-adobe-utopia-bold-i-normal--0-0-0-0-p-0-adobe-standard

Script to do all these things

sudo apt-get install libmotif3 libmotif-dev libmotif4:i386 nspluginwrapper lib32z1 libc6-i386 rpcbind xfonts-100dpi xfonts-75dpi ksh

echo 'OPTIONS="-w -i"' | sudo tee /etc/default/rpcbind
sudo service rpcbind restart
sudo mkdir /usr/tmp
sudo chmod uga+rwx /usr/tmp
echo "*SystemFontSpec:-adobe-utopia-bold-i-normal--0-0-0-0-p-0-adobe-standard" > font_tmp.txt
echo "*SystemFont:-adobe-utopia-bold-i-normal--0-0-0-0-p-0-adobe-standard" >> font_tmp.txt
xrdb -merge font_tmp.txt
rm font_tmp.txt



Download the latest linux version of Libero SOC from microsemi and install, unpack and run as sudo.

Install, unpack, the latest flexlm tools.

Request a licence file from microsemi, based on MAC.

Setting up the environment for the Libero SOC

Environment variables

LOCALE = C seems to be necessary, but this is not really certain since my reboot might have cured the issue.
LD_LIBRARY_PATH needs to contain the path to the 32 bit X libraries, including motif, in my case /usr/lib/i386-linux-gnu/
LM_LICENSE_FILE needs to be set to the license server, not the file!!!
SNPSLMD_LICENSE_FILE needs to be set to the license server, not the file!!!

Run the license manager

<path to binary>/lmgrd -c <path to license file>/License.dat -l <path to where you want to log stuff>/license.log

Start the program

<path to installation>/Libero/bin/libero

Network Drives

For SMB mounts, option noserverino might be required to allow Libero SOC to read the files and directories.

My way of running the program

Script, modify as per your installation. This script assumes that the licensing daemon was unpacked in a folder $HOME/lmgrd

export LOCALE=C
export LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/
LIBERO_INSTALLED_DIR=/usr/local/microsemi/Libero_v11.2; export LIBERO_INSTALLED_DIR



PATH=$LIBERO_INSTALLED_DIR/Model/modeltech/linuxacoem:$PATH; export PATH

LM_LICENSE_FILE=1702@localhost; export LM_LICENSE_FILE

/home/$USER/lmgrd/Linux_Licensing_Daemon/lmgrd -c /home/$USER/lmgrd/License.dat -l /home/$USER/lmgrd/license.log


LiberoSOC (last edited 2015-06-15 19:16:08 by bc-proxy-6)