Using the Brother MFC-420CN multi-function device with Kubuntu 5.10 (Breezy Badger) or Kubuntu 6.10 (Edgy Eft)

Tag/tag.png

Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...

* this also worked with an MFC-5440CN under 7.10 *

The Brother MFC-420CN is a multi-function device that offers (ink-jet) printing, scanning, faxing and copying capabilities in one compact device. The device has an RJ-45 network port, built in LPD server and is well supported on Linux (with a proprietary driver from Brother). It offers 20 ppm (black) and 15ppm (color) printing speeds and is available for less than $100.

Linux support

Brother offers Linux drivers for the MFC-420CN. The stock Kubuntu 5.10 (Breezy Badger) distribution does not come with the drivers for the MFC-420CN. I am not sure whether it ever will given that one of the driver (filter) files from Brother appears to be a proprietary binary file, but who knows... Brother offers separate drivers for the printer and the scanner components. Brother also has LPR PC-Fax and CUPS PC-Fax drivers, but I have not explored the Fax functionality of this device, and this will not be covered in this document.

Prerequisites

This document assumes that you are using the network interface on the MFC-420CN, and that you know the IP address / hostname associated with the device. I recommend you setup your DHCP server to offer a fixed IP address to the device, and associate that IP address with a hostname on your local domain. If the IP address associated with the device changes, and you do not have an associated hostname, the printer configuration that once worked will stop working!

I am assuming that you have a working default installation of Kubuntu 5.10 (Breezy Badger). and that you chose the 'standard' install (kubuntu-desktop) and not the 'server' install. You need to have the following packages available before installing the drivers from Brother: a2ps gs-esp cupsys csh. The Debian packages from Brother don't seem to have the right dependencies built in, and the installation will go through but the driver will fail if you do not have these packages. In addition, you may want to install the following optional packages:

  • cupsys-bsd: If you are used to the lpr / lpq / lprm commands rather than lpstat / cancel

  • xsane: If you want the xsane UI for scanning

  • gimp: If you want to use gimp as the front end for scanning

You can check whether you have these packages installed using the following command:

dpkg -l a2ps gs-esp cupsys csh cupsys-bsd xsane gimp

If you see output similar to the following (with all the packages listed with 'ii' in the first two columns), you can proceed with the installation:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  a2ps           4.13b-4.3      GNU a2ps - 'Anything to PostScript' converte
ii  csh            20050313-1     Shell with C-like syntax, standard login she
ii  cupsys         1.1.23-10ubunt Common UNIX Printing System(tm) - server
ii  cupsys-bsd     1.1.23-10ubunt Common UNIX Printing System(tm) - BSD comman
ii  gimp           2.2.8-2ubuntu6 The GNU Image Manipulation Program
ii  gs-esp         7.07.1-9ubuntu The Ghostscript PostScript interpreter - ESP
ii  xsane          0.97-3ubuntu2  GTK+-based X11 frontend for SANE (Scanner Ac

If you don't have any of these packages, you can install them easily by typing:

sudo apt-get install a2ps gs-esp cupsys csh cupsys-bsd xsane gimp

Note: For Kubunu 6.10 you will require csh to be installed as well

sudo apt-get install csh

Downloading drivers from Brother

This is the Brother Linux Driver home page. Remember: you need BOTH the LPR Printer Driver (filter) as well as the CUPS Printer Driver (PPD).

Printer drivers

Download the LPR Printer driver (filter) from this page. If you want to directly go to the MFC-420CN driver for Debian, click here. Once you have accepted the agreement, you will be prompted to download / save a file named mfc420cnlpr-1.0.2-1.i386.deb Download the CUPS Printer driver (PPD) from this page. If you want to go directly to the MFC-420CN driver for Debian, click here. Once you have accepted the agreement, you will be prompted to download / save a file named cupswrappermfc420cn_1.0.0-1_i386.deb

Scanner Driver

Download the scanner driver from this page. The MFC-420CN requires the brscan2 package. If you want to directly go to the MFC-420CN driver for Debian, click here. You will be prompted to download / save a file named brscan2-0.2.1-0.i386.deb

Installing

Run the following commands only if you are very particular you do not want to see any errors from the installation of the mfc420cnlpr package:

sudo rm -f /usr/lib/libbrcompij.so*
sudo ln -s /etc/init.d/cupsys /etc/init.d/cups
sudo mkdir /var/spool/lpd/

The first command removes symlinks that mfc420cnlpr puts in but doesn't remove when it is uninstalled (in case you have already installed and removed this package once). The second command makes it easier for the package that expects /etc/init.d/cups (that Mandriva, Red Hat, Suse provide). The third command creates some missing directories required for the mfc420cnlpr package.

Installation is as simple as running dpkg -i on all the downloaded packages:

sudo dpkg -i mfc420cnlpr-1.0.2-1.i386.deb
sudo dpkg -i cupswrappermfc420cn_1.0.0-1_i386.deb
sudo dpkg -i brscan2-0.2.1-0.i386.deb

Note for Feisty Fawn (7.04 beta):

When installing mfc420cnlpr-1.0.2-1.i386.deb, IGNORE the following error

mkdir: cannot create directory `/var/spool/lpd/MFC420CN': No such file or directory
chown: cannot access `/var/spool/lpd/MFC420CN': No such file or directory
chgrp: cannot access `/var/spool/lpd/MFC420CN': No such file or directory
chmod: cannot access `/var/spool/lpd/MFC420CN': No such file or directory

When installing cupswrappermfc420cn_1.0.0-1_i386.deb, IGNORE the following errors:

lpadmin: Unable to copy PPD file!

We will fix this error later – installing the PPD through the CUPS web interface.

Configuring Printer

The Brother package creates a printer named MFC420CN. To configure, proceed as follows:

  • Make sure the CUPS system is running – run /etc/init.d/cupsys start if required.

  • Open the Printing manager by clicking KDE Panel --> Utilities --> Printing Manager. On 6.10 use the KDE Panel --> System Settings and click on Printers.

  • Click 'Administrator Mode' and enter your password when prompted. Make sure you select CUPS as the Print System (drop down box just above the OK button).
  • Choose the MFC420CN printer and click on the 'Properties' tab
  • Click on 'Interface' on the left and click on the 'Change' button
  • Choose 'Network Printer (TCP)' and click 'Next'
  • Enter Printer address (IP address or hostname) and enter 9100 as the port and click 'Finish'

Note for Feisty Fawn (7.04 beta):

The above steps (alone) are insufficient to get the printer working. In addition to (or INSTEAD of) making changes through the KDE Printing Manager, do the following:

  • Open a browser to http://localhost:631/printers/ – this is the CUPS web-based administration interface

  • Select 'Printers' – you should see a printer named 'MFC420CN'
  • Modify this printer as follows through several dialogs
  • Location / Description: Retain defaults, press Continue
  • Device: Choose 'LPD/LPR Host or Printer', press Continue
  • Device URI: Enter socket://mfc-420cn:9100 (where mfc420cn is the DNS name or IP address of your printer), press Continue
  • Make / Manufacturer: Choose to provide PPD file, enter /usr/share/cups/model/brmfc420cn_cups.ppd
  • Press Finish
  • Set printer to be Default (if that is what you want)

Configuring scanner

As root run the following command:

brsaneconfig2 -a name=MFC-420CN model=”MFC-420CN” nodename=mfc-420cn

Replace nodename=mfc-420cn with the IP address or hostname associated with your device. brsaneconfig2 may give and error of "Invalid model name" removing the quotes around the model name will help.

Note for Feisty Fawn (7.04 beta):

Ensure that the model name does not containing surrounding double quotes – i.e

brsaneconfig2 -a name=MFC-420CN model=MFC-420CN nodename=mfc-420cn

and not

brsaneconfig2 -a name=MFC-420CN model=”MFC-420CN” nodename=mfc-420cn

Using scanner

Assuming you have xsane installed, it is as simple as running xsane and choosing your scanner

Kooka (installed by default on 6.10) works as well.

Using the Brother MFC-420CN multi-function device with Ubuntu 10.04 (Lucid Lynx)

Ubuntu 10.04 includes the necessary support drivers for the MFC-420CN. Start by installing package brother-cups-wrapper-extra, which brings in various other packages.

Once these packages are installed, you can proceed to configure the Brother MFC-420CN. These instructions assume that you are using its network interface (rather than the USB interface).

Connect the printer to your LAN, and turn it on.

Now, start the CUPS administration interface from a browser. Do this by connecting to http://localhost:631/admin.

From this page, click *Add Printer*. CUPS will scan your local subnet, and if your printer is on that subnet, it should discover your MFC-420CN device. Select it, and *Continue* to set up your printer.


PrintersBrotherMfc420cn (last edited 2010-07-19 19:51:08 by jimp-launchpad-rs9z)