title Puppet

Introduction

Will contain more Puppet on Ubuntu details.

Backport version on Lucid 10.04

Just in case anyone else is trying to use the 2.7.1 version of puppet from the lucid-backports repository on lucid (for example, to use with clients running a later version of ubuntu and thus running a new version of the agent), this doesn't work due to a problem with ruby not being able to verify the certificates on the agents.

It also will not work to run an older version of puppet as the master and a newer version on the agents, at least not fully. It will appear to work, but none of the configuration catalogs will actually make it to the agents.

Puppet (last edited 2012-04-21 17:17:02 by ndoc2)