Ubuntu 9.10 (Karmic) 32 bit

Working out of the box

  • Brightness buttons, auto dim
  • Volume buttons
  • screen @ 1280x800
  • Wireless (and probably bloototh, but I do not have any device to test it)
  • ethernet
  • suspend to both, RAM and disk
  • card reader (both, SD and SDHC card worked)
  • external VGA
  • battery ACPI

Not working out-of-box

  • Touchscreen including rotations (wacom input does not rotate with screen !)
  • thermal sensors (showing 27 and 37 deg. C all the time)
  • frequency scaling
  • tablet buttons

Not tested

  • finger ID
  • bluetooth
  • HDMI
  • fireware
  • express cards

How to make things working

Touchscreen

wacom input does not rotate with screen ! First, setserial has to be installed using sudo apt-get install setserial. Then /var/lib/setserial/autoserial.conf has to be modified to include following line: /dev/ttyS0 port 0x220 irq 4 autoconfig and /etc/X11/xorg.conf has to be created, file which works for me (but only using stylus, no fingers, multitouch or even good rotation !!) follows:

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
     # TabletPC Pen Device
        InputDevice     "cursor"        "SendCoreEvents"
        InputDevice     "stylus"        "SendCoreEvents"
        InputDevice     "eraser"        "SendCoreEvents"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath     "built-ins"
EndSection

Section "Module"
        Load  "extmod"
        Load  "dri2"
        Load  "glx"
        Load  "dri"
        Load  "record"
        Load  "dbe"
        Load    "wacom"                 # added
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection
#### ADDED ####
# These lines should go after the detected mouse and touchpad
Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/ttyS0"
        Option          "ForceDevice"   "ISDV4"
        Option          "Type"          "cursor"
        Option          "Mode"          "absolute"
        Option          "Speed"         "3.0"
        Option          "Threshold"     "2"
#       Option          "DebugLevel"    "10"
#       Option          "MaxX"          "24576"
#       Option          "MaxY"          "18432"
EndSection
Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/ttyS0"
        Option          "ForceDevice"   "ISDV4"
        Option          "Type"          "stylus"
        Option          "Mode"          "absolute"
        Option          "button2"       "3"
#       Option          "Tilt"          "on"
#       Option          "TiltInvert"    "on"
        Option          "Threshold"     "2"
#       Option          "DebugLevel"    "10"
EndSection
Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/ttyS0"
        Option          "ForceDevice"   "ISDV4"
        Option          "Type"          "eraser"
        Option          "Mode"          "absolute"
        Option          "Button1"       "2"
#       Option          "Tilt"          "on"
#       Option          "TiltInvert"    "on"
        Option          "Threshold"     "2"
#       Option          "DebugLevel"    "10"
EndSection
##### added end #####
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"                   # [<bool>]
        #Option     "SWcursor"                  # [<bool>]
        #Option     "ColorKey"                  # <i>
        #Option     "CacheLines"                # <i>
        #Option     "Dac6Bit"                   # [<bool>]
        #Option     "DRI"                       # [<bool>]
        #Option     "NoDDC"                     # [<bool>]
        #Option     "ShowCache"                 # [<bool>]
        #Option     "XvMCSurfaces"              # <i>
        #Option     "PageFlip"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel Corporation"
        BoardName   "Mobile 4 Series Chipset Integrated Graphics Controller"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

thermal sensors

By default sensors are showing 27 and 37 deg. C all the time

frequency scaling

tablet buttons

Ubuntu 9.10 (Karmic) 64 bit

Working out of the box

  • Brightness buttons, auto dim
  • Volume buttons
  • screen @ 1280x800
  • Wireless, blootouth
  • ethernet
  • suspend
  • frequency scaling
  • thermal sensors
  • card reader

Not working out-of-box

  • Tablet Pen - after several unsuccessful attempts I gave up in 64 bit an reinstalled 32 bit, where it was possible to configure the touchscreen ... see above
  • tablet buttons / screen rotation
  • web cam

How to make things working

Tablet Buttons / screen rotation

Please install the following packages from ppa:khnz/ppa (see also https://bugs.launchpad.net/ubuntu/+bug/302245)

  • fsc-btns-kernel-source
  • fjbtndrv

Add fujitsu_laptop to /etc/modules

Not tested

  • external VGA

Ubuntu 10.04 (Lcuid) 64 bit

Seems to work now mostly out of the box. You have still to install the following packages from ppa:khnz/ppa (see also https://bugs.launchpad.net/ubuntu/+bug/302245)

  • fsc-btns-kernel-source
  • fjbtndrv

Appendix

Bug Reports

Currently the following bug reports are filled:

References & stuff to read

T4310 (last edited 2010-12-19 11:16:25 by mazrezzz)