Hi all,

The following are the steps I took to get my Toshiba Satellite A215-S7422 laptop working completely with Ubuntu Hardy Heron 8.04. Please note that this is my first HOWTO, and that I am a complete newb, so I may not be able to answer all of the questions you might have. These are simply the steps that I took and worked, and will probably work with laptops with similar hardware, so if you do get this working on a laptop other than the Toshiba Satellite A215-S7422, please say so in a post and I will add the laptop's model to the supported laptops list in the bottom of this section.

Please read the entire guide and not skip to certain parts (it's not that long Smile :) )Also, before I begin, I just want to say thanks for all the great people in this community and those of you who helped me get my laptop working. Smile :)

Supported Laptops:

Toshiba Satellite A215-S7422 (if this guide worked for yours, please say so in your post and I will add the model here)

1. Realtek 8187b Wireless

When I first loaded Ubuntu onto my PC, in my extreme-newbie days (about two months ago), I thought and expected all of the hardware to work right "out-of-the-box". I quickly realized that this wasn't the case, and I quickly gave up on Ubuntu and started a thread requesting help to remove it only after a few hours of installing it.

A few days ago, I happened to be browsing the forums to look for a possible solution to my wireless problem, and saw a potential fix for the RTL8187b wireless card (the one thing that was keeping me back from installing Ubuntu again). You can find the fix here, as posted by Tom--d. I decided to give another shot at Ubuntu if this could potentially solve my wireless problems, so I did.

Unfortunately, I did not get any luck with this route, although some claimed they have, just not me. I then turned to the hacked drivers which you can find here. I decided to revive my old thread about installing these drivers, and finally figured out the answer about 8 hours ago (thank you chili555 and tamoneya, and everyone who posted on my thread). So, without further ado, I present the solution for the RTL8187b wireless card:

  1. Download the Drivers: You can download the hacked driver to use with the RTL8187b wireless here. Download rtl8187b-modified-jadams-2-1-2008.tar.gz to the desktop.

  2. Extract the tar.gz: First things first, you must extract the .tar.gz that you just downloaded to the Desktop. To do this, make sure you are on your desktop and that you see rtl8187b-modified-jadams-2-1-2008.tar.gz. Then, right-click this file and select "Extract Here". Now, you should have a new folder on your desktop named rtl8187b-modified. You can now right-click on rtl8187b-modified-jadams-2-1-2008.tar.gz and select "Move to Trash".

  3. (Install?) the Driver: Again, I'm a newb, so the reason that "Install" is in parentheses is because I do not know if that is the right term for what I am about to show you how to do. Anyway, now that you have rtl8187b-modified on your desktop, go to Applications > Accessories > Terminal. Once that is loaded, you are going to want to enter in this command:

cd /home/your_username_here/Desktop/rtl8187b-modified/

"CD" means "Change Directory", so you are telling it to change the directory to rtl8187b-modified. I have typed in "your_username_here", but make sure to substitute this with the name you use to log in on your computer. When you are finished, hit "Enter" on your keyboard and you should get a new line that looks like this:

maxwell@maxwell-laptop:~/Desktop/rtl8187b-modified$ 

This means that you have changed directories successfully. Please note that "maxwell" will be replaced by your name. If it says

bash: No such file or directory

you have NOT changed directories successfully, and need to proofread the first command.

OK, now that I assume we have all changed directories into rtl8187b-modified, we can move on.

  • Make makedrv (Executable?): Again, the reason I put "Executable" in parentheses is because I do not know if that is the right term. Anyway, what you are going to want to do now is (once we have changed directories successfully) enter this command in this same terminal window that we used in the last step:

sudo chmod +x makedrv

It might ask you for your password. If so, just type in the password you use to log in. Please note that you will not see any *'s when you type in your password, and this is normal. When you have finished typing in your password, push the "Enter" button on your keyboard. If it did not ask you for your password, you are fine.

Well, by now our terminal window should look like this:

maxwell@maxwell-laptop:~$ cd /home/maxwell/Desktop/rtl8187b-modified/
maxwell@maxwell-laptop:~/Desktop/rtl8187b-modified$ sudo chmod +x makedrv
[sudo] password for maxwell: 
maxwell@maxwell-laptop:~/Desktop/rtl8187b-modified$ 

Notice that after you have typed in the above command, it simply goes to the next line. This mean that it was successful, so we can now type in the following command:

sudo ./makedrv

Once you have typed in this command (and have hit "Enter" on your keyboard), you should see many lines of text write themselves in the terminal window. You should also see many warnings, but this is fine. After this is done, you can proceed with the next step.

  • Make wlan0up (Executable?): Once you have completed the previous step, type the following into the terminal window:

sudo chmod +x wlan0up

After typing this in press "Enter" on your keyboard, and, if done successfully, you should be on a new line that looks like this:

maxwell@maxwell-laptop:~/Desktop/rtl8187b-modified$ 

If the previous command was successful, simply type in this final command:

sudo ./wlan0up

After a few seconds, it should create a new line that looks like the one shown above, and, if you followed all of the steps, you should be done! Now click on the Network Manager > Unlock > Enter the password you use to log in to the computer > Wireless Connection, and connect! If you still do not see Wireless as an option in the Network Manager, please review all of the steps again. Also, please note that the Network Manager can be a bit... clumsy ...at times, so give it around 30 seconds (yes, it sometimes takes this long!) time to connect.

Drawbacks of using this driver:

  1. Although you can connect to Wireless networks and get the full strength of the signal, the icon will only show you that you have 30% and one bar
  2. This driver works best on unsecured wireless networks, although I am pretty sure that it supports WEP, but I am waiting for somebody to confirm this
  3. This driver might not support WPA or WPA2 encryption, but I am waiting for somebody to confirm this

2. ATI Radeon x1200 Graphics Card

Although it may appear that your graphics card is working fine (assuming you have an ATI Radeon x1200 chip like the one that comes in a Toshiba Satellite A215-S7422), it, in fact, is not working 100%. However, it is an easy fix, and very useful if you are looking at getting some cool desktop effects. Let's get started!

  1. Download and Install ATI Catalyst Control Center: This one is pretty easy. To do this, just go to Applications > Add/Remove Programs > make sure All Available Programs are listed > check (or tick) the box next to ATI Catalyst Control Center. Then click "Apply Changes" down near the bottom.

  2. Download and Install the Necessary Packages: Please note: you must have a working Internet connection for this section to work, so why not use your new Wireless connection:)? Also, you must have the extra repositories enabled in System > Administration > Software Sources for this section to work. If you are connected to the Internet in some way, go to Application > Accessories > Terminal and type in:

sudo apt-get update

This will update your software. After that is done (it might prompt you for your password, if so, just type it in), type in:

sudo apt-get install linux-restricted-modules-generic

This will install the package we need for this driver to work: linux-restricted-modules-generic. Once you are done with that, type in:

sudo apt-get install xorg-driver-fglrx

This will install the actual driver for the card. Once that's finished, type in:

sudo depmod -a

Once all of that is finished, you are going to want to edit the xorg.conf file, so please type in:

sudo gedit /etc/X11/xorg.conf

Once gedit opens up with xorg.conf, look for a section that looks like this:

Section "Device"
        Identifier  "whatever"
EndSection

Once you find it, add a new line below "Identifier" and add the following text to it:

Driver      "fglrx"

Also, please note that "whatever" is not the actual text you are going to see in the file, but I realized that the text where "whatever" is changes, so I put "whatever" in to avoid confusion. Just to be clear, the "Device" section should now look like this:

Section "Device"
        Identifier  "whatever"
        Driver      "fglrx"
EndSection

Then click Save at the top of the program, and it will close.

Then click Save at the top of the program, and it will close.

Now, type this in terminal:

sudo aticonfig --initial -f

Now, restart your computer. Once it reboots, click Applications > Other > ATI Catalyst Control Center. If you get a window with options, and other things, you have successfully installed your graphics card! Now you can look into some of those neat desktop effects. However, if, when you try and open ATI Catalyst Control Center you get a screen that says that the drivers are not installed, it was unsuccessful and you need to review all of the steps and try again.

3. Tips and Tricks

  1. Configure ./wlan0up on startup: If you used the above guide to install the Realtek Drivers, you might notice that you have to do "sudo ./wlan0up" from the rtl8187b-modified directory every time you restart your computer!!! That's not fun, so, if you want it to do this automatically on startup, first right-click on the rtl8187b-modified on your Desktop and select Cut. Then, go to Places > Home Folder > right-click > Paste. The folder "rtl8187b-modified" should now be off of your Desktop and in your home folder. Now, go to Applications > Accessories > Terminal and type in the following:

sudo gedit /etc/rc.local

Now, add two lines below where it says:

#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

On the second line, type in:

cd /home/your_username_here/rtl8187b-modified/ && ./wlan0up

Now save the file, and close out of terminal. This should now load .wlan0up on startup, so you don't have to. Just be sure that you have placed rtl8187b-modified in your home folder, and you replace "your_username_here" with your Ubuntu username.

That's all for this guide, although I will be adding more to it if anyone sees fit. If you are having trouble, please post saying so, and I will see what I can do, although please keep in mind that I have very limited knowledge on the subject, being a newb and all. Thank you for all your help, again, and if this post helped you, please click the ribbon in the bottom-right corner of this post.

Thank you, and have fun! Smile :)

Owner of this page Please include this sound fix:

Out of the box ubuntu works fine with the Realtek HD audio with the exception of the microphone input in some applications such as skype.

open terminal enter "sudo gedit /etc/modprobe.d/sound" will present a blank text file for you add this line excluding the (" ") "options snd-hda-intel model=toshiba" save and close

Upon restart the microphone should be working fine if not, open the volume manager and select the input source appropriately.

Sorry for lack of formatting but this info deserves to be here.

ToshibaSatelliteA215S7422Guide (last edited 2008-07-24 17:11:08 by localhost)