Introduction

This page gives general information on the device and user notes about their experience setting it up. If you need more help, please look to the WifiDocs page for more support channels.

Device Info

  • Manufacturer: D-Link

  • Model #: DWA-111

  • Revision: A1

  • Device Type: USB

  • Chipset: RT73

  • Vendor/Device #: 07d1:3c06

Gutsy 7.10 (Kernel 2.6.20-16-generic)

Did it configure during install?

  • NO

What driver did you use and ease of set up?

Ralink : http://www.ralinktech.com.tw/2008_0117_RT73_Linux_STA_Drv1.1.0.0.tar.bz2

SerialMonkey : http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz

Did it work by just configuring network settings after install (out of box)?

  • NO

Installation

Install the following packages :

  • «build-essential»;
  • «tofrodos» ;
  • «linux-headers-2.6.22-14-generic» (→ adapt this last package to you kernel version, ... uname -r).

Usually the USB key is not detected at this stage and the light is off under Gutsy.

Compilation of Ralink drivers sources

Download the drivers sources and compile them with the current kernel (uname -a). lDriver sources are available from : http://www.ralinktech.com.tw/data/RT73_Linux_STA_Drv1.0.4.0.tar.gz.

Add to Modules/rtmp-def.h the USB key ID at the end of the file.

{USB_DEVICE(0x07d1,0x3c06)}, \

Edit the Configure file by finding the line that reads:

LINUX_SRC=/usr/src/linux-$CUR_RELEASE

Edit it to read:

LINUX_SRC=/usr/src/linux-headers/$CUR_RELEASE

Run the following code :

~$ sudo cp -p Makefile Makefile.20061205
~$ sudo cp Makefile.6 Makefile
~$ sudo chmod +w *
~$ sudo dos2unix *
~$ sudo ./Configure # point to /usr/src/linux-headers-`uname -r`
~$ make all
~$ sudo mkdir /lib/modules/`uname -r`/kernel/drivers/usb/net/
~$ sudo cp -v rt73.ko /lib/modules/`uname -r`/kernel/drivers/usb/net/
~$ sudo mkdir /etc/Wireless
~$ sudo mkdir /etc/Wireless/RT73STA 
~$ sudo cp rt73.bin /etc/Wireless/RT73STA/
~$ sudo cp rt73sta.dat /etc/Wireless/RT73STA/
~$ depmod

Interfaces set up

Edit /etc/network/interfaces and add :

# The USB key will be given a static adress

iface rausb0 inet static
address your_ip      # e.g : 192.168.1.4
netmask 255.255.255.0                
network 192.168.1.0                 
gateway 192.168.1.1                  
    pre-up ip link set rausb0 up

# SSID is imposed :
      pre-up iwconfig rausb0 essid "network name_or_SSID"
      pre-up iwconfig rausb0 mode Managed
 
# Mode and channel are also imposed :
 
      pre-up iwconfig rausb0 channel 11      # This line is not compulsory, but the "channel" 
                                             # has to be known, however I had to keep the line to have the USB key working.
      pre-up iwpriv rausb0 set AuthMode=WEPAUTO
      pre-up iwpriv rausb0 set EncrypType=WEP

#Wep key

      pre-up iwpriv rausb0 set Key1="uncoded wep key"
      pre-up iwpriv rausb0 set SSID="network name_or_SSID"

Restart and check your Internet connexion. If the connexion is not working the next step should be done

== SerialMonkey Drivers installation==

Blacklist rt2570 module and rt73usb module.

Edit folder /etc/modprobe.d/blacklist and add

blacklist rt2570

blacklist rt73usb

Check the modules already there :

~$ lsmod | grep rt 

If presence of rt73usb module is detected :

~$ sudo rmmod rt73usb

Then download serialmonkey driver

~$ wget http://rt2x00.serialmonkey.com/rt73-cvs-daily.tar.gz

Untar the file

~$ tar -xvf rt73-cvs-daily.tar.gz

Compile next

~$ cd rt73-cvs-*
~$ cd Module
~$ make

If the error message below :

!!! WARNING: Module file much too big (>1MB) !!! Check your kernel settings or use 'strip'

It means that the module size is too big :

~$ strip -S rt73.ko

Proced as followed,

~$ sudo make install

~$ sudo mkdir -p /etc/Wireless/RT73STA/
~$ sudo cp rt73.bin /etc/Wireless/RT73STA/

Run

~$ sudo depmod -a

Then reload driver

~$ sudo modprobe rt73

And finally load the driver when starting

~$ gksu gedit /etc/modules

by adding

rt73

Restart and the USB key light should come on, an iwconfig should indicate the presence of an rausb0 network. At this stage the Internet connexion is still not working.

Use/Configuration

  • A ping to the gateway might return 'host unreachable' when testing your network.

In which case, run :

~$ sudo ifdown eth0

eth0 refer to you wired network (seen by ip addr)

Then run :

~$ sudo ifup rausb0

And test the connexion without restarting.

If it works

Edit /etc/network/interfaces and put # symbole before every line eth0. Your wire connexion will not be directly detected by Ubuntu and should not conflict with your wihi connexion.

Authors/Contributors

Thimpat, Neima


CategoryHardware CategoryNetworking CategoryWireless

WifiDocs/Device/DWA-111 (last edited 2011-05-16 15:34:01 by jengelh)