Style Cleanup Required
This article does not follow the style standards in the Wiki Guide. More info...


Working - Ubuntu 9.1 and later

This device requires proprietary firmware to function, as discussed in this thread. Install the linux-firmware-nonfree package from the multiverse repository before plugging in the device:

sudo apt-get install linux-firmware-nonfree

If the device was already plugged in, make sure you reinsert it - the blue LED should now light up.

WG111 How To (Part 1)

This page describes the setup procedure for the Netgear WG111 (version 1) -- a USB-based wireless dongle -- in Ubuntu 5.04. Though the author tested with the version 1 dongle it was reported that the version 2 dongle also works. A third version was released in 2008 (usb id 0846:4260). WG111v3 can be used with the rtl8187 driver (or ndiswrapper if you must). See this forum thread.

Note: Ubuntu 6.10 Edgy Eft supports the WG111v2 (rtl8187 chipset) with a native driver straight out of the box. Just plug and play. Strangely, there is also another WG111v2 that does not use the rtl8187 chipset and it will require ndiswrapper, so test for plug and play using iwconfig to determine if you need ndiswrapper.


The following packages are required:

  • ndiswrapper-utils

It is assumed you are logged in as root when performing this process. To get a root terminal open a terminal and run

sudo -s

Install The NetGear Drivers

Included on the CDROM provided with the device are Windows drivers. Place the CD in the drive and install these with ndiswrapper:

ndiswrapper -i /media/cdrom/netwg111.inf

Load The ndiswrapper Module

If the dongle is not already plugged in do so now. Load the ndiswrapper module, which in turn loads the installed drivers from above, by running

modprobe ndiswrapper

Verify the module found the device by running

tail /var/log/syslog

You should see information about ndiswrapper initializing the device. Note the wlan# that is reported. This will be wlan0 if this is your only wireless device.

Setup The Network Interfaces

Specify the details of the connection. Assuming your wireless network runs in managed mode and you need only an ESSID (no WPA or WEP), add the the following to /etc/network/interfaces

auto wlan0
iface wlan0 inet dhcp
        hostname <hostname>
        wireless_mode managed
        wireless-essid <essid>

adjusting wlan0 as appropriate, and specifying your hostname and the ESSID of your wireless access point.

Test the connection by running

ifup wlan0

You should receive an IP if things are working correctly.


The presence of auto wlan0 above causes the interface to be started at boot time. You must add the following line to the end of /etc/modules to ensure the ndiswrapper is also loaded at boot time


WG111 HowTo (Part 2: DAPPER DRAKE)

After upgrading to Dapper Drake (6.06), I fould significant problems trying to get the WG111 working. Here are the instructions that I fould worked on a Compaq Deskpro EN desktop and IBM Netvista. This section describes a successful setup procedure for the Netgear WG111 (version 2) -- a USB-based wireless dongle -- in Ubuntu 6.06.

  • Start with the WG111 out of the USB port.
  • Undertake a clean install of Ubuntu 6.06 LTS
  • Blacklist the default drivers installed as part of Dapper

    gksudo gedit /etc/modprobe.d/blacklist
    [...add to the bottom of the listing....]
    blacklist islsm_pci
    blacklist islsm
    blacklist islsm_usb
    blacklist prism2_usb
  • install ndiswrapper. Install the package ndiswrapper-utils (eg using the Synaptic Package Manager).

  • find the Netgear WG111 driver. Within the 'factory' drivers there is a NDIS5 directory, use these files. All the enclosed files must be together when the driver is loaded (don't just copy netwg111.inf out by itself).

The driver is available at http://kbserver.netgear.com/release_notes/d102869.asp . It is marked as drivers for MA111 v1 but works for v2 also. This is the same drivers that are available on the factory disk.

  • configure ndiswrapper

    cd /DRIVER/DIRECTORY/ndis5
    sudo ndiswrapper -i netwg111.inf
    sudo depmod -a
    sudo modprobe ndiswrapper
    sudo ndiswrapper -m
  • configure modules

    gksudo gedit /etc/modules/
    ''...add to bottom of the listing...''
  • link MAC to wlan0. You can find the MAC address of the device written on the side. It should be something like 000FB5XXXXXX, you just need to place the colon after each 2 characters/numbers.

    gksudo gedit /etc/iftab/
    ''...add to bottom of the listing...''
    wlan0 mac 00:00:00:00:00:00
  • put the WG111 USB device in. I performed a re-boot at this point.
  • configure network. This can be achieved from within the netwrok tools also; this example is using WEP restricted access.

    sudo iwconfig wlan0 essid ACCESS_POINT_NAME mode managed key TEXT_WEP_KEY restricted

At this point I had a functioning wireless network using the Netgear WG111 USB dongle.

WG111 HowTo (Part 3: Edgy Eft)

  • The same instructions as for Dapper worked for me with one important change:
  • Instead of using the ndiswrapper in the repositories I had to download the latest version of ndiswrapper from their home page at SourceForge.

  • You must compile the module yourself. For this to succeed you must install build-essentials

  • Enjoy your wireless!


WifiDocs/Device/NetgearWG111 (last edited 2013-07-03 01:51:09 by navcar)