• This page gives general information on the device and user notes about their experience setting it up. If you need more help, please look to the WifiDocs page for more support channels.

Device Info

User Notes

What Ubuntu release are you using?

  1. 6.06 (DapperDrake)

  2. 8.04 (HardyHeron)

  3. 8.04 (HardyHeron)

  4. 8.10 (Intrepid)
  5. 9.04 (Jaunty Jackalope)
  6. 9.10 (Karmic Koala)
  7. 10.04 (Lucid Lynx)

Did it configure during install?

  1. No
  2. No
  3. No
  4. No
  5. No
  6. No

Did it work by just configuring network settings after install (out of box)?

  1. No
  2. No
  3. No
  4. No
  5. No
  6. No

What driver did you use and ease of set up?

Dapper Drake

  1. Use the WinXP drivers in the directory  TL-WN620G/Win2000_XP/Driver Files  of the installation CD:

    •  r5523.bin  athfmwdl.inf  athfmwdl.sys  tl-wn620g.inf  tl-wn620g.sys 
  2. Install athfmwdl first, then tl-wn620g second:

    • $ sudo ndiswrapper -i athfmwdl.inf
      $ sudo ndiswrapper -i tl-wn620g.inf 
  3. Check that the device is found:
    • $ sudo ndiswrapper -l
            Installed ndis drivers:
            athfmwdl                driver present
            tl-wn620g               driver present, hardware present
  4. Fire it up:
    •  modprobe ndiswrapper

You can then use  systemsettings  to configure the network interface.

Hardy Heron

  1. Download the Windows drivers from here:

  2. Unzip to your desktop
  3. Install the Windows driver using a terminal window:
    • $ cd ~/Desktop/2007*/Win2000_XP/Driver\ Files/
      $ sudo ndiswrapper -i athfmwdl.inf 
      $ sudo ndiswrapper -i net5523.inf
  4. Check that the device is found:
    •  $ sudo ndiswrapper -l
            athfmwdl : driver installed
                     device (0CF3:0002) present
            net5523 : driver installed
                    device (0CF3:0002) present
  5. Fire it up:
    •  $ sudo modprobe ndiswrapper
  6. Setup your network connection by clicking on the network icon on the top menu bar and selecting your wireless network.
  7. Currently there is a bug( in Hardy which prevents the device from working after a reboot, to fix this you will have to type these commands everytime you reboot (you may consider putting them into a script that is run at login):

    • $ sudo modprobe -r ndiswrapper
      $ sudo modprobe ndiswrapper

Hardy Heron

  1. Like many others, I've been struggling with this device for quite a long time.

Here is what I found out.

a. Seemingly, there is no need in the athfmwdl.inf driver. Probably, it only gets things worse.

b. You should configure ndiswrapper with your device physically removed, and only insert it after you complete the setup and add the ndiswrapper module by the modprobe command, otherwise you may suffer lockups and the adapter may not work.

c. There is a new version for the ar5523 driver ( It is available on windows update. There's where I got it. It works for me, though after I discovered the above 2 points, the older version available on the official tp-link site, works for me too. If you wish to try the new version and do not have access to windows update, you may have some hard time finding it. This version is not available on the tp-link site. I googled it, but nothing appropriate was found. Posting it in attachment, don't tell anyone.

I'm using the latest version of ndiswrapper (1.53), compiled from source.

Lucid Lynx

  1. Do not plug the adapter until after the drivers are installed.
  2. Download the Windows drivers from here:

  3. Unzip to your desktop
  4. Open the 'Ubuntu Software Center' from the Application menu and search for 'ndiswrapper'; when found install the 'Windows Wireless Drivers' application.
  5. Execute 'Windows Wireless Drivers' from the System -> Administration menu

  6. After authenticating, choose 'Install New Driver' button.
  7. Vector to the location where you unzipped the drivers in step 3 above and choose the net5523.inf XP driver.
  8. After the driver installs you should see it displayed in the 'Currently installed Windows Drivers' list.
  9. Plug in the adapter to a USB port and close 'Windows Wireless Drivers' app.
  10. Open a terminal and type:
    •  $ sudo ndiswrapper -l
            net5523 : driver installed
                    device (0CF3:0002) present
      • Should echo back the above.
       $ sudo modprobe ndiswrapper
      • Should activate the adapter, check that the LED is flashing slowly
  11. Click on the network icon on the top menu bar and if it worked, you should be able to select a wireless network.

I tried the above instructions 4-5 times repeatedly. All times worked, but I found a few things that are somewhat odd.

+ At least with Lucid, it may warn about the ndiswrapper file in /etc/modprobe.d directory needing a .conf file extension. I found I could delete the file outright and it would continue to work anyway.

+ You may or may not need to reboot your pc after driver install.

+ On at least two of my repeats, I didn't need to execute step 10 above. If the LED is flashing, it's active.


  1. There is no need to install athfmwdl.inf
  2. I compiled ndiswrapper 1.54 and used driver from install CD.

Jaunty Jackalope

  1. Followed process as per Hardy Heron above, except did not install athfmwdl.inf. Worked a treat. Used ndiswrapper 1.53. Only problem is doesn't work after reboot, but does if I disconnect and reconnect the device. Keen to find a solution for this!

If you used ndiswrapper and pulled driver from the internet, where?

updated TPLink TL-WN620G

Dapper Drake

  1. The driver on the device's CD-ROM works. The drivers can also be downloaded from the manufacturer's support page:

Hardy Heron

  1. The driver on the CD-ROM hasn't been tested. The following drivers from the manufacturer's support page work:

Hardy Heron

  1. Windows update


  1. The driver from supplied CD-ROM works well.

Jaunty Jackalope


Comments, tips, or other set up help...

  1. None
  2. None
  3. None
  4. None
  5. None

Karmic Koala

6. Followed process as per Jaunty Jackalope.

  • Used driver from CD-ROM net5523.inf (Driver ver. 07/27/2005) with ndiswrapper package ver. 1.55 (utils ver. 1.9) from xubuntu CD-ROM
  1. Install net5523.inf:

    • $ sudo ndiswrapper -i net5523.inf
  2. Fire it up:
    •  $ sudo modprobe ndiswrapper
  3. You need to disconnect your device before setting ndiswrapper.

CategoryHardware CategoryNetworking CategoryWireless

WifiDocs/Device/TP-Link_TL-WN620G_(ndiswrapper) (last edited 2010-12-27 18:05:06 by tomdavies04)