Built-in drivers/modules, tested only on Intrepid

Also works on Karmic - see below

If the method described in this section doesn't work for you, try the alternate method using ''madwifi'' and ''ath_pci'' described below.

Look for the ath5k module, located in the package linux-backports-modules-intrepid. Install the package using either Synaptic or apt-get, and make sure it is activated on System/Administration/Hardware Drivers.

Note: For 9.10 substitute linux-backports-modules-karmic,

Follow the steps below only if ath5k module did not work. This may be the result of a conflict with either ath_hal or ath_pci, or ath5k might be blacklisted somewhere. So:

1) Hit "alt+f2" to run a command and type:

gksudo gedit /etc/modprobe.d/blacklist.conf

And add the following lines to the bottom of the file:

blacklist ath_hal
blacklist ath_pci

Reboot. If it's still not working than it is very likely you have ath5k being blacklisted somewhere. Blacklisting may have occurred if you are coming from a Hardy upgrade and/or did not uninstall the madwifi driver before doing this. So try the following, but Be Extremely Careful - this next command opens nautilus with root privileges, which can change and/or damage any file on the system.

2) Hit "alt+f2" to run a command and type:

gksudo nautilus

And navigate to

/etc/modprobe.d

Now check each and every file for a line that looks like:

blacklist ath5k

And just add a "#" character at the beginning of the line, thus commenting it. You might probably find this case on a file named "madwifi".

2.1) Alternatively, to quickly find where ath5k is being blacklisted, you can open a terminal (Applications/Accessories/Terminal) and type:

grep -r "ath5k" /etc/modprobe.d/

Just remember you need to just comment lines that have "blacklist ath5k".

This solution is based on this thread on the forums: http://ubuntuforums.org/showthread.php?p=6089169

If after all the above you see a network but cannot connect

You might want to try changing the WPA Supplicant on your network manager to wext. On wicd it's the first option when you go into Preferences.

If after everything you don't see your network

Remember that you might be trying to connect to an access point that is not broadcasting its name (hidden SSID), which is a separate issue and can be checked by enabling SSID broadcast on the access point.

Manually installed drivers

sudo lshw -C network

I found the following things helpful:

1) https://bugs.launchpad.net/bugs/182489

(Synopsis: Add the following line:
blacklist ath_pci
to the /etc/modprobe.d/blacklist.conf file and reboot. If you are running an up-to-date Hardy, this should enable the free/libre ath5k driver.)

2) http://madwifi-project.org/ticket/1192

(Synopsis:
0. Connect to wired network and install build-essential (sudo apt-get install build-essential)
1. wget http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6-current.tar.gz
2. tar -zxvf madwifi-hal-0.10.5.6-current.tar.gz
3. cd madwifi-hal-0.10.5.6-r*
4. sudo make
5. sudo make install
6. System -> Administration -> Hardware Drivers -> Uncheck both hal and Atheros support
7. sudo vi /etc/modprobe.d/blacklist.conf -> blacklist ndiswrapper (Do this if you had tried ndiswrapper)

This will download and install a non-free, binary-only driver for the atheros chipset. You need to rebuild and reinstall the driver every time you update your kernel.

3) The wireless LED on my laptop does not work in linux. I may have pressed the wireless button while troubleshooting and turned off wireless without knowing it. So while fiddling around, I may have installed the right driver but not known it.

Method Using madwifi and ath_pci

The following method was described in the Ubuntu Forum thread http://ubuntuforums.org/showthread.php?t=1309072. Sections of this thread are quoted below. If you run into trouble, looking at the details of that thread may be helpful.

Dr. P.J. Kurian posted the following information (edited here):

Hi guys! In this thread you will find the instructions for installing the madwifi drivers for Atheros wireless cards. Please follow the instructions exactly.

Open the terminal by navigating through Applications-->Accessories--> Terminal.

Now type the following commands in the terminal window:

sudo nano /etc/apt/sources.list

Now uncomment anything in that file that starts with deb by changing it from #deb to deb or something along those lines. To exit and save your changes, hit CTRL+X. Then answer "YES" to "Do you want to save?" and hit ENTER.

Now type the following commands:

sudo -i
apt-get update && apt-get upgrade
apt-get install build-essential libssl-dev linux-headers-`uname -r` subversion
svn checkout http://svn.madwifi-project.org/madwifi/trunk/ madwifi-ng
cat >> /etc/modprobe.d/blacklist.conf << END

#Remove To Install MadWIFI Drivers
blacklist ath9k
blacklist ath5k
END
cd madwifi-ng
make && make install
echo ath_hal >> /etc/modules
echo ath_pci >> /etc/modules

Restart your machine. Your wireless connection should work now.

optional: I use wicd to connect to the wireless modem. To install wicd type the following commands in a terminal window:

sudo apt-get update
sudo apt-get install wicd

Warning about kernel updates

Kernel updates of your system will kill your driver, so you'll need to recompile it. Type the command sudo -i into a terminal window and just repeat the last three steps. Your madwifi will come back to life.

Additional step for kernel 2.6.32.22 and later

Kernel 2.6.32.22 changed the default for the rfkill parameter of ath_pci from 0 to 1, which had the effect of killing the methods described above. You'll need to make sure that it's set back to 0 on system startup. To do that, edit (or create) the file /etc/modprobe.d/options.conf to include the line

options ath_pci rfkill=0

Your wireless should work after you reboot.

(Edited 2010-05-15 to remove advertising spam links)

WifiDocs/Driver/Atheros (last edited 2010-09-21 00:48:12 by blendmaster1024)