1. Marvell Libertas Wireless Cards

1.1. Do you have one?

This page is intended to help you make your mrv8k based wireless card work under Ubuntu.

To check if you have one, run:

lspci

If you see a line like:

Ethernet controller: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)

then you have a mrv8k.

1.2. Disable the broken driver

Sadly, the default kernel contains an unfinished driver for this chip. It simply doesn't work. Thus, we need to use disable it and set up ndiswrapper to get our card to work correctly.

First, disable the broken free driver:

echo 'blacklist mrv8k' | sudo tee -a /etc/modprobe.d/blacklist.conf

1.3. Configure ndiswrapper

Now, download the windows drivers for the mrv8335 chip:

mkdir mrv
cd mrv
wget -c http://www.cafuego.net/stuff/mrv.zip
unzip mrv.zip
sudo ndiswrapper -i mrv8335.inf
sudo ndiswrapper -m
cd ..
rm -rf ./mrv

Note: I've zipped up the set of working ones that I use, which I got from http://people.freebsd.org/~wpaul/marvell/

A known to work 64-bit driver tested with the trendnet tew-423pi B1 was found at: http://www.versiontracker.com/dyn/moreinfo/win/131948

This driver will be required if you use 64-bit ubuntu.

Now, reboot your system, and note you have a wlan0 interface to play with Smile :-)

Troubleshooting: If Ubuntu freezes durring the boot process at "Configuring Network Devices...". After letting it sit for a few minutes (I let mine sit for half an hour before I figured this out), do a hard reboot. Ubuntu should boot fine this time, and have a working wlan0!

1.4. Issues with Feisty

Some people are experiencing issues with this driver under feisty. These seem to stem from network-manager, and can be resolved in the following way:

Firstly, follow the instructions above to get your card working correctly, and check your card is active by initiating a scan:

iwlist wlan0 scan

If things are working you should see a list of your local networks. Now, obtain a copy of wicd from here using a wired network connection: http://wicd.sourceforge.net

Install the .deb file, and uninstall network-manager (and network-manager-gnome) using Synaptic. You'll need to restart your gnome-panel with killall -9 gnome-panel to stop the error messages from network-manager. It should automatically restart.

After rebooting, start wicd from Applications > Internet. You should see your local wireless networks listed, and be able to connect after adding your settings under the Advanced Settings option for your chosen network.

It should also be noted, that you cannot connect to WPA2-secured networks with the mrv8k chipset and ndiswrapper in Feisty or Gutsy (which is currently on Tribe 5).

WifiDocs/Driver/mrv8k (last edited 2012-01-02 21:19:17 by tom6)