Introduction

xrdp is a Remote Desktop Protocol (RDP) Server, allowing RDP clients to be presented an X windows desktop to the user.

Installation

Simple setup with no user logged into console

This is a simple setup without using TLS and certificates. Also, it requires that no person is logged into the console when attempting to connect.

With Ubuntu 18.04 first install xrdp:

sudo apt-get -y install xrdp

Next, one may adjust the configuration file:

sudo nano /etc/xrdp/xrdp.ini

Set encryption level to high:

encrypt_level=high

Next, allow just RDP through the local firewall:

sudo ufw allow 3389/tcp

Next, create a polkit configuration file:

sudo nano /etc/polkit-1/localauthority.conf.d/02-allow-colord.conf

and input inside it:

polkit.addRule(function(action, subject) {
if ((action.id == “org.freedesktop.color-manager.create-device” || action.id == “org.freedesktop.color-manager.create-profile” || action.id == “org.freedesktop.color-manager.delete-device” || action.id == “org.freedesktop.color-manager.delete-profile” || action.id == “org.freedesktop.color-manager.modify-device” || action.id == “org.freedesktop.color-manager.modify-profile”) && subject.isInGroup(“{group}”))
{
return polkit.Result.YES;
}
});

Finally, restart xrdp and you should be able to connect:

sudo /etc/init.d/xrdp restart

FAQ

  • From Windows, attempting to connect one gets the error message:

    Remote Desktop Connection
    The connection cannot proceed because authentication is not enabled and the remote computer requires that authentication be enabled to connect.
    This can happen if TLS is setup incorrectly.
  • From Windows, use Remote Desktop Connect to connect, and after inputting the username and password at the xrdp login screen one gets a password prompt noting:

    Authentication Required
    Authentication is required to create a color profile
    However, the prompt reappears after inputting the correct password. This is due to not adding a polkit rule.
  • From Windows, use Remote Desktop Connect to connect, at the xrdp login screen using Session Xorg, after inputting the username and password one gets a blank screen. This can happen due to how one is logged into Ubuntu at the console. Unfortunately, by default it does not act like Windows, where the console will become locked, and the console session will be redirected to the RDP connection. One will have to log out first.
  • From Windows, use Remote Desktop Connect to connect, at the xrdp login screen using Session Xorg, after inputting the username and password one logs in but no docks exists. Log out of the RDP session, at the console login screen login click the gear icon and choose Ubuntu > open the application Tweaks > Extensions > Ubuntu dock > ON

External Links


CategoryApplications

xrdp (last edited 2018-05-23 04:07:58 by penalvch)