Tag/tag.png

Candidate for Moving
This article may not be appropriate for this wiki, and should be moved to the Team wiki. More info...

Tag/tag.png

Candidate for Deletion
This article may not be appropriate for this wiki, and may be deleted. More info...

Tag/tag.png

Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...

This page was created in the hopes that we could keep the more confusing issues from the Aspire One page, leaving it as clean as possible. The AspireOne pages need a revamp.

Wireless Problems Authenticating to WPA-PSK (TKIP), Hidden SSID

9.04 works great out of the the box, but after a few updates and package installs, wireless networking decides that it no longer can authenticate to my access point. I'm presented with a window titled: "Wireless Network Authentication Required". Prior to this, the wireless networking connects without any effort on my part: "It just works". The last thing I did was to install ffmpeg using synaptic package manager. In the authentication window described above there is an encrypted password. I click "Connect" but the little blue comet keeps on goin' round-n-round. The SSID is shown in the Network Manager GUI. Has anyone else seen this problem? I have an AOA150-1635.

yes sort of, i'm suspecting over heating perhaps as it seems to happen when my aspireone (110L) is left on a soft surface which tends to block airflow. The wireless card disappears from the system wifi-radar says it can't change mode or something and so far the only reliable reset seems to be to power down and remove the battery for a few seconds and next boot up seems to work fine, it did this under hardy as well for me) wifi-radar will give you a better clue to whats happening when launched from a command prompt.

I have also seen this. Power cycle failed to help. Didn't try removing the battery. But I did try installing the madwifi driver, which didn't work. But when I reverted to the original driver, everything worked again. Maybe something gets set in the hardware, and does not clear with the normal driver?

Yup, definitely something wrong when you activate the madwifi driver through System --> Administration --> Hardware Drivers. After I deactivated it and rebooted it worked again, but another reboot it stopped working. I had a quick look and it used the new driver again, even though it was deactivated. Tried activating it and put acer_wmi in the blacklist as suggested, but it didn't work.

I have the same problem. After some time, app. 20 minutes to one or two hours my wireless connection fails. I am connected to the university Eduroam network using WPA2. I first had this problem now after upgrading to ubuntu 9.04. A shutdown-restart fixes the problem.

My dmesg reads the following right after the connection goes down. (Delete if you find this irrelevant)

[ 3469.450162] wlan0: RX ReassocResp from 00:0b:85:88:42:5d (capab=0x431 status=0 aid=1)
[ 3469.450175] wlan0: associated
[ 5029.411212] wlan0: authenticate with AP 00:0b:85:88:42:5d
[ 5033.466925] ath5k phy0: gain calibration timeout (2437MHz)
[ 5033.466944] ath5k phy0: can't reset hardware (-11)
[ 5033.466956] phy0: failed to restore operational channel after scan
[ 5033.825976] ath5k phy0: gain calibration timeout (2412MHz)
[ 5033.825992] ath5k phy0: can't reset hardware (-11)
[ 5033.826004] wlan0: Failed to config new BSSID to the low-level driver
[ 5038.346041] ath5k phy0: noise floor calibration timeout (2412MHz)
[ 5039.274235] ath5k phy0: gain calibration timeout (2417MHz)
[ 5039.274256] ath5k phy0: can't reset hardware (-11)
[ 5039.274271] phy0: failed to set freq to 2417 MHz for scan
[...]

Jaunty, tuxonice, wireless and backports modules

On my AOA150, everythings worked fine with kernel 2.6.28-13, tuxonice and linux-backports-modules-jaunty. Updgrading upward, I couldn't had ath5k loaded anymore until I removed linux-backports-modules-jaunty. Without that package, wifi works again as expected (wpa) with kernel 2.6.28-15. Sure, wifi led remains black, but this is not an issue for me.

To Fix Choppy Video Playback With Intel Video

  1. Pass enable_mtrr_cleanup to kernel in /boot/grub/menu.lst. (Explanation of problem at: http://perens.com/blog/2009/01/31/13/)

  2. Determine video memory register and assign to mtrr. Explanation at: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/314928

  3. Make fix load automatically at each XSession startup. Explanation at: http://ubuntuforums.org/showpost.php?p=7078262&postcount=35
    Alternately create your fix file as root somewhere safe: sudo gedit /usr/local/bin/fixmtrr

    • #!/bin/bash
      if ! `cat /proc/mtrr | grep -q "write-combining"` ; then

      • echo "base=0xyourbase size=0xyoursize type=write-combining" > /proc/mtrr

      fi

    Set execute permissions on the file
    • sudo chmod a+x /usr/local/bin/fixmtrr
    Set sudoers access using sudo visudo - (following goes at the end of the file):
    • yourusername ALL=NOPASSWD: /usr/local/bin/fixmtrr

    Place the autorun command in the System/Preference/Startup Applications dialog (or Sessions on earlier Ubuntu's):
    • sudo /usr/local/bin/fixmtrr
  4. *Optional* You can get latest version of Intel driver (v. 2.7.0) by adding the following ppa to your sources: deb http://ppa.launchpad.net/glasen/ppa/ubuntu jaunty main [Edit: The more recent and complete updates might be available here: https://launchpad.net/~ubuntu-x-swat/+archive/x-updates/]

Comment on script in point 3.

  • Why are you using command substitution with your if there? Since you have grep -q there will be nothing to execute, so it should be safe in this case, but why do it more complicated than it needs to be?

    if ! grep -q "write-combining" /proc/mtrr; then

== Discuss==

First Problem: the Easiest way to build a new kernel is with kernelcheck and it will take the original kernel options and you can search for and add enable_mtrr_cleanup in the build. This looks to be what bruce perens did. The problem is that there are 8 mtrr registers and the bios uses them all by default, leaving none for X this slows down the Aspire one.

There are some issues. On a 8GB Aspireone I found that 3Gb of free space wasn't enough to build the kernel and also you need to allow windows to be moved above the screen a little to be able to see whats happening with kernelcheck. So I had to build on a separate system but 2.6.29 works and frees two mttr registers (but the Wireless light doesnt flash anymore) its noticably faster in use.

NEW!! Easier workflow - UNR Choppy Flash Video for Dummies:

I am a linux dummy, but a total computer nerd. This solution took my Flash Video from NO speed to full speed allowing me to watch Hulu and You tube with no video hesitation. I will walk you through step by step:

1. Install UNR 9.04 2. DO NOT install Flash from the default respository. 3. Install Flash 10 from Adobe following these instructions in terminal:

$ cd /tmp
$ wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.tar.gz
$ tar -zxvf install_flash_player_10_linux.tar.gz
$ cd install_flash_player_10_linux
$ ./flashplayer-installer

4. Then, add the following to /boot/grub/menu.lst with these commands

$ sudo gedit /boot/grub/menu.lst

where you see # defoptions in that file, add the following: enable_mtrr_cleanup mtrr_spare_reg_nr=1 to make it look like this: # defoptions splash quiet enable_mtrr_cleanup mtrr_spare_reg_nr=1 Save this file, exit, restart

Hibernate should work out of the box with an adequate swap file (2x RAM) (MEP)

== To get Hibernate working (using TuxOnIce) (may not be necessary with correct swap)==

  1. Make sure that you have a swap partition set up (it doesn't have to be as big as 2xRAM)
  2. Add the TuxOnIce PPA repositories (and don't forget to add the auth key), which you can find here: https://launchpad.net/~tuxonice/+archive/ppa

  3. Follow the instructions here: http://lists.tuxonice.net/lurker/message/20090409.181125.d20e0bbe.en.html

Discuss

== any other issues ==

I created a package for the fan control module which uses DKMS and includes an init script to load the module on boot. I'm tempted to add the information on the main page but I don't want to tread on anyones toes. The package is here

https://launchpad.net/~paul-hirst/+archive/ppa

If anyone is interested they can contact me on launchpad. Thanks.

Can I request a brief guide to using the 'Storage Expansion' slot to combine an SD card with the SSD under Jaunty?

**Fix for sdhc cards** I've found the instructions here: http://crunchbanglinux.org/wiki/howto/aspireone much more reliable: ie creating a /etc/modprobe.d/sdhci file, with just these two lines in it:

  • options pciehp pciehp_force=1 options sdhci debug_quirks=1

The grub line solution on the front page gives errors, and flat out doesn't work for me... Any others have thoughts here? (on A110)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Am using AA1 150, BIOS V.3309 with Netbook Remix and while the Aspire one report for UNR says that Card Reader is an issue, cards are readable if inserted during boot. Unfortunately this is not the case for me. My laptop does not read cards whether they are inserted after boot or before. I tried the pciehp pciehp_force=1 but that did not work.I have tried the solution listed here but that has not worked as well.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

AO751h (11.6 inch, 1366x768 display) cannot wake up from sleep

Visual effects in AA1 150

I am using AA1 150. After having automatically upgraded from Intrepid Ibex to Jaunty, I can't enable any visual effects (the computor says "video effects could not be enabled"). But, at least one of the effects was very important for users of netbooks: it is the ability to drag a window from one screen to another. Have you encountered this problem? How has it to be solved for AA1? Best regards, Alexandre.

i'm on a 110L with 1.5gb ram , a fresh install of jaunty has no problems with visual effects it just works. perhaps there is something left from the old install?

Wireless Problems Connecting WEP(Wired Equivalent Privacy) 64-bit - encryption shared key Ubuntu 9.10 PT - Aspire One AOA110

The wireless device is installed it detects all the available wireless connections but when I edit my connection to select WEP, shared key and to insert access key the network connects for seconds and then it goes offline. When I edit connection again the access key field it's empty.

If I search for available wireless networks I do find several nearby but when I select it to connect nothing happens...


CategoryPageDiscussion

AspireOneDiscussion (last edited 2013-12-08 02:14:41 by cprofitt)