Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...


Candidate for Deletion
This article may not be appropriate for this wiki, and may be deleted. More info...

The page is so outdated it is probably best to delete it and write a new from scratch.

This page attempts to present an easy and simple official method to help any user set up SCIM in Ubuntu. SCIM is used to input different languages, most often Asian languages like Chinese, Japanese or Korean, but it can be used to input many other languages as well. For further explanations, please go to https://wiki.ubuntu.com/InputMethods/SCIM/Setup

For Kubuntu, see /Kubuntu

To install im-ja, an alternative Japanese input method, please see ImJa.

IconsPage/tip.png On Ubuntu 8.10 and 8.04, you should only need to do the Quick Setup. On Ubuntu 7.10 and Ubuntu 7.04, you need to do the Quick Setup, plus one more step in case your session is not using a CJK (Chinese, Japanese or Korean) language, which would be the case of most western languages.

Quick Setup

SCIM is the name of the program that will allow you to input a CJK language in Ubuntu.

  1. Open System>Administration>Language Support1:


  2. and install the support package corresponding to the language you want to input2:


  3. under Ubuntu 8.10, 8.04, 7.10 and 7.04, you will have to check the box at the bottom (Input Method) to activate complex characters input. You might have to uncheck it, click Apply, then check it again and click Apply.
  4. then log out (System>Quit>Log Out), and login again.

On Ubuntu 8.10 and 8.04, you should be able to use SCIM input in any application (go to Using SCIM to learn how to do it). However, KDE applications in a Gnome session won't have SCIM input enabled this needs to be completed. Also and a few applications like Skype and aMSN might need a few more steps in order to enable SCIM input.

Under previous versions of Ubuntu, if your session is using a CJK language (for example, all your menus are in Chinese, Japanese or Korean) you should be able to do the same (go to Using SCIM to learn how to do it).

If your session is not using a CJK language, see Additional configuration if you're not using a CJK session.

Note for Xubuntu

Under Xubuntu 8.04, you will need to install scim-bridge-client-gtk via synaptic in order to successfully check the "Enable support to enter complex characters" option, in the Language Support menu

Using SCIM

SCIM should now start along with every application. To trigger it, use any of these shortcut keys : Control+Space, Shift+Space, Zenkaku_Hankaku(on Japanese keyboard), Hangul(on Korean keyboard)

While inputting, if you want to switch back and forth between your CJK language and your session language, you can just use the shortcut key, or even just the Shift key alone. Fast and easy!

Incompatibilities with Some Applications

KDE Applications in a Gnome Session

Please insert simple step by step guide on how to get SCIM input working for KDE applications like Amarok in a Gnome session

MythTV, Skype and aMSN

On Hardy Heron (and possibly earlier versions as well) SCIM will not work on applications compiled with their own version of QT such as Skype or aMSN. To resolve this do the following in addition to the guide above:

  • Edit /etc/profile
    gksudo gedit /etc/profile
  • And add the following lines
    # SCIM
    export XMODIFIERS='@im=SCIM'
    export GTK_IM_MODULE="scim"
    export XIM_PROGRAM="scim -d"
    export QT_IM_MODULE="scim"
    scim -d

If you haven't already added your locale to /etc/scim/global do that now.

  • Run the command 'locale' in your terminal, and copy the locale name after LANG=
  • Edit the file /etc/scim/global:
    gksudo gedit /etc/scim/global
  • And add your locale name to the line /supportedUnicodeLocales = list using comma, for example:
    /SupportedUnicodeLocales = fr_FR.UTF-8,en_US.UTF-8
  • Restart your X server or reboot to apply settings

Applications Failing to Start

On Ubuntu 6.10 (and possibly under Ubuntu 6.04, not tested), after making these changes, some applications (such as Open Office) may fail to start, or may appear to start and then simply die. If you encounter this issue, try using the "scim_xim" option for im-switch instead of "scim", for example:

im-switch -z en_GB -s scim_xim

Additional configuration if you're not using a CJK session

On Ubuntu 8.10, you should be able to use SCIM in all applications except a few ones. On prior versions of Ubuntu, you should have SCIM input in Gnome applications, like gedit (Application>Accessories>Text Editor), by right clicking on the document, then selecting Input Methods>SCIM Input Method. However, it won't work in the others, like Open Office. On Hardy or Gutsy, you might also notice that installing SCIM has broken deadkeys support - for example, you won't be able to type ï, because typing the ¨ key before the i key will result in ¨i. Do not worry, the following steps will ensure both deadkeys and SCIM will work together.

Under Ubuntu 8.10 (Intrepid Ibex)

If you are logging in with your system's default language (defined in the language support dialog above) SCIM input should be enabled for all programs. However there are exceptions for some KDE programs under Gnome and a few other applications.

If you are not using your system's default language, try the steps for Ubuntu 8.04 just below.

Under Ubuntu 8.04 (Hardy Heron)

If your user interface is English, there is nothing more to do since the ubuntu-desktop package already brings scim-bridge-client-gtk and language-selector setup the use of scim-bridge by default.

If you are using another interface language (non-English and non-Asian) and SCIM does not appear once you logout and re-login take the following steps:

  1. Open a terminal (Applications>Accessories>Terminal)

  2. Type :

    locale|grep 'LANG='
    and hit enter.
  3. This will display your locale. For example, Spanish (Spain) is "es_ES.UTF-8"
  4. Type

    im-switch -z (your_locale) -s scim-bridge

    For example,

    im-switch -z es_ES.UTF-8 -s scim-bridge
  5. Logout and login, SCIM should now be active.

Under Ubuntu 7.10 (Gutsy Gibbon)

  1. Open System>Administration>Synaptic Package Manager1 and install the package named scim-bridge :


Alternatively, if you prefer the command line, you can type in a terminal :

sudo apt-get install scim-bridge

If you want to use SCIM input in KDE applications, like Amarok or K3b, you will also have to install the package scim-bridge-client-qt using one of the two aforementioned methods (the package scim-bridge-client-gtk, for Gnome applications, should have been installed automatically along with scim-bridge).

  1. Edit the file /etc/X11/xinit/xinput.d/scim by typing in a terminal (Applications>Accessories>Terminal):

gksudo gedit /etc/X11/xinit/xinput.d/scim

Change the line :


into :


If you want to use SCIM input in KDE applications, you will also have to change the following line :


into :


The resulting file will look like this:


Save the file, then to be sure you won't be affected by previous configurations you can delete the folders .scim and .xinput in your home directory. Since they are hidden folder, you can make them appear in Nautilus with the shortcut Ctrl+H.

Now restart your computer and you should be done Smile :)

Under Ubuntu Versions Prior to Ubuntu 7.10

The recommended method to set up SCIM input for all applications is using a command-line tool called im-switch (where im stands for Input Method, obviously Smile :) ). Before that, you will have to know the name of the locale you're using. In a terminal (Applications>Accessories>Terminal) type :

locale | grep LANG=

The answer would be something like


where the relevant part is en_GB (en standing for English and GB for the country, here Great Britain). Another example could be fr_FR (fr for French and FR for France).

Now you just have to install an additional package called scim-qtimm and tell the system you want to use SCIM as the input method for your locale, using

im-switch -z “your locale” -s scim

In the above example, with an en_GB locale, you would type in the terminal :

sudo apt-get install scim-qtimm
im-switch -z en_GB -s scim

Log out, then log in again. SCIM should be now the default input for all applications (go to Using SCIM to learn how to use it)

Note for Xubuntu users : On Xubuntu, the system will ask you first to install the package libapt-pkg-perl. Install it from Synaptic (see above) or by the command line :

  • sudo apt-get install libapt-pkg-perl

Then you'll be ready to use im-switch (see just above). In Xubuntu, you will also have to apply the following instructions :

In Case All of This Doesn't Work

You might have to add your locale as a supported locale, by editing (you might have to create it) the file ~/.scim/global (the ~ means it's in your home directory, the . that .scim directory is a hidden file. Just type in a terminal :

gedit ~/.scim/global 

If you can find a line like

/SupportedUnicodeLocales = en_US.UTF-8

add your locale to it after a comma, not forgetting you need to add the full name reported by locale | grep LANG= after LANG= . In case of English for Great Britain, your line would look like this one :

/SupportedUnicodeLocales = en_US.UTF-8,en_GB.UTF-8 

If the line wasn't there, create it, then save the file.

Log out, then log in and you should be able to use SCIM input in every application.


  • If you find that the shortcut key has stopped working, check your Caps Lock status. The shortcut key for SCIM will not work if Caps Lock is turned on (this is arguably a bug).
  • If you are using dead keys (i.e. keys like ~, ^, `, etc. that you hit before you hit the letter key on which the accent should sit, in order to get things like ñ, â, ì, etc.), you might encounter the problem that they don't work any more as soon as you activate SCIM. Maybe this helps: Go to the SCIM setup window, choose IMEngine - Global setup, scroll down to 'Other', expand the entry, activate 'English/European', hit 'OK' and restart your system. You'll see two separate entries for latin (english) letters now, which seems unnecessary, but in some cases this seems to be the only way to get back your dead keys.

Reverting changes

If you've just done the Quick setup, you just need to go back to System>Administration>Language Support, uncheck both the support package corresponding to the language you want to remove and the box at the bottom (Input Method), then click Apply or Ok.

If you've also done other steps to enable SCIM input, try to revert these exact steps. The following methods might help you:

  • Use im-switch to set the input method for your locale to "default", for example:

    im-switch -z en_GB -s default

  • Remove the file in your ~/.xinput.d directory corresponding to the appropriate locale:

    rm ~/.xinput.d/en_GB

  • Remove the SCIM package from your system (this should not be needed, and isn't the cleanest method, but should do the job if nothing else does):

    apt-get remove scim

The Simplest Method to switch to SCIM by denim98@gmail.com ( malaysia )

1. Install your language support thru Administration/Language Support

2. Go to Administration/Keyboard/Layouts

  • click +add and add the keyboard layout for the language you want e.g. Chinese
  • click close

3. Add to top panel "Keyboard Indicator" and when you restart Ubuntu you will see the keyboard icon on the top right of the screen.

4. Left-click and set your SCIM.

5. when you open Firefox or OpenOffice , you can use the new language

  1. You'll need administrative rights for these kind of tasks, else ask your system administrator to install it for you. (1 2)

  2. You'll need an Internet connection because these packages don't fit on the Install CD. (3)

SCIM (last edited 2013-12-13 23:41:41 by knome)