Recent versions of Ubuntu

Most tablets should be detected automatically in recent versions of Ubuntu. Try connecting it and using it in an application such as MyPaint or GIMP. If that works, you are done and don't have to bother with the following.

Known tablets working with the Wizardpen-driver

The setup has been tested with the following USB tablets. Non-USB tablets are not covered by this guide.

Known Tablet Names (The packaging)

  • Acecad Flair II GT-504
  • DigiPro 5.5×4” Graphics Tablet

  • Digital Ink Pad (A4 format)
  • G-pen
  • G-Pen 4500
  • Genius Wizardpen
  • Genius Mousepen
  • Genius Easypen i405
  • Genius EasyPen M610

  • Genius G-Pen F610
  • Genius G-Pen M610
  • Genius G-Pen 340 (UC-LOGIC Tablet WP4030U)
  • Genius G-Pen 450 (UC-LOGIC Tablet WP5540U)
  • Genius
  • iBall
  • Manhattan
  • NGS CADBOY (UC-LOGIC Tablet WP5540U)
  • Pentagram
  • QWare
  • Trust TB-3100
  • Trust TB-5300
  • Trust TB-6300
  • UC-LOGIC
  • iBall Tablet PF8060
  • AIPTEK HyperPen 10000 U

  • AIPTEK Slim Tablet U600 Premium II
  • Monoprice Graphic Drawing Tablet WP8060-TAB08
  • Kanvus Artist 127
  • Kanvus Office 53

Setting up your tablet

Method 1

As of march 2010 the latest wizardpen driver from Wizardpen on Launchpad is available for Ubuntu/Debian as xserver-xorg-input-wizardpen.

* For Ubuntu Lucid (10.04) and Ubuntu Maverick (10.10), just add the following line to the software sources as described in here:

 ppa:doctormo/xorg-wizardpen 

* For Ubuntu Jaunty (9.04):

 deb http://ppa.launchpad.net/doctormo/xorg-wizardpen/ubuntu jaunty main
 deb-src http://ppa.launchpad.net/doctormo/xorg-wizardpen/ubuntu jaunty main 

After adding the repository install the driver using the command bellow:

sudo apt-get update
sudo apt-get install xserver-xorg-input-wizardpen

Method 2

Open a terminal

Install some needed packages - Run this command:

sudo apt-get install xutils libx11-dev libxext-dev build-essential \
            xautomation xinput xserver-xorg-dev xutils-dev libtool \
            autoconf

Downloading the driver

You can download the latest driver from Wizardpen on Launchpad. Either try to find a deb or a source package there, or get the latest version using bzr. If you choose to install a source package you can just extract it and skip to "Building and installing the driver".

To install bzr run:

sudo apt-get install bzr
bzr branch lp:wizardpen

Now we need to generate the ./configure script:

./autogen.sh

Building and installing the driver

Run these commands from the directory you installed the source:

Configure, make and install:

./configure --with-xorg-module-dir=/usr/lib/xorg/modules
make && sudo make install

Check the integrity of the driver installation by typing the command.

ls /usr/lib/xorg/modules/input/wizardpen_drv.*

It should give the output as follows

/usr/lib/xorg/modules/input/wizardpen_drv.la
/usr/lib/xorg/modules/input/wizardpen_drv.so

Configuration

For Jaunty (9.04) release:

Type the following command in the terminal to know the make of the Pentablet.

grep -i name /proc/bus/input/devices

Please note down the make of the tablet which you have to use in the next step.

Create a new .fdi file by using the following command in terminal

sudo vi /etc/hal/fdi/policy/99-x11-wizardpen.fdi

Press 'I' so that INSERT appears Paste the following template in the terminal

<?xml version="1.0" encoding="ISO-8859-1" ?>
            <deviceinfo version="0.2">
            <device>
                <!-- This MUST match with the name of your tablet obtained -->
                <!-- in Step 2 specified previously                        -->
                <match key="info.product" contains="NAME OF YOUR TABLET">
                <merge key="input.x11_driver" type="string">wizardpen</merge>
                <merge key="input.x11_options.SendCoreEvents" type="string">true</merge>

                <!-- Modify these configuration accordingly -->
                <!-- See CONFIGURATION OPTIONS section for the full-set of -->
                <!-- configurable options                                  -->
                <merge key="input.x11_options.TopX" type="string">5619</merge>
                <merge key="input.x11_options.TopY" type="string">6554</merge>
                <merge key="input.x11_options.BottomX" type="string">29405</merge>
                <merge key="input.x11_options.BottomY" type="string">29671</merge>
                </match>
            </device>
            </deviceinfo>

Please insert the name of your tablet where i have mentioned NAME OF YOUR TABLET. You can do this by moving the cursor in the terminal with arrow keys. Click Esc and type :wq and press Enter to save the file you have created.

  • Reboot your machine. It should work.

For Lucid Lynx (10.04) release:

Reboot your machine. It should work.

If the tablet is still not working, follow this instructions:

write the following command in the terminal:  ls /dev/input/by-id/ 

copy the caption saying something like:

 *-event-mouse 

that is matching your tablet.

Edit "/usr/lib/X11/xorg.conf.d/70-wizardpen.conf" file, it should be there if you installed the driver properly (in Maverick this file is /usr/share/X11/xorg.conf.d/70-wizardpen.conf).

If your tablet is Waltop, you would need to add "|WALTOP|Waltop" to MatchVendor value.

Try to set identifier to name of device (you may see it in /var/log/Xorg.0.log, for Genius EasyPen M610 name is "6x10 Tablet").

Now place the caption you copied instead of the "_COPY HERE_" text, also place the same caption instead of the "_COPY HERE TOO_", without the "-event" text:

Section "InputClass"
   Identifier "wizardpen"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/by-id/___COPY HERE___"
   MatchVendor "UC-LOGIC|KYE Systems|Ace Cad|WALTOP|Waltop"
   Driver "wizardpen"
EndSection
Section "InputClass"
   Identifier "wizardpen ignore mouse dev"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/by-id/___COPY HERE TOO___"
   MatchVendor "UC-LOGIC|KYE Systems|Ace Cad|WALTOP|Waltop"
   Driver ""
EndSection

an example of a complete config file after edit:

Section "InputClass"
   Identifier "wizardpen"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/by-id/usb-UC-LOGIC_Tablet_WP4030U-event-mouse"
   MatchVendor "UC-LOGIC|KYE Systems|Ace Cad|WALTOP|Waltop"
   Driver "wizardpen"
EndSection
Section "InputClass"
   Identifier "wizardpen ignore mouse dev"
   MatchIsTablet "on"
   MatchDevicePath "/dev/input/by-id/usb-UC-LOGIC_Tablet_WP4030U-mouse"
   MatchVendor "UC-LOGIC|KYE Systems|Ace Cad|WALTOP|Waltop"
   Driver ""
EndSection

Calibration

8060 IconsPage/note.png Note: In the subsection, you'll find output from calibrate. If your tablet is listed there, you can just use that output instead.

  • If you tablet isn't listed, I would love to recieve an email with the output, and the model of your tablet. (See email at the end of the page.)

If you want to calibrate yourself, just proceed.

Enter the "calibrate"-directory - Run this command:

cd calibrate

Calibrate in order to find the edges of your tablet/digitizer - Run this command:

sudo ./wizardpen-calibrate /dev/tablet-event

You may find "/dev/tablet-event" missing, try this command to help find the correct value

ls /dev/input/by-id/

Example corrected "/dev/tablet-event" location. Use the value for rc.local and xorg.conf

/dev/input/by-id/usb-WALTOP_International_Corp._Slim_Tablet-event-if00

Save the output from wizardpen-calibrate (the last 10 lines) - You'll need it later in this HowTo.

Calibration output (If calibrate for some reason doesn't work)

IconsPage/tip.png Skip this section if calibrate worked for you.

Genius G-Pen F610 (WALTOP SlimTablet) :

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Driver          "wizardpen"
        Option          "Device"        "/dev/input/by-id/usb-WALTOP_International_Corp._Slim_Tablet-event-if00"
        Option          "TopX"          "295"
        Option          "TopY"          "210"
        Option          "BottomX"       "20000"
        Option          "BottomY"       "12500"
EndSection

Tablet W5540U (UC-Logic):

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "2199"
        Option          "TopY"          "3598"
        Option          "BottomX"       "30325"
        Option          "BottomY"       "29278"
EndSection

Tablet W8060U (UC-Logic):

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "826"
        Option          "TopY"          "2626"
        Option          "BottomX"       "32747"
        Option          "BottomY"       "32762"
EndSection

Tablet PF1209 (UC-LOGIC)

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "0"
        Option          "TopY"          "1553"
        Option          "BottomX"       "32541"
        Option          "BottomY"       "32762"
EndSection

Tablet W8060U (Trust TB-6300)

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "0"
        Option          "TopY"          "234"
        Option          "BottomX"       "32747"
        Option          "BottomY"       "32762"
EndSection

For some configuration you might need to stop at this point and just add your TopX, TopY, BottomX, BottomY values into both sections of "/usr/lib/X11/xorg.conf.d/70-wizardpen.conf" file using syntax from examples above, without setting them in /etc/X11/xorg.conf file.

Setting up X

Now we are ready to edit the xorg.conf file.

Take a backup - Run this command:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Edit the file - Run this command:

sudo vim /etc/X11/xorg.conf

Press "I" - So that "-- INSERT --" appears

Insert the output from calibrate into xorg.conf: (just place it below your generic mouse)

Add the following line in the "ServerLayout" section:

InputDevice "WizardPen Tablet" "AlwaysCore"

Save the file, and exit the editor (Press "ESC" and write ":wq" and press "Enter")

Making X start without a tablet connected

Now, the driver should NOT be initialized, if the tablet is NOT found

The wizardpen-driver does not support hotplugging, so we should run a script on startup, to define whether or not the tablet is present.

Open /etc/rc.local - Run this command:

sudo vim /etc/rc.local

Press "I" - So that "-- INSERT --" appears

...and insert some code: (insert it JUST above "exit 0")

XORG_CONF=/etc/X11/xorg.conf
if [ -e /dev/tablet-event ]; then
  sed -ie 's/^\(\s*\)\#\(\s*InputDevice\s\s*\"WizardPen\ Tablet\"\s\s*\"AlwaysCore\"\)\s*$/\1\2/' "$XORG_CONF"
  echo "Udev created /dev/tablet-event = Tablet present - Tablet-driver enabled"
else
  sed -ie 's/\(^\s*InputDevice\s\s*\"WizardPen\ Tablet\"\s\s*\"AlwaysCore\"\)\s*$/\#&/' "$XORG_CONF"
  echo "Udev did NOT create /dev/tablet-event = tablet NOT present - Tablet-driver disabled"
fi

Save the file, and exit the editor (Press "ESC" and write ":wq" and press "Enter")

Now you can test udev's ability to detect the tablet - Run this command:

sudo /etc/init.d/rc.local start

The output will tell you if it is present or not - And it should match reality (try to disconnect it, and try again - connect, and then again - etc...)

You should now be able to restart X and have the tablet working as a mouse.

I'm still working on a way to support hotplugging, but the above code-example will make X start without a present tablet.

Configuring the buttons on the pen

IconsPage/note.png Special thanks to riesenpixel for writing the following part about the button-configuration.

There are two ways to change the button mapping:

The first way (Not very smart, since it also change the behaviour of your generic mouse)

If you want to change the button mapping for all devices running in core mode, you should use xmodmap. (not recommended, try the second way first)

Show the current configuration:

xmodmap -pp

You will get a table like this:

Physical Button

Button Code

1

1

2

2

3

3

4

4

5

5

6

6

7

7

8

8

9

9

For example, if you now want to change the middle button and the right button, execute the following command:

xmodmap -e "pointer = 1 3 2"

Here is a list of numbers with their corresponding function:

Number

Function

0

No action (only movement)

1

Left button click

2

Middle Button click

3

Right Button click

4

Scroll up (one click equals one step of scroll wheel in my logitech mouse)

5

Scroll down

If you want to disable a button (maybe because you know that one of the buttons causes some problems), use zero. Example (should disable the right click):

xmodmap -e "pointer = 1 2 0"

To reset the xmodmap-configuration, use this command:

xmodmap -e "pointer = default"

The second way

If you are using more devices than just the tablet (e. g. mouse+tablet or multiple tablets a. s. o.) you can use this second way to change the mapping just for one device.

  • Step 1: Find the name of the device you want to change, e.g. with this command: xsetpointer -l alternatively you can use this command: xinput list

    Step 2: execute this command to swap the middle and the right button ("WizardPen Tablet" is the device – if you want to change the configuration of another device, you have to change the name; use the table above to define other buttons)

xinput set-button-map "WizardPen Tablet" 1 3 2

Hint: If you experience problems with the buttons, use:

xinput set-button-map "WizardPen Tablet" 1 0 0

or, if you have a pen with 32 buttons Wink ;)

xinput set-button-map "WizardPen Tablet" 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

...to disable all buttons on your pen (for instance if you just want to draw).

Troubleshooting - See this if you have any problems

Everything worked great, except the mouse doesn't move at all

This is known to be an issue with WP8060 at least, and possibly other models. Fortunately, there is a common fix as well. You need to go back into /etc/X11/xorg.conf and modify the InputDevice section a little:

Section "InputDevice"
       Identifier  "Tablet"
       Option "Name" "UC-LOGIC Tablet WP8060U"
       Option "SendCoreEvents" "true"
       Driver          "wizardpen"
       Option           "TopX"          "2650"
       Option           "TopY"          "3563"
       Option           "TopZ"          "10"
       Option           "BottomX"       "30733"
       Option           "BottomY"       "29715"
       Option           "BottomZ"       "511"
EndSection

The whole block is shown to indicate context. The main thing to change is the

Option "Name" "UC-LOGIC Tablet WP8060U"

part. Set the name to whatever type you have.

Reboot the XServer by logging out and back in, or typing sudo /etc/init.d/gdm restart, or reboot your computer, and you're good to go.

After X server restart, display reverts to "Safe Mode"

From xtoast's suggestion on the discussion page (linked at the bottom of this article), I found the ServerLayout line provided in the Setting up X section above causes my xorg.conf to 'forget' basic video display settings. I used the line suggested on the discussion page instead:

InputDevice     "Tablet"     "SendCoreEvents"

Restarted the PC and everything worked. I did not follow the rest of the advice on the linked page because just modifying the ServerLayout line resolved my problem.

The command cat /var/log/Xorg.0.log | grep "wizardpen" outputs errors

The output of

cat /var/log/Xorg.0.log | grep "wizardpen"
  • may reveal several errors, some of them are:

Module present, but with compilation-errors:

(II) LoadModule: "wizardpen"
(II) Loading /usr/lib/xorg/modules/input/wizardpen_drv.so
dlopen: /usr/lib/xorg/modules/input/wizardpen_drv.so: undefined symbol: __stack_chk_fail_local
(EE) Failed to load /usr/lib/xorg/modules/input/wizardpen_drv.so
(II) UnloadModule: "wizardpen"
(EE) Failed to load module "wizardpen" (loader failed, 7)
(EE) No Input driver matching `wizardpen'

Module missing:

(II) LoadModule: "wizardpen"
 (WW) Warning, couldn't open module wizardpen
(II) UnloadModule: "wizardpen"
 (EE) Failed to load module "wizardpen" (module does not exist, 0)
(EE) No Input driver matching `wizardpen'

The Xserver is not starting after playing with the xorg.conf file

Wow - That's bad - First of all, check that you set everything right.

Well, I suggest that you drop me an email, telling me what went wrong.

And then just restore the backup we created - run this command:

sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

Everything seems to work, except pressure sensitivity

All the tablets mentioned in "known tablets" has pressure sensitivity support in Linux.

If pressure-sensitivity doesn't work, there are 3 possible causes:

1. The driver is not properly installed

2. The tablet is not supported by this driver

3. The application is not properly configured, to accept pressure sensitivity.

Please make sure that your favourite application supports pressure sensitivity.

Application

Support for pressure sensitivity

Guide

Krita

Full support since 1.6

Non yet

Inkscape

Full support

TabletSetupInkscape

Gimp

Full support - but problems with 2.2.13

TabletSetupGIMP

Please tell me about other applications.

Pressure sensitivity works, but is not calibrated well

The section we inserted into xorg.conf holds some options to calibrate the area of the tablet, but I haven't put in options to configure pressure sensitivity, since it varies a lot.

You can insert these options to enable MAX and MIN pressure sensitivity:

  • Option "TopZ" "10" Option "BottomZ" "511"

Where "TopZ" represents the lowest pressure-level to accept, and "BottomZ" represents the maximum pressure-level to accept.

The tablet is automatically detected as a generic mouse

In addition to the Wizardpen configuration, my system automatically configured the tablet as a generic, relative-positioned mouse. This double configuration caused the mouse pointer to move out of sync with the tablet's absolute position. Explicitly defining X11's CorePointer Device prevented auto-configuration of the tablet, leaving Wizardpen the only driver using the device (the desired behavior). For an example configuration, see the forum post: How do I -disable- tablet control of the mouse?.

The tablet works but losts cursor on each touch. Cursor reveals if to move pen out and bring it back to tablet

On my WALTOP tablet it was solved by: 1) restoring original /etc/X11/xorg.conf 2) updating "/usr/lib/X11/xorg.conf.d/70-wizardpen.conf" with "|WALTOP|Waltop" in MatchVendor value 3) adding TopX, TopY, BottomX, BottomY right into "/usr/lib/X11/xorg.conf.d/70-wizardpen.conf" for both sections. You can get them using calibrate or at worst by experimental way.

Clicking does weird things or the cursor jumps

If your tablet input works, but you experience strange behaviour when clicking (it seemingly doubleclicks or drags when you try to single-click), or the mouse cursor jumps around, it might be that your device is configured twice.

The device will show up multiple times in "xinput list", sometimes even under different names.

This happens if you define both a specific section "InputDevice" in /etc/X11/xorg.conf and have an "InputClass" in /usr/share/X11/xorg.conf.d/70-wizardpen.conf.

Comment out either of them to solve the problem.

I have problems not solved by the above troubleshooting

Try one of these forums:

http://www.stud.fit.vutbr.cz/~xhorak28/unb/forum.php

http://ubuntuforums.org/showthread.php?t=1337260

Talking about hotplugging: (haven't tested it - Please mail me in case it works, and should be implemented here) http://deadcabbit.blogspot.com/2007/07/linux-genius-wizardpen-setup-for-udev.html


CategoryHardware

TabletSetupWizardpen (last edited 2013-12-13 23:40:27 by knome)