IconsPage/warning.png THIS GUIDE IS NO LONGER UPDATED - SEE: TabletSetupWizardpen for support for the newest release

Known tablets working with the Wizardpen-driver

The setup has been tested with the following USB tablets.

Non-USB tablets are not covered by this guide.

Known Tablet Names (The packaging)

  • Acecad Flair II GT-504
  • DigiPro 5.5×4” Graphics Tablet

  • Digital Ink Pad (A4 format)
  • G-pen
  • Genius Wizardpen
  • Genius Mousepen
  • Genius
  • iBall
  • Manhattan
  • Pentagram
  • QWare
  • Trust TB5300
  • Trust TB-6300

Known Tablet SystemNames (How the computer recognize it!)

  • Syntax: Output from "/sys/bus/usb/devices/*/product" (Output from "lsusb") - Name
  • Tablet WP4030U (lsusb: UC-Logic Technology Corp. ) - Tablet WP4030U
  • Tablet WP5540U (lsusb: UC-Logic Technology Corp. Genius MousePen 5x4 Tablet) - Genius MousePen 5x4 Tablet

  • Tablet WP8060U (Genius MousePen 8x6 Tablet) - Genius MousePen 8x6" Tablet

  • Tablet WP8060U (lsusb:UC-Logic Technology Corp.) - Manhattan Graphics Tablet 8x6"
  • Tablet WP8060U (lsusb: UC-Logic Technology Corp.) - Trust TB-6300 Tablet 8x6" Tablet
  • Tablet PF1209 (lsusb: UC-Logic Technology Corp.) - Genius PenSketch 9x12"

  • Tablet PF1209 - Pentagram Titan Tablet
  • TABLET DEVICE (UC-Logic Technology Corp. Genius MousePen 5x4 Tablet) - DigiPro 5.5×4” Graphics Tablet

If your tablet is working, but not listed here, please ADD it! (If you don't have an account, then email me: danielklejnstrup@gmail.com)

Setting up your tablet

General information

This guide is based on the newest release: *ubuntu 8.04 (Hardy Heron)

temporary note: currently Intrepid HAL breaks tablet settings in xorg.conf follow the instructions for Hardy but see this bug report for a HAL rule that blacklists the tablet from HAL https://bugs.launchpad.net/ubuntu/+bug/277946

IMPORTANT! Hardy Heron seems to have upgraded Xorg beyond version 1.7.3 in May 2008. After this version, setting up UDEV is no longer needed. Please start Synaptic and search titles for "xorg" to see which version you have. For 1.7.3 and after, see TabletSetupWizardpenHardy173

For an *ubuntu 6.06 (Dapper Drake)-version, see TabletSetupWizardpenDapper

For an *ubuntu 7.04 (Feisty Fawn)-version, see TabletSetupWizardpenFeisty

For an *ubuntu 7.10 (Gutsy Gibbon)-version, see TabletSetupWizardpenGutsy

Installing needed packages

Open a terminal

Install some needed packages - Run this command:

sudo aptitude install xutils libx11-dev libxext-dev x-dev build-essential xautomation xinput xserver-xorg-dev

Downloading and installing the driver

Download the wizardpen driver, and extract it! - Run these commands:

wget http://www.kubuntu.dk/wizardpen/wizardpen-

tar -xvf wizardpen-

cd wizardpen-

Configure, make and install:

sudo ./configure --with-xorg-module-dir=/usr/lib/xorg/modules && make
&& make install

Setting up udev (If the tablet is USB)

Connect your tablet (if not connected already)

Find out what the device is called, run this command:

cat /sys/bus/usb/devices/*/product

The output will look something like this: (depending on your system)

Tablet WP5540U
UHCI Host Controller
UHCI Host Controller
UHCI Host Controller
EHCI Host Controller

Note the product of the tablet (obviously Tablet WP5540U in my case!)

Now, add a udev rule: (Note that the SYSFS{product} is tablet-specific! - See output from above command!)

Run these commands:

sudo bash

echo 'BUS=="usb", KERNEL=="event*", SYSFS{product}=="Tablet WP8060U", NAME="input/%k", SYMLINK+="tablet-event", MODE="0666"' >> /etc/udev/rules.d/010_local.rules


Restart udev - Run this command:

sudo /etc/init.d/udev restart

Check that the syslink has been created - Run this command:

ls -la /dev/tablet-event

If it outputs a line, it means that it succeeded!


8060 IconsPage/note.png Note: In the subsection, you'll find output from calibrate! If you tablet is listed there, you can just use that output instead!

  • If you tablet isn't listed, I would love to recieve an email with the output, and the model of your tablet! (See email at the end of the page!)

If you want to calibrate yourself, just proceed.

Enter the "calibrate"-directory - Run this command:

cd calibrate

Build the calibration tool - Run this command:


Calibrate in order to find the edges of your tablet/digitizer - Run this command:

sudo ./wizardpen-calibrate /dev/tablet-event

Save the output from wizardpen-calibrate (the last 12 lines!) - You'll need it later in this howto!

Calibration output (If calibrate for some reason doesn't work!)

IconsPage/tip.png Skip this section if calibrate worked for you!

Tablet W5540U (UC-Logic):

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "2199"
        Option          "TopY"          "3598"
        Option          "BottomX"       "30325"
        Option          "BottomY"       "29278"
        Option          "MaxX"          "30325"
        Option          "MaxY"          "29278"

Tablet W8060U (UC-Logic):

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "826"
        Option          "TopY"          "2626"
        Option          "BottomX"       "32747"
        Option          "BottomY"       "32762"
        Option          "MaxX"          "32747"
        Option          "MaxY"          "32762"

Tablet PF1209 (UC-LOGIC)

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "0"
        Option          "TopY"          "1553"
        Option          "BottomX"       "32541"
        Option          "BottomY"       "32762"
        Option          "MaxX"          "32541"
        Option          "MaxY"          "32762"

Tablet W8060U (Trust TB-6300)

Section "InputDevice"
        Identifier      "WizardPen Tablet"
        Option          "SendCoreEvents"        "true"
        Driver          "wizardpen"
        Option          "Device"        "/dev/tablet-event"
        Option          "TopX"          "0"
        Option          "TopY"          "234"
        Option          "BottomX"       "32747"
        Option          "BottomY"       "32762"
        Option          "MaxX"          "32747"
        Option          "MaxY"          "32762"

Setting up X

Now we are ready to edit the xorg.conf file!

Take a backup - Run this command:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Edit the file - Run this command:

sudo vim /etc/X11/xorg.conf

Press "I" - So that "-- INSERT --" appears!

Insert the output from calibrate into xorg.conf: (just place it below your generic mouse!)

Add the following line in the "ServerLayout" section:

InputDevice "WizardPen Tablet" "AlwaysCore"

Save the file, and exit the editor! (Press "ESC" and write ":wq" and press "Enter")

Making X start without a tablet connected

Now, the driver should NOT be initialized, if the tablet is NOT found!

The wizardpen-driver does not support hotplugging, so we should run a script on startup, to define whether or not the tablet is present.

Open /etc/rc.local - Run this command:

sudo vim /etc/rc.local

Press "I" - So that "-- INSERT --" appears!

...and insert some code: (insert it JUST above "exit 0")

if [ -e /dev/tablet-event ]; then
  sed -ie 's/^\(\s*\)\#\(\s*InputDevice\s\s*\"WizardPen\ Tablet\"\s\s*\"AlwaysCore\"\)\s*$/\1\2/' "$XORG_CONF"
  echo "Udev created /dev/tablet-event = Tablet present! - Tablet-driver enabled"
  sed -ie 's/\(^\s*InputDevice\s\s*\"WizardPen\ Tablet\"\s\s*\"AlwaysCore\"\)\s*$/\#&/' "$XORG_CONF"
  echo "Udev did NOT create /dev/tablet-event = tablet NOT present! - Tablet-driver disabled"

Save the file, and exit the editor! (Press "ESC" and write ":wq" and press "Enter")

Now you can test udev's ability to detect the tablet - Run this command:

sudo /etc/init.d/rc.local start

The output will tell you if it is present or not! - And it should match reality! (try to disconnect it, and try again! - connect, and then again! - etc...)

You should now be able to restart X and have the tablet working as a mouse.

I'm still working on a way to support hotplugging, but the above code-example will make X start without a present tablet.

Configuring the buttons on the pen

IconsPage/note.png Special thanks to riesenpixel for writing the following part about the button-configuration!

There are two ways to change the button mapping:

The first way (Not very smart, since it also change the behaviour of your generic mouse!)

If you want to change the button mapping for all devices running in core mode, you should use xmodmap. (not recommended, try the second way first!)

Show the current configuration:

xmodmap -pp

You will get a table like this:

Physical Button

Button Code



















For example, if you now want to change the middle button and the right button, execute the following command:

xmodmap -e "pointer = 1 3 2"

Here is a list of numbers with their corresponding function:




No action (only movement)


Left button click


Middle Button click


Right Button click


Scroll up (one click equals one step of scroll wheel in my logitech mouse)


Scroll down

If you want to disable a button (maybe because you know that one of the buttons causes some problems), use zero. Example (should disable the right click):

xmodmap -e "pointer = 1 2 0"

To reset the xmodmap-configuration, use this command:

xmodmap -e "pointer = default"

The second way

If you are using more devices than just the tablet (e. g. mouse+tablet or multiple tablets a. s. o.) you can use this second way to change the mapping just for one device.

  • Step 1: Find the name of the device you want to change, e.g. with this command: xsetpointer -l alternatively you can use this command: xinput list

    Step 2: execute this command to swap the middle and the right button ("WizardPen Tablet" is the device – if you want to change the configuration of another device, you have to change the name; use the table above to define other buttons)

xinput set-button-map "WizardPen Tablet" 1 3 2 

Hint: If you experience problems with the buttons, use:

xinput set-button-map "WizardPen Tablet" 1 0 0

or, if you have a pen with 32 buttons Wink ;)

xinput set-button-map "WizardPen Tablet" 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

...to disable all buttons on your pen (for instance if you just want to draw).

Troubleshooting - See this if you have any problems

Everything worked great! Except the mouse doesn't move at all!

This is known to be an issue with WP8060 at least, and possibly other models. Fortunately, there is a common fix as well! You need to go back into /etc/X11/xorg.conf and modify the InputDevice section a little:

Section "InputDevice"
       Identifier  "Tablet"
       Option "Name" "UC-LOGIC Tablet WP8060U"
       Option "SendCoreEvents" "true"
       Driver          "wizardpen"
        Option          "TopX"          "2650"
        Option          "TopY"          "3563"
        Option          "TopZ"          "10"
        Option          "BottomX"       "30733"
        Option          "BottomY"       "29715"
        Option          "BottomZ"       "511"
        Option          "MaxX"          "30733"
        Option          "MaxY"          "29715"
        Option          "MaxZ"          "511"

The whole block is shown to indicate context. The main thing to change is the

Option "Name" "UC-LOGIC Tablet WP8060U"

part. Set the name to whatever type you have.

Reboot the XServer with Ctrl+Alt+Backspace, or reboot your computer, and you're good to go! I (Dave) found this solution from much searching on the internet, but it seems to have worked for at least a few people already.

If it helps, here is my configuration: * Ubuntu 8.04 Hardy Heron with GNOME * DigiPro 8"x6" Drawing Tablet WP8060

Link to Google Cache of the no longer working website:


After X server restart, display reverts to "Safe Mode"

From xtoast's suggestion on the discussion page (linked at the bottom of this article), I found the ServerLayout line provided in the Setting up X section above causes my xorg.conf to 'forget' basic video display settings. I used the line suggested on the discussion page instead:

InputDevice     "Tablet"     "SendCoreEvents"

Restarted the PC and everything worked! I did not follow the rest of the advice on the linked page because just modifying the ServerLayout line resolved my problem.

The command cat /var/log/Xorg.0.log | grep "wizardpen" outputs errors

The output of

cat /var/log/Xorg.0.log | grep "wizardpen"

  • may reveal several errors, some of them are:

Module present, but with compilation-errors:

(II) LoadModule: "wizardpen" 
(II) Loading /usr/lib/xorg/modules/input/wizardpen_drv.so
dlopen: /usr/lib/xorg/modules/input/wizardpen_drv.so: undefined symbol: __stack_chk_fail_local 
(EE) Failed to load /usr/lib/xorg/modules/input/wizardpen_drv.so
(II) UnloadModule: "wizardpen" 
(EE) Failed to load module "wizardpen" (loader failed, 7)
(EE) No Input driver matching `wizardpen' 

Module missing:

(II) LoadModule: "wizardpen"
 (WW) Warning, couldn't open module wizardpen
(II) UnloadModule: "wizardpen"
 (EE) Failed to load module "wizardpen" (module does not exist, 0)
(EE) No Input driver matching `wizardpen' 

The Xserver is not starting after playing with the xorg.conf file

Wow - That's bad! - First of all, check that you set everything right!

Well, I suggest that you drop me an email, telling me what went wrong!

And then just restore the backup we created - run this command:

sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

Everything seems to work, except pressure sensitivity

All the tablets mentioned in "known tablets" has pressure sensitivity support in Linux!

If pressure-sensitivity doesn't work, there are 3 possible causes!

1. The driver is not properly installed

2. The tablet is not supported by this driver

3. The application is not properly configured, to accept pressure sensitivity.

Please make sure that your favourite application supports pressure sensitivity.


Support for pressure sensitivity



Full support since 1.6

Non yet


Full support



Full support - but problems with 2.2.13


Please tell me about other applications!

Pressure sensitivity works, but is not calibrated well

The section we inserted into xorg.conf holds some options to calibrate the area of the tablet, but I haven't put in options to configure pressure sensitivity, since it varies a lot.

You can insert these options to enable MAX and MIN pressure sensitivity:

  • Option "TopZ" "10" Option "BottomZ" "511" Option "MaxZ" "511"

Where "TopZ" represents the lowest pressure-level to accept, and "BottomZ"/"MaxZ" represents the maximum pressure-level to accept.

The tablet is automatically detected as a generic mouse

In addition to the Wizardpen configuration, my system automatically configured the tablet as a generic, relative-positioned mouse. This double configuration caused the mouse pointer to move out of sync with the tablet's absolute position. Explicitly defining X11's CorePointer Device prevented auto-configuration of the tablet, leaving Wizardpen the only driver using the device (the desired behavior). For an example configuration, see the forum post: How do I -disable- tablet control of the mouse?.

I have problems not solved by the above troubleshooting

Try the forum:


Talking about hotplugging: (haven't tested it! - Please mail me in case it works, and should be implemented here!) http://deadcabbit.blogspot.com/2007/07/linux-genius-wizardpen-setup-for-udev.html


TabletSetupWizardpenHardy (last edited 2013-12-13 23:40:01 by knome)