Introduction

  • This page gives general information on the device and user notes about their experience setting it up. If you need more help, please look to the WifiDocs page for more support channels.

Device Info

  • Manufacturer: D-Link
  • Model #: DWL-122
  • Revision: A1
  • Device Type: USB
  • Chipset:
    ID 2001:3700 D-Link Corp. [hex] DWL-122 802.11b
    nic h/w: id=0x8026 1.0.0
  • Vendor/Device #: 2001:3700
  • Vendor Link: ftp://ftp.dlink.com/Wireless/dwl122/

User Notes

What Ubuntu release are you using?

  1. 6.06
  2. 7.10 (alternate install CD)
  3. 7.10 (alternate install CD)
  4. 7.10
  5. 8.04 rc
  6. 8.10
  7. 9.04

Did it configure during install?

  1. No
  2. No
  3. No
  4. No
  5. No
  6. Yes
  7. Yes

Did it work by just configuring network settings after install (out of box)?

  1. No
  2. No
  3. No
  4. No
  5. No
  6. Yes
  7. Yes

What driver did you use and ease of set up?

  1. linux-wlan-ng package (prism2_usb kernel driver module)
  2. I had to install the linux-wlan-ng package from the CD. The wireless network must be
    • unprotected, or
    • protected with WEP with a 64 bit key. In the case of WEP, the wireless access point must be configured to enable WEP wireless security.
    There is a small inconvenience. After every reboot, I have to use "Connect to Other Wireless Network". The dialog "Network Settings" does not work.
  3. Ndiswrapper. My wireless network is protected with WPA-PSK (TKIP). My steps:
    • I pulled out the device DWL-122 from the USB port of my computer.
    • edited the file /etc/modprobe.d/blacklist : added line: blacklist prism2_usb
    • (Do not know if necessary): sudo modprobe -r prism2_usb
    • I used ndisgtk. I chose the file NETPRISM.inf from

      ftp://ftp.dlink.com/Wireless/dwl122/Driver/dwl122_driver_102.zip

    • I restarted my computer.
    • only after the restart of the system I plugged-in the device DWL-122 to a USB port
    • (Do not know if necessary): In the dialog "Network Settings", I switched-on the checkbox of the Wireless Connection.
    • In the dialog "Network Settings", in the Properties of the Wireless Connection, I set "WPA Personal", the password, and DHCP.
    • Note: before each new booting of Ubuntu I have to unplug the device.
  4. I had to install the linux-wlan-ng package and run "wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable" every time I plug in the usb adapter. After running that command it works in network manager. Before running that command, iwconfig showed wlan0 as having no wireless extensions, and ip addr would report that the device wlan0 did not exist.

  5. See #3 except I didn't edit /etc/modprobe.d/blacklist, and Don't need to unplug before boot
  6. NA
  7. Worked out-of-box

If you used ndiswrapper and pulled driver from the internet, where?

  1. NO INPUT
  2. NO INPUT
  3. See above.
  4. NO INPUT
  5. See #3
  6. NA
  7. NA

Comments, tips, or other set up help...

  1. COMMENTS
  2. NO INPUT
  3. Links:
  4. See http://ubuntuforums.org/archive/index.php/t-4041.html


CategoryHardware CategoryNetworking CategoryWireless

WifiDocs/Device/DWL-122 (last edited 2011-05-16 15:29:07 by jengelh)