Needs Updating
This article needs updating to include the latest versions of Ubuntu. More info...

Acer Aspire One 110L (SSD)

Disclaimer: the original Community-Site for the Acer Aspire One is a bit cluttered right now. So I opened a new one, with the goal to maybe replace the instructions for installing Ubuntu 8.10 on the Aspire One - or at least have a single site for the Aspire One 110L. Also this file is only about the Aspire One 110L (the one with the 8GB SSD) because that's the model I own. I copied many parts of the original instructions. Thanks to all the contributors, especially khaeru!

Xubuntu 12.04 LTS, XFCE 4.8

Acer Aspire One 110L, 16Gb SSD

Tested by sid1950, September 2012

Worked out of the box except for right hand card reader and fan control. Fixes for Karmic (9.10 NetBook Remix) worked for both. Adding "lp" & "acpiphp" to /etc/modules and rebooting made the RH card slot work all the time. The LH slot already worked all the time. Adding "acerhdf" to etc/modules seems to have worked, but not as well as with 10.04 NBR. acerhdf is supposed to be in the kernel since 2.6.x.

There are a couple of start up issues which I am investigating and will post here. This netbook now dual boots Xubuntu and Android 4, but that is a story for another time and place!

10.04 LTS (Lucid Lynx)

IconsPage/ubuntu.png Currently supported: Support will end in April 2013.

Tested by primes2h here.

Works Immediately

  • Everything not listed below.

Requires Work-Around

  • Card Reader - Doesn't work if memory is inserted after boot. (Bug #453742

    • Might be fixed using neosergio's fix
      In a text editor modify /etc/default/grub on the following line:
      GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash”
      and replace it for:
      GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash pciehp.pciehp_force=1″
      after that, type this in a terminal, followed by a reboot:

sudo update-grub

Ubuntu 8.10 (Intrepid Ibex)



If you have any questions or new insights about Intrepid on the Acer Aspire One, please consider posting to the according thread in the forums first.

Notes on using this guide

This guide was written with Ubuntu in mind. Generally everything works the same with the other Ubuntu variants of (e.g., Kubuntu, Xubuntu). This guide assumes you will use gedit as your text editor. You may also substitute the text editor of your choice (e.g., kate for Kubuntu, mousepad for Xubuntu or just use vim/emacs/nano).

Version History

  • 2008-10-27: Original version by christian-paratschek

  • 2008-10-30: Added section to recreate logs in chapter "Reduce SSD Wear"
  • 2008-11-01: Clarified stuff in the Audio section, added link to forum, removed some deprecated stuff
  • 2008-12-01: added possible solution for broken wlan after end-of-november kernel update
  • 2008-12-10: I added warning about grub installing on usbstick and a solution to get wifi working with previous backports-modules

  • 2009-02-09: 2.6.28-6 jaunty kernel monnezzaio

Latest Updates to this Page

To fix not working internal microphone: Open alsamixer in terminal. Press F4 to select Capture. Select your capturing line and decrease volume of the left or the right channel to zero by pressing Z or C (see man alsamixer to view other keys). After that internal microphone is working.

fix wifi in version 11.10

To make active the Wireless Networks, you only need to follow the instructions below to rmmod and blacklist the acer_wmi module.

last upgrade 2010-05-18

Install and use the open Chromium web-browser on Lucid and say good-bye to all the Firefox SSD problems. Lucid + Chromium = smooth performance.

last upgrade 2010-02-13

The toolkit.storage.synchronous-key in about:config might help to speed up firefox. on SSD disks.

last upgrade 2010-05-18

Install and use the open Chromium web-browser on Lucid and say good-bye to all the Firefox SSD problems. Lucid + Chromium = smooth performance.

last upgrade 2010-02-13

The toolkit.storage.synchronous-key in about:config might help to speed up firefox. on SSD disks.

last upgrade 2009-11-08

In karmic with grub2, there is no /boot/grub/menu.lst file. Instead edit /etc/default/grub file and change the GRUB_CMDLINE_LINUX_DEFAULT option to read like

GRUB_CMDLINE_LINUX_DEFAULT="elevator=noop quiet splash enable_mtrr_cleanup"

and run

sudo update-grub 

last upgrade 2009-02-09

Successfully used kernel from jaunty repository resolving many issue like:

  • wifi (out of box ath5k)
  • compiz (cube with dolphins between gears are fundamental for a geek)
  • truecrypt (a test with zen kernels fails here)

NOT successfully used kernel from jaunty repository boot kernel panic.Doesn't mount root

open terminal

wget http://fr.archive.ubuntu.com/ubuntu/pool/main/l/linux/linux-image-2.6.28-6-generic_2.6.28-6.17_i386.deb
sudo dpkg -i linux-image-2.6.28-6-generic_2.6.28-6.17_i386.deb
sudo update-grub

Hardware Summary

Fully/Mostly functional

  • Audio [ works out of box, has problems with Suspend ]
  • Video (with desktop effects)[ works out of box ]
  • USB [ works out of box ]
  • Wireless Networking [ Using ath5k: works after tweaking, no leds. Using madwifi: works after tweaking, right led works ]
  • Wired Networking [ works out of box ]
  • Card Readers [ works after tweaking ]
  • Webcam [ works out of box ]
  • Silent Fan [ works after tweaking ]

Partially functional

  • Suspend/Resume [ works out of box, but DO NOT USE with SD Cards inserted. ]
  • Hibernate [ works for some people, I have no swap partition here to conserve my SSD, so I cannot use Hibernate at all ]
  • wifi kill switch [ works, but no visual notification on screen ]

Installation Guide


  • A copy of Ubuntu 8.10 Intrepid Ibex.
  • A wired network connection.
  • An external USB CD-ROM. If not:
    • A 1+ GB memory key that can be formatted.
    • Another working computer with internet access.

(NOTE: It is also possible to install directly from network, which makes USB devices unneeded. You will still need a network cable and another computer. See: Installation/Netboot or Netinstall via Windows - if you are having problems with 8.10 netboot, see Bug 322001)


(Skip this step if you have an external USB CD-ROM)

Ubuntu 8.10 includes a neat little application called "Create a USB startup disk". It can be found under "System" - "Administration". Just insert the Ubuntu CD and the USB Stick and run the program.

If you don't have a working installation 8.10, you can use unetbootin:

On this website: Create a bootable USB Drive or Memory Card, the tool used was UNetbootin which seems to only require the one computer to run it on (as a statically linked binary, no install required, minimal dependencies) and generically works for a large number of distributions in addition to Ubuntu and handles custom diskimages and custom kernels.

To install:

  • Connect an 1+ GB stick to your computer and insert the Ubuntu 8.10 cd (or have the .iso on the hard drive)
  • Download the current file unetbootin-linux-xxx (as of this writing, xxx=293) from http://sourceforge.net/project/showfiles.php?group_id=222386&package_id=268713

  • sudo aptitude install syslinux mtools
  • chmod 755 unetbootin
  • sudo ./unetbootin &

  • select diskimage or distribution (point to your .iso or to the CD-drive)
  • select USB drive from list (uses only device names unfortunately)
  • click ok

Flash drive or memory card will be formatted and set up as a bootable drive.


Shut down your Aspire One and insert the external USB CD-ROM or the USB stick that we just used. Turn it on and tap F12 to bring up the boot menu. Connect your Aspire One to the internet using a wired connection.

With a CD-ROM, choose the USB CD-ROM option. With the bootable USB stick created, choose the USB HDD option. This will boot you to the USB CD-ROM/LiveUSB stick, and allow you to install Ubuntu. Install it like normal if you have the hard disk Aspire One. For good performance and to increase the life of the SSD of your Aspire One 100L use a non-journaled filesystem like ext2.

Note: On my 150L with a HD, grub is by default installed on the first HD but unfortunately the usbstick is considered the first HD so grub is installed on the stick :-(. The solution is to answer "No" to the grub install question and give as install location /dev/sdb.

My setup:

  • The SSD, /dev/sda1 is 8GB ext2, used for /
  • I use no swap partition
  • I use the left card reader for permanent file storage (mounted as /media/Data)

    Note: If you have already installed with ext3 then follow this post: http://www.aspireoneuser.com/forum/viewtopic.php?f=5&t=164&st=0&sk=t&sd=a&start=10#p1177 to convert to ext2. Installation (file copy) will take a LONG time (hour +). If you are not currently connected to the internet on a wired connection, you may get an error about setting up a mirror. You can safely ignore that error - it's non-fatal.

Tweak/Fix Installation

So now we should have an installed Ubuntu system. The very first thing we do is install all the necessary updates. Open a terminal (Applications -> Accessories -> Terminal). Perform the updates:

sudo aptitude update
sudo aptitude safe-upgrade


ath5k Method

Wireless does not work out of the box but can be brought to life easily. The most simple way is to install ath5k, the new open source driver for Atheros chipsets. It got removed from the stock Intrepid kernel because it was not stable on some systems. I do not have any problems so my recommendation for the Aspire One is to use this driver. To activate ath5k, deactivate the proprietary driver "Atheros wireless card" (System -> Administration -> Hardware Drivers) that Ubuntu tries to use and install the package "linux-backports-modules-intrepid"

sudo aptitude install linux-backports-modules-intrepid

Wireless will work after a reboot.

Make sure acer_wmi is not being loaded in your modules. It's a known issue for the module developers that is broken with the AAO http://www.mjmwired.net/kernel/Documentation/laptops/acer-wmi.txt.

lsmod | grep acer_wmi

if it's listed then do

rmmod acer_wmi

and add it to the blacklisted items if necessary in /etc/modprobe.d/blacklist-wifi.conf.

blacklist acer_wmi
# blacklist ath5k

This will fix problems with Network Manager greying out the enable wireless option and the wireless LED will work perfectly.

[Paul Carmichael]Didn't work for me, so tried re-enabling old driver. That didn't work either, so tried something really silly ie; enabled both. This worked a treat.

NOTE: To avoid broken wlan after kernel-updates, get updates for the backports-modules:

sudo synaptic

  • Settings -> Repositories -> Updates

  • Check "Unsupported updates (intrepid-backports)"

NOTE: You might need a bios upgrade if everything else fails. Upgraded to Bios v0.3309 and ath5k worked like a charm. NOTE: BIOS upgrade was absolutely necessary for me, as well. After installing ath5k via linux-backports-modules-jaunty, no progress had been made, then after updating to BIOS v0.3310, it worked perfectly.

madwifi method

If you are not very confident with wireless then ath5k is probably for you however I found it to drop out or fail too regularly and installed madwifi instead. Note: you will have to do this each time your kernel is upgraded.

This part is sourced from the main Acer Aspire One howto but I have tested it on Ibex.

Now we need to disable the hardware drivers that Ubuntu tries to use before the ones we make will function. So go to System -> Administration -> Hardware Drivers and uncheck everything. It should prompt us to reboot, so lets do it now.

We need to grab the wireless driver, and the things we need to build it, from a terminal:

wget http://snapshots.madwifi-project.org/madwifi-hal-
sudo apt-get install build-essential linux-headers-$(uname -r)
tar -xzf madwifi-hal-
cd madwifi-hal-*/

And we build and install:

sudo make install
sudo modprobe ath_pci

In order to have the wireless work after reboot, add the following line to /etc/modules ("sudo gedit /etc/modules") to automatically load the module when booting:


You should now have working wireless. However you may want to do the following to prevent problems (the symbol mismatch) when the module is loaded:

Add ath_hal to the DISABLED_MODULES= stanza in /etc/default/linux-restricted-modules-common

(i.e. 'DISABLED_MODULES="ath_hal"')

Every time there is a kernel update you will need to perform the following steps to make the wireless work. Go to the directory (madwifi-hal- and run:

make clean
sudo make install

Suspend/Resume with madwifi

If you want to suspend and resume and have your wifi working you will need the following script:

# Adapted from AbtZ on http://ubuntuforums.com/showthread.php?p=5564900
# Enable wireless after a suspend/hibernate
# For my Acer Aspire One running Ubuntu Intrepid and Madwifi (madwifi-hal-
# This needs to be executable (chmod +x) and placed in the /etc/pm/sleep.d/ folder
case $1 in
    # We go into hibernate
    # We go into suspend
    # We come out of hibernate
        /sbin/ip link set wifi0 up
    # We come out of standby
        /sbin/ip link set wifi0 up
    # catch all

Save this file as /etc/pm/sleep.d/10-wifi and run sudo chmod +x /etc/pm/sleep.d/10-wifi

WLan LEDs/Switch

If you used the ath5k method

WLAN can be turned off with the switch on the front side of the Aspire One, although you don't get a visual notification in the GUI. The Wireless LEDs however DO NOT WORK with the kernel 2.6.27 that is used in Ubuntu 8.10.

In UNR with jaunty 9.04 and ath5k and making sure the acer_wmi module is not loaded the Wlan LED will work perfectly.

If you used the madwifi method

WLAN can be turned off with the switch on the front side of the Aspire One, although you don't get a visual notification in the GUI. The Wireless LEDs DO work, with the addition of these lines to /etc/rc.local

# Make wifi lights blink
sysctl -w dev.wifi0.ledpin=3
sysctl -w dev.wifi0.softled=1

Make sure those lines appear before exit 0.

Card Readers

Note: there are problems with the card readers: DO NOT SUSPEND your Aspire One with an SD Card inserted. I lost all my data on it!

There is some debate as to the cause of this problem but if your SD card is formatted with the XFS filesystem then suspend and resume work fine.

Note: There is a page on mounting SD cards after suspend, with some suggestions on tweaking the fstab file, here: AspireOneSDCardsAndSuspend.

If you want the card readers to be hot-pluggable, you'll need to work through the following modified instructions from http://wiki.debian.org/DebianAcerOne.

Create a file /etc/modprobe.d/aspireone.conf with the following content:

# Module options for the Acer AspireOne
# Enable USB card reader
options pciehp pciehp_force=1
install sdhci for i in 2381 2382 2383 2384; do /usr/bin/setpci -d 197b:$i AE=47; done; /sbin/modprobe --ignore-install sdhci

Add the following line to the end of you existing /etc/modules file:


You need to reboot to the get the files /etc/modules and /etc/modprobe.d/aspireone.conf read properly. Inserting a SD card should then result in HAL finding the card and placing icon on the desktop automagically.

Note there are still a few problems with this setup:

  • If you first insert a card in the left card reader, both card readers will be hot pluggable. However, if you first insert a card in the right card reader, the left card reader will not be available until reboot.
  • MemorySticks wouldn't work for me in the right multi-card reader. I think this is a kernel module limitation.

A script to poll the card reader for power events (AC unplugged, etc.) is included on the recovery DVD shipped with the machine within the "hdc1._.tar.bz2" archive as /usr/sbin/jmb38x_d3e.sh. This script runs once every 5 minutes and adjusts the power level depending on the system power state.

The script is also available from the petaramesh site. Download it, make it executable and copy it to /usr/local/sbin with:

wget http://petaramesh.org/public/arc/projects/AcerOne_Ubuntu/jmb38x_d3e.sh
sudo chmod 754 jmb38x_d3e.sh
sudo mv jmb38x_d3e.sh /usr/local/sbin/

To use the script add a line like:

/usr/local/sbin/jmb38x_d3e.sh &>/var/log/jmb38x_d3e.log &

to rc.local before exit 0. Next time you reboot this script will be running (or you can execute it in a terminal now as root).

The script generates lots of harmless warning messages, so we send the output messages to a log file.

My setup: I use the left card reader with a 16GB SD Card as permanent storage expansion. The right card reader remains empty and is used for the occasional SD Card that needs to be read.

The card readers are identified as /dev/mmcblk0 and /dev/mmcblk1. Partitions on them are labeled, for example /dev/mmcblk0p1. I have experienced problems with using both card readers at the same time because the kernel tends to mix up the devices and then I don't find my regular files. This can be avoided by using a UUID in /etc/fstab. If you plan to use the left card reader the way I do, do the following:

sudo blkid /dev/mmcblk0p1

Use the UUID in /etc/fstab, like

UUID=f6d7b922-bde5-35a2-b58c-51414052eb35 /media/Data ext2 noatime 0 0

This way, Ubuntu will not mix up the devices if you have two cards inserted.

Fan Control

In a default install, the fans of the Aspire One are not managed at all and just keep running, resulting in a very noisy AA0. Solution:

  • Ensure you have dmidecode installed, so acerfand can detect which bios version you have. It's probably installed by default already. If not, execute:

 sudo aptitude install dmidecode
  • Download the acer_ec.pl script (Direct download).

  • Download the acerfand daemon script (Direct download). (New version (2008-10-19) adding support to BIOS 3305)

  • Execute these lines in a terminal in the directory you downloaded the above scripts:

 chmod a+x acerfand
 sudo cp acer_ec.pl acerfand /usr/local/bin/
  • To run it straight away:

 sudo acerfand
  • Note, you need the correct bios for this to work correctly. To see if the acerfand script is working, you can check the system log after you have run the *sudo acerfand* command:

#sudo tail -f /var/log/syslog
Oct  9 02:04:36 lilput acerfand: acerfand 0.03 starting
Oct  9 02:04:36 lilput acerfand: Detected bios version v0.3301
Oct  9 02:04:36 lilput acerfand: Unsupported bios version v0.3301 found. Aborting.

case "$BIOS_VERSION" in
      #change: handle 3309 seperate 0xAF -> 0x21

If you upgrade to BIOS version 3310, the current version of acerfand (v 0.7 at time of writing) throws an unsupported BIOS error. Since the fan control is not changed by this BIOS update, change the acerfand script like so:

#add 3310 BIOS support


case "$BIOS_VERSION" in
        "${BIOS_VERSION_3309}" | "${BIOS_VERSION_3310}")
                #change: handle 3309 seperate 0xAF -> 0x20
  • To run it at boot:

 sudo gedit /etc/rc.local

Insert the following line above the exit 0 at the bottom:


Note: This is not working on 9.04 UNR, it seems like the script is not been executed from /etc/rc.local. A workaround can be found here.

The fan is not completely disabled. When the FANAUTO temperature is reached (70ºC), fan works again. According to Intel, the Atom chip could work until 99ºC.

Optional: Above instructions will work fine, but if you want to define another temperature:

  • Create an /etc/acerfand.conf file. The file is just a shell script that sets up to three values. eg:


Those are the default values, if the /etc/acerfand.conf file isn't found.

INTERVAL is the polling interval in seconds FANOFF is the temperature (in Celsius Degrees) at or below which to turn the fan off, if it's currently on auto FANAUTO is the temperature (in Celsius Degrees) at or above which to turn the fan to auto, if it's currently off

SSD Performance

The performance of the SSD drive can be significantly improved by a few tweaks described in an article by Jason Perlow (But ignore Tweak #1, which does not apply.). The most important of these are described here.

Change the file system mount options on SSDs to "noatime"

Edit /etc/fstab (sudo gedit /etc/fstab) and change the the option "relatime" to "noatime". The line for the root partition should then be something like:

UUID=f0ae2c59-83d2-42e7-81c4-2e870b6b255d / ext2 noatime,errors=remount-ro 0 1

Use the "noop" I/O scheduler

Edit /boot/grub/menu.lst using your favorite editor, and add "elevator=noop" as an option. The default kernel configuration, found in the last part of the file should be something like:

title           Ubuntu 8.10, kernel 2.6.27-7-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.27-7-generic root=UUID=f0ae2c59-83d2-42e7-81c4-2e870b6b255d ro quiet splash elevator=noop
initrd          /boot/initrd.img-2.6.27-7-generic

In order for the changes to remain when updating the kernel, also in menu.lst, find the line

# defoptions=quiet splash

and add "elevator=noop" as an option:

# defoptions=elevator=noop quiet splash

Reduce SSD Wear

Frequent writes to the SSD will cause failure eventually. We can reduce the number of writes to the SSD by moving our logs to a temporary filesystem in RAM that gets destroyed on every reboot. Now this means your logs will not be persistent across reboots making debugging difficult in some cases. This step is optional of course, so if you need the logs for an extended period of time do not follow these steps.

Open your fstab again, and add the following lines:

sudo gedit /etc/fstab
tmpfs      /var/log/apt    tmpfs        defaults           0    0
tmpfs      /var/log        tmpfs        defaults           0    0
tmpfs      /tmp            tmpfs        defaults           0    0
tmpfs      /var/tmp        tmpfs        defaults           0    0

Warning: this will cause some packages to fail mysteriously when they cannot access the log directories that were installed with the packages and then disappeared at reboot.

Optional: to rebuild the directory structure inside /var/log on each reboot, add these lines to /etc/rc.local above the 'exit 0' line:

for dir in apparmor apt cups dist-upgrade fsck gdm installer samba unattended-upgrades ; do 
        if [ ! -e /var/log/$dir ] ; then 
                mkdir /var/log/$dir 


Audio works decently out of the box but has some issues, especially with Suspend. Out-of-the-box, Suspend/Resume will break audio playback. Multiple ways to deal with the issue are discussed, none worked well enough for me. You'll have to edit /etc/modprobe.d/alsa-base and add the following line:

# Reenable Sound after a Suspend
options snd-hda-intel model=xxx

xxx can be the following:

  • model=acer: Sound works after a Suspend, but the internal speakers will not be turned off when you plug in headphones, the internal mic is not working

  • model=auto: No sound after resume, don't know about the mic

  • model=basic: No sound after resume, don't know about the mic

  • model=toshiba: Sound will work OK, plugging in headphones will turn off the speakers, only the internal mic will be dead.

My recommendation at this point is to not use Suspend/Resume on your Acer Aspire One at all. If you can do without the internal mic (an external microphone is supposed to work, though I can't test it), use the model=toshiba option. At least sound playback with headphones and speakers will be OK then.


The default configuration will give you fonts that are too large.

sudo gedit /etc/X11/xorg.conf

Add this line to the "Monitor" section:

DisplaySize 195 113

Add this line to the "Device" section:

Option "NoDDC"

This sets the resolution to the correct 96 DPI, and thus the correct size fonts. (Note: This appears to affect multiple monitor setups, at least for certain external monitor resolutions. If you have trouble setting an external monitor to the correct resolution try commenting out these two lines and restarting your X server.)


Out of the box, the Graphics Adapter, Intel GMA 950, is well detected. No configuration is needed to get anything including a reasonable speed.

If you need more than you get out-of-the-box add enable_mtrr_cleanup to the boot parameters grub passes to the kernel as is stated above. Doing this allows the kernal to free a MTRR register the X server can use to tell the CPU which is the fastest way to talk to the RAM portion that it shares with the graphics chip.

Legacy information follows:

Previously there were tips on /etc/X11/xorg.conf configuration to achieve better performance, but the tips are outdated and presented here only for reference:

Section "Device"
        Option "MonitorLayout" "LVDS,VGA" # Use Preferences -> Screen Resolution instead when necessary. If you use this, you might be using extra power by having the VGA output unnecessarily enabled.
        Option "Clone" "true"
        Option "AccelMethod" "EXA" # EXA is already default, no need to specify it again.
        Option "MigrationHeuristic" "greedy" # This is not needed anymore. It is only a workaround that disables some acceleration paths which caused problems before.
        VideoRam       229376 # This is a legacy option that has no functionality anymore.
        Option "CacheLines" "1980" # This is a legacy option that has no functionality anymore.

The Option Clone was especially useful if you want to capture video or photos. Without it you would get a black screen on applications like cheese.

According to http://wiki.archlinux.org/index.php/Intel_GMA_950, add this to your /etc/profile (Note: Not currently working in 8.10 https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/284082):

export INTEL_BATCH=1

Bootup Speed

To decrease boot time, activate concurrency bootup. Edit /etc/init.d/rc by typing:

sudo gedit /etc/init.d/rc

and replace the line:




Speed up Firefox

Reduce disk cache (from ArchWiki):

  • Make Firefox store its cache in the /tmp directory --- which when we have moved to a tmpfs before! Firefox 3.x uses a sqlite db that creates many write accesses, we reduce it: in Firefox go to (type as url) "about:config", right click, add new string "browser.cache.disk.parent_directory" with value "/tmp/firefox"
  • You can disable warnings about phishing too: in Firefox choose Edit->Preferences, click "security" and disable 'attack sites' and 'forgery sites' if you dare. While Firefox runs faster, you'll no longer be warned about such sites.

Another Note:

  • Alternatively, set "browser.cache.disk.enable" to "false". This will disable all disk caching, but will still cache to RAM. You may also wish to decrease the cache size (browser.cache.disk.capacity) to a lower value to reduce memory usage over time.

Firefox halts during browsing

Firefox tends to stall, halt or freeze for a few seconds while browsing. This is a result of Firefox writing indices that can grow to an impractical size - and making sure they are completely written to the disk before it continues working.

Telling firefox not to wait until all data is written increases performance here:

  • type about:config into the location bar
  • If there is a key named toolkit.storage.synchronous set the value of this key to 0
  • If it doesn't exist press the right mouse key, tell firefox you want a new integer - name it toolkit.storage.synchronous and set its value to 0.

Limiting the size will also result in increased performance:

  • In "about:config" reduce "browser.history_expire_days" to say 7
  • To reset any oversized caches and start from scratch locate the directory "~/.mozilla/firefox/?.default/" and delete large files with extension ".sqlite".



Changing the default options to use elevator=noop:


## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=elevator=noop quiet splash



This is my sample fstab-file.

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=29eee8e2-da49-41db-b2aa-de4f45c6ef12 /               ext2    noatime,errors=remount-ro 0       1
# /dev/sda2
UUID=b2eceed3-6994-49df-90a5-6bbce548efad none            swap    sw              0       0
# Left Card Reader for permanent storage
UUID=4eee89ab-dd43-4ddb-a384-79b4e3874812       /media/Data     ext2    noatime 0       0
# tmpfs für log files
tmpfs   /var/log/apt    tmpfs   defaults        0       0
tmpfs   /var/log        tmpfs   defaults        0       0
tmpfs   /tmp            tmpfs   defaults        0       0
tmpfs   /var/tmp        tmpfs   defaults        0       0


Replace CONCURRENCY=none with CONCURRENCY=shell, on line 32 for me



Sound after resume. model=toshiba, works best though also not perfect.

# Reenable Sound after a Resume
options snd-hda-intel model=toshiba


Rather than modify the other files in this directory, create a new file just for Aspire One settings. It will be processed along with the rest on boot. This setting is for the Card Readers.

# Module options for the Acer AspireOne
# Enable USB card reader
options pciehp pciehp_force=1
install sdhci for i in 2381 2382 2383 2384; do /usr/bin/setpci -d 197b:$i AE=47; done; /sbin/modprobe --ignore-install sdhci


Add this to the end of the existing file:



The file /etc/sysctl.d/README states, "End-users can use 60-*.conf and above," so we create a file /etc/sysctl.d/60-aspireone.conf instead of editing sysctl.conf directly or calling "sysctl -w" from rc.local:

# Settings for the Acer Aspire One
# Discourage Swapping
vm.swappiness = 10
# As suggested by PowerTOP
vm.dirty_writeback_centisecs = 1500
# Suggested by https://help.ubuntu.com/community/AspireOne
vm.vfs_cache_pressure = 0
vm.dirty_ratio = 20
vm.dirty_background_ratio = 10
vm.laptop_mode = 5

Note: Set swappiness to zero if you have no swap partition. Use this only with enough RAM (1GB or better 1.5GB). My setup: 1GB RAm and 1GB Swap, so I use vm.swapiness = 10.


Here we include only settings that cannot be placed in the above files.

# rc.local
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
# In order to enable or disable this script just change the execution
# bits.
# By default this script does nothing.
# https://help.ubuntu.com/community/AspireOne
# Wireless disable/enable key
/usr/bin/setkeycodes e055 159
/usr/bin/setkeycodes e056 158
# Decrease power usage of USB while idle
[ -w /sys/bus/usb/devices/1-5/power/level ] && echo auto > /sys/bus/usb/devices/1-5/power/level
[ -w /sys/bus/usb/devices/5-5/power/level ] && echo auto > /sys/bus/usb/devices/5-5/power/level
# Disable Wake-On-LAN feature of Ethernet port
ethtool -s eth0 wol d
# As in the rc.last.ctrl of Linpus
echo 1 > /sys/devices/system/cpu/sched_smt_power_savings
# Recreate Log directories (use only if you put the Logs in tmpfs in /etc/fstab
for dir in apparmor apt cups dist-upgrade fsck gdm installer samba unattended-upgrades ; do 
        if [ ! -e /var/log/$dir ] ; then 
                mkdir /var/log/$dir 
# Fan control
exit 0

Note: You'll have to install ethtool to use this script:

sudo aptitude install ethtool


Add in Section "Device" the following:

Section "Device"
        Option "MonitorLayout" "LVDS,VGA"
        Option "Clone" "true"
        Option "AccelMethod" "EXA"
        Option "MigrationHeuristic" "greedy"
        VideoRam       229376
        Option "CacheLines" "1980"


Add after the last line (umask 022) (Note: Not currently working in 8.10 https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/284082):

umask 022
# https://help.ubuntu.com/community/AspireOne
export INTEL_BATCH=1


Add this line to the "Monitor" section:

DisplaySize 195 113

Add this line to the "Device" section:

Option "NoDDC"

AspireOne/110L (last edited 2013-12-14 10:54:46 by knome)