Tag/tag.png

Unsupported Version
This article applies to an unsupported version of Ubuntu. More info...

Tag/tag.png

Candidate for Deletion
This article may not be appropriate for this wiki, and may be deleted. More info...

This page only contains advice for obsolete releases of Ubuntu. Best is to delete it and write a new one from scratch.

Ethernet

Some EeePC 900 and 1000 users have found that the Ethernet connection does not function after a fresh Ubuntu installation (this does not seem to affect every user) (Bug #219662).

Installing Ubuntu via PXE

For the 1005H* model and possibly others: when attempting to install Ubuntu via PXE (Netboot) you will find that only atl1.ko and atl1e.ko are included in the initrd.lz of Ubuntu 9.10, which will stop you when trying to mount through NFS. A quick workaround to this is unpacking the squashfs and initrd in casper/ and put the atl1c.ko that is included in the squashfs of casper, into initrd (a howto on creating the initrd is out of the scope of this document, I'd say). I also had to throw atl1c into conf/modules.

IP Address

If you are unable to obtain an IP address with your EeePC after a fresh installation, you may need to do the following...

  1. Shutdown the EeePC
  2. Unplug the AC power
  3. Remove the battery
  4. Reconnect the battery
  5. Reconnect the AC power
  6. Turn on the EeePC

Wireless

The command

sudo lshw -C network

should show which hardware the machine has for networking (including for internet access). Alternatively you might check your hardware with the lspci command.

If wireless is NOT working out-of-the-box, then I suggest following this procedure to get help from the community:

https://help.ubuntu.com/community/WirelessTroubleshootingProcedure

Atheros Card

Most models of the EeePC use an Atheros card which is not supported by default (Bug #182489). It is supported in Intrepid using the free ath5k driver in the linux-backports-modules-intrepid-generic package.

If after completing the relevant steps below you still do not have wifi, check that it has not been disabled in your BIOS. Reboot and tap F2 to get to your BIOS to check. It's probably worth checking before you start, too.

These threads might be useful for UNR 10.04

Eee PC 1001P and 1005PX with UNR 10.04 confirmed with the backport wireless module

sudo apt-get update
sudo apt-get install linux-backports-modules-wireless-lucid-generic
sudo reboot

Realtek Card

The 701SD uses a Realtek rtl8187se instead of the usual Atheros. Hopefully this thread fom Launchpad Answers might help

Note that in the, now obsolete, Ubuntu 8.10 the Realtek support was broken (Bug #246141)

Some (later) 901 and 1000 models use a Ralink rt2860sta (this for example is the onboard wifi card used on EeePC 1000H), which also isn't supported in the now obsolete Intrepid (8.10). Download and install the "rt2860 - 1.8.0.0-0ubuntu1~ppa2" package you find here. The Intrepid installation file (.deb) is found here and a detailed how-to here. If this doesn't work try a fresh install of Ubuntu (this means reinstalling it from LiveCd or a bootable USB stick) and then install the plug-in from the link given before. (Bug #210725)

Note 10.10 includes the 1.8.0.0 driver, however this doesn't support wireless-n, which the updated drivers do. See the discussion page.

Ath5k Driver

The ath5k driver was removed from Ibex's 2.6.27 kernel, and moved to the backport modules. To get wireless to work (at least for the 701), you need to install an additional package. You will need wired internet access for the following steps.

sudo apt-get update
sudo apt-get install linux-backports-modules-intrepid-generic
sudo modprobe ath5k

EeePC 900s and 701s require "blacklist ath_pci" added to "/etc/modprobe.d/blacklist" to enable wireless.

sudo -s
echo blacklist ath_pci >> /etc/modprobe.d/blacklist

After this you can reboot and your wireless should work.

Note: On my EeePc 900 and Intrepid, the signal was bad and I experienced intermittent failures when using this method. Ndiswrapper seems to work ok so far - VilleV

If you've used ndiswrapper previously but move to the ath5k driver, you'll probably need to (re)move /etc/modprobe.d/ndiswrapper out of the way

Note: On a mostly-Ubuntu EeePC with an Atheros AR928X card (as reported by lspci), I found wifi working-but-flakey after an upgrade to Ubuntu 9.10. Running lsmod showed that two wifi driver modules were loaded (ath5k and ath9k). Doing rmmod ath5k restored normal operation, and adding the ath5k module to the blacklist as described above will make the removal stick across reboots.

Madwifi Driver

Recommended for Ubuntu 8.04.

You will need wired internet access for the following steps. Depending on your BIOS version, you may need to have the wired network connected on boot to be recognized properly.

First remove startup for linux-restricted-modules-common because it causes conflicts with the madwifi drivers.

sudo update-rc.d -f linux-restricted-modules-common remove

Update your apt package list

sudo apt-get update

Install the madwifi driver.

sudo apt-get install build-essential checkinstall
wget http://snapshots.madwifi.org/special/madwifi-hal-0.10.5.6-r3698-20080604.tar.gz
tar zxvf madwifi-hal-0.10.5.6-r3698-20080604.tar.gz
cd madwifi-hal-0.10.5.6-r3698-20080604
make clean
make
sudo checkinstall #results in a proper debianized package
sudo reboot

Once the machine is rebooted you should have full wireless support through the network manager.

This version of madwifi only gives intermittent WiFi for me - I get frequent brown-outs (no data though connection stays up) and connection failures. The old madwifi (madwifi-ng-r3366+ar5007) linked from here: http://wiki.eeeuser.com/getting_ubuntu_8.04_to_work_perfectly works better for me but doesn't appear to be hosted on snapshots.madwifi.org anymore! I don't have the ability to host the file myself, is anyone already doing it? --Tsuki

I've uploaded madwifi-ng-r3366+ar5007 from a backup. Temporary download location: http://www.megaupload.com/?d=YZZ04LZY -komputes

I've uploaded madwifi-ng-r3366+ar5007 (gotten from the link provided by komputes) to a (hopefully) more permanent location: http://file-hosting.site-hosts.net/eeepc/madwifi-nr-r3366+ar5007.tar.gz . A script to do this setup automatically: http://file-hosting.site-hosts.net/eeepc/ubuntueeetweak_eee900_wireless.sh - christian-chess-geek

Ndiswrapper Driver

If the madwifi drivers do not work, or you prefer to use the ndiswrapper method tpo use the Windows driver in Linux anyway then try ...

First you'll need to remove and blacklist any existing madwifi drivers:

sudo modprobe -r ath_pci

Then edit the /etc/modprobe.d/blacklist file and add the following line to the bottom:

blacklist ath_pci

You'll need to then install the ndiswrapper utilities:

sudo apt-get install ndiswrapper-common ndiswrapper-utils-1.9

The Windows Drivers that we'll use for this method are either available on the EeePC Dvd that should have accompanied your machine, or are available from the Asus website.

Historical edits from people

  • I've got it up and running with 8.10 intrepid on EeePC900. I've also update my system today and now i have kernel 2.6.27-7 and it's still fine. Before Ndiswrapper i have tried with all your madwifi version, with stable version on the project main site and with the trunk version from SVN but nothing was working for me. I'm not very happy but i must say that the XP driver is working great. (SiouxeS)

Same here, works great. As a matter of fact the ndiswrapper solution is the only one that seems to work in a stable and consistent manner on my 701 4g. The other solutions above produced at best a connection that was intermittent. It used to drop and re-connect about once every 3-5 minutes. Not practical if you listen to streamed content.... Ndiswrapper has worked without any hickups at least a week now. (ben4launchpad)

Navigate to the folder containing the net5211.inf and run these commands:

sudo ndiswrapper -i net5211.inf

You should then be able to load the ndiswrapper module:

sudo ndiswrapper -m

Finally, set the ndiswrapper module to load at each boot:

sudo ndiswrapper -ma && sudo ndiswrapper -mi

You may need to reboot for everything to take effect, but you should have a working wireless connection at this point.

Microphone

The microphone does not work by default (Bug #232173).

For the 700/701

  • Edit /etc/modprobe.d/alsa-base and add the line “options snd-hda-intel model=3stack-dig”
  • Run the following command:

sudo alsactl store

I'm getting the following error in kubuntu 8.04.1 "alsactl: get_control:209: Cannot read control info '2,0,0,Master Playback Volume,0': No such file or directory" -komputes

For the 900

There are no confirmed workarounds at this time. In the interim, you can try:

  • Edit /etc/modules and add the line “snd-hda-intel model=auto”

The following sourced from: http://forum.ubuntu-it.org/index.php?topic=182515.msg1211841

sudo apt-get install module-assistant
sudo m-a update
sudo m-a prepare
sudo m-a a-i alsa
sudo reboot
  • Edit /var/lib/alsa/asound.state : find “Capture Switch” and change the two “false” statements to “true”.
  • Run:

sudo alsactl restore

Once the driver is working correctly, the ALSA mixer must be configured properly to use the microphone. From the Ubuntu desktop:
Right click on speaker icon
"Open volume control"
"Edit - Preferences"
Check/enable "input source" (and "Front mic" if it's not enabled) and close that window
Go to tab "options"
Choose "Front mic"
Go to tab "Playback" and verify that the faders for "Front mic" is set correctly and not muted.

1000HE

This model should be working out of the box since Lucid Lynx according to https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/232173.

1001PX

This model still has problems with the internal microphone and there doesn't seem to be any fix available at the moment. This model also features a combined input/output audio jack which also isn't working properly.

There are currently two bug reports up on launchpad:

1) https://bugs.launchpad.net/ubuntu/+source/linux/+bug/580183
2) https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/689258

1005PX

10.04 installed, the internal microphone doesn't work. Following from

sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
apt-get install linux-alsa-driver-modules-$(uname -r)

Then run alsamixer and set mic boost 0,0% capture 90% and remaining controls to 100% This would probably work also for 1001PX

Hotkeys

The wireless (fn+f2) and volume (fn+f7/f8/f9) hotkeys do not work out-of-the-box, although the brightness (fn+f3/f4) and sleep (fn+f1) hotkeys do work (Bug #232170).

It might be worth trying although these answers need to be confirmed

Shutdown

Sometimes the EeePC does not turn off when set to shutdown. This is due to a module not being removed and the sound subsystem remaining active (Bug #126140).

  1. Make sure the module is properly removed when the system goes down by adding it to the halt shutdown script.

  2. Add modprobe -r snd-hda-intel to your /etc/init.d/halt file should workaround this issue. Place it just within the stop function as seen in the example below:

do_stop () {
modprobe -r snd-hda-intel
if [ "$INITHALT" = "" ]
....

Screen Resolution

Note: This has been fixed for later releases but may still be an issue for Ubuntu 8.04 LTS (Hardy Heron) - when reconfiguring xserver-xorg it does not ask questions regarding video drivers.

By default you may be running a 640x480 vs the 800x480 (for the 700 series) that it should run at. To set the higher resolution by reconfiguring xserver-xorg with the following command: Note: If you plan on using an external screen, you may want to have it connected on the previous reboot before issuing the next command, and selecting resolutions appropriate for your external monitor.

sudo dpkg-reconfigure xserver-xorg

Select all the default values, making sure to select intel as the video driver and then 800x600 as the resolution. Setting this resolution, even though it doesn't exactly match, will fall back to the 800x480.

Webcam

Note: May not be applicable to current supported releases of Ubuntu but may affect 7.10.

The built in webcam should work out of the box in Ekiga and Skype 2 Beta for Linux.

You can install the Skype client available here http://www.skype.com/intl/en/download/skype/linux/beta/choose/, select the Ubuntu 7.04 version and install.

Troubleshooting

If the BIOS setting "OS Installation" is set to [Begin], then the webcam may not function (this tested under Hardy 8.04 LTS). Change this setting to "Finished" and the webcam will function. Also ensure that the webcam itself is enabled in the BIOS.

Note: The following has been fixed in the latest release of the Skype beta.

If you have trouble getting video to work in both directions (you can see yourself, but not the other person) the problem is likely the intel driver intel_drv.so. The version of this driver available in Ubuntu 7.10 "Gutsy" only supports one Xv port which is likely the cause of this problem.

One work around is to have the remote person turn off their video. Then turn off your video. Then the remote person turns their video back on, then you turn your video back on. You will not be able to see your self in the sub-window however.

A better solution is to copy the intel_drv.so driver from the original Xandros installation and put it in /usr/lib/xorg/modules/drivers, after first backing up the original version. (If you copy this while in X, your screen will likely freeze. Pause for a few seconds, then hit the power button once and the machine will shutdown gracefully. The new driver should be in use when it comes back up.)

A copy of the original Xandros driver intel_drv.so is temporarily available here: http://zelut.org/projects/misc/intel_drv.so

Flash Support

From Linux Adobe Flash Player 10 onwards (current) Flash player supports V4L2 (V4L2 is used to provide access the EeePC's webcam). For the old Linux Flash Player 9 there is a workaround (albeit an ugly one) in the form of the Flashcam Project.

Power Management

The eee-applet is a small applet to control the fans, the power consumption and the status of different devices such as the camera, the SD slot or the wireless

On the latest kernel for Ubuntu 10.04 (2.6.32-9 and up) the kernel no longer passes the ACPI information to the Asus Bios, so the Bios changes the ACPI information preventing the module from loading

A quick fix is to add "acpi_osi=Linux acpi_backlight=vendor" to your grub configuration. From a command-line

gksudo gedit /etc/default/grub

Change the line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Save & close.

Back to a linux command-line

sudo update-grub

References


CategoryAudio

EeePC/Fixes (last edited 2011-06-11 20:59:39 by skovprodukter)