Introduction

Mythbuntu / Ubuntu + MythTV Frequently Asked Questioins

0.21 Upgrade Questions

Question: I upgraded to 0.21 and MythVideo is broken or Question: I upgraded to 0.21 and can't upgrade MythVideo

Answer: MythDVD is now deprecated, because MythVideo has taken over its functionality. Therefore, upgrading MythVideo requires MythDVD's removal. However, many package management interfaces will not automatically do this. You can fix this by issuing the following command from the Terminal:

sudo apt-get install mythvideo


Question: I upgraded to 0.21 and can't upgrade MythStream

Answer: This is because MythStream has not been backported yet. Keep an eye on this bug: https://bugs.launchpad.net/gutsy-backports/+bug/202988 UPDATE: an updated version of MythStream should now be available


Question: xbmcMythTV doesn't work with 0.21

Answer: Correct, you will need to wait for the Author to release a new version. Until then I recommend using the new UPnP functionality which will at least allow you to access your media. UPDATE: xbmc now has partial support for MythTV, so you may not need the MythTV xbmc python plugin any longer. The March 23rd build is known to be working. See here for more information: http://www.mythtv.org/wiki/index.php/Xbox_Frontend#Running_XBMC_with_native_MythTV_Support


Question': I upgraded to 0.21 and now my frontend eats CPU

Answer: In 0.21 playback profiles are introduced. You can try to chose a different profile, slim is most like the 0.20.2 playback settings. For more info see: http://www.mythtv.org/wiki/index.php/Playback_profiles

MythWeb Questions

Question: My videos/music/recordings don't work in MythWeb

Answer: Verify that the symlinks located at /var/www/mythweb/data point to the correct locations of your media. If they are broken, remove the old one and use ln to create a new one:

sudo ln -s /path/to/your/videos video


Question: I enabled the flash player but don't have any sound

Answer: You need a version of ffmpeg that has libmp3lame enabled. Verify with:

ffmpeg --verion

If your version does not have it then you can get a working version from Medibuntu UPDATE: This now works with Hardy

Themes Questions

Question: The mythtv-themes package recommends themes that are not available in Gutsy

Answer: Correct, they are not backported yet, keep an eye on this bug: https://bugs.launchpad.net/gutsy-backports/+bug/202049

Until then you can install these themes by adding this to your /etc/apt/sources.list:

deb http://ppa.launchpad.net/rhpot1991/ubuntu gutsy main
deb-src http://ppa.launchpad.net/rhpot1991/ubuntu gutsy main

Troubleshooting

Question: You can't seem to get anything to work with your capture card even though you know its well supported

Answer: First off all check that your capture card has been registered. You can test whether its is there by running lspci and checking for your card. You can also try cat /dev/video0 it will show garbage but prove that the card is actually there. If your capture card does not show up it does not mean that your capture card is dead, try reseating or reconnecting it, and try it on a different port in your computer, or on a different computer. Other tell tale signs that your card may not be working/found/connected/registered properly are errors or a absence of information under dmesg.


Question: When You run the frontend or MythTV-Setup, there is no text only a blank background.

Answer: Sometimes this occurs due to the default Theme Painter (QT). Not all video cards will properly render the fonts and images in the theme with QT. An easy way to check if this is the case for you is to close the frontend and open it from Terminal by doing the following:

mythfrontend -O ThemePainter=OpenGL

If this works you can change the default in the frontend settings:

Utilities/Settings > Settings > Appearance


Question: After my Hardy (Mythtv .21) upgrade I have blue skin people with the MythTV internal player, using ATI video card using the free drivers. What happened?!

Answer: It seems Mythtv .21 and .22 can set the Hue to "0". You can set it back (to approx 50%) and your color should come back. To do that:

.22- the setting isnt available via the OSD menu like in .21 so you need to go into totems settings and change there,

  1. open totem media player
  2. edit > preferences

  3. display tab
  4. move Hue slider to centre position.

.21-

  1. Open MythTV and select Live TV.

  2. Press M to bring up the menus

  3. Arrow down to Adjust Picture then hit right arrow, then arrow down to Hue.

  4. Press the right arrow to bring up the slider.
  5. Press the right arrow until it's at approximately 50%, or whatever looks best for your setup.

If you press M inside LiveTV and get nothing, (no slider, and it just goes back to Live TV) check to make sure you have the OSD theme installed and selected correctly under the menu in Utilities/Setup > Setup > TV Settings > Playback OSD.


Question: I have a secondary VNC desktop that runs GNOME, and the MythTV frontend automatically starts when I log in! How can I make it stop?

Answer: To understand the problem, realize that mythfrontend starts automatically when your session (GNOME, KDE, Xfce, ...) reads the ~/.config/autostart directory, finds the mythtv.desktop, file and executes the command defined within.

Short answer: If you are using a secondary GNOME desktop, you can use the following procedure to stop mythfrontend from starting when the GNOME session starts.

  1. From the menu in GNOME, select System > Preferences > Sessions

  2. Scroll down to MythTV Frontend.

  3. Uncheck the Enabled check-box.

This assumes that the primary display (which you want the MythTV frontend to start on) is still running Xfce. (How to make that happen is beyond the scope of this FAQ entry.)

Why this works: GNOME looks for a special attribute in the .desktop file; a line starting with X-GNOME-Autostart-enabled=. If this is set to false, GNOME will ignore that .desktop file and move along, while Xfce will not understand it and continue to start it.

Alternatively, you could create a second user for your GNOME desktop. (i.e. when you first set up the machine, create a 'tv' account, or similar, and add your "normal" user later.)


Question: MythTV frontend doesn't respond to the keyboard except for Alt-F4 or Ctrl-Alt-Del. The mouse works only somewhat (if I guess where the links are). Why?

Answer: There are QT incompatibilities with SCIM. Please see SCIM Binary Incompatibilities for details on how to patch your system to address this.


MythTV/FAQs (last edited 2010-06-01 23:03:03 by holto2go)