ISD Support Portal

ISD main pageUbuntu SSOSSO FAQsUbuntu PayPay FAQs

But can I still buy software with the old USC?

Yes, the old USC, available in older versions of Ubuntu, can still be used to buy software. In any case, you should consider what happens when you update (and we recommend having your system up to date!)

If you really really need to buy something, you can install old Ubuntu Software Center in 16.04, although you must know it’s unsupported.

Pay/FAQs/Old_USC_still_works (last edited 2016-06-15 12:01:08 by julia-palandri)